Package Details: osh 0.5.0-1

Git Clone URL: https://aur.archlinux.org/osh.git (read-only)
Package Base: osh
Description: A bash-compatible UNIX shell written in Python.
Upstream URL: https://www.oilshell.org/
Licenses: Apache
Submitter: timetoplatypus
Maintainer: timetoplatypus
Last Packager: timetoplatypus
Votes: 3
Popularity: 0.002143
First Submitted: 2017-10-26 03:45
Last Updated: 2018-07-21 20:59

Latest Comments

timetoplatypus commented on 2018-07-25 00:50

I'll relay the information you've provided to the project. I'm not sure what I can do in the package to fix that. If there is a solution that can be used by this package, I'll want to confirm that it's something the package should be doing and not something that can't be fixed in the actual projects installer script(s)

kseistrup commented on 2018-07-22 19:58

After a clean install of osh v0.5 with the original PKGBUILD, it seems that oil.ovm remembers the pkg directory and thinks it belongs there:

$ export OVM_VERBOSE=1
$ oil.ovm
ovm_path = ovm_path_buf (/var/local/aur/o/osh/pkg/osh/usr/bin/oil.ovm)
ovm_path: /var/local/aur/o/osh/pkg/osh/usr/bin/oil.ovm
…
$

timetoplatypus commented on 2018-02-02 23:55

Hi @ibrokemypie, thanks for reporting the issue you're encountering. I tried a clean install of OSH using this AUR package and I'm unable to reproduce the error you're experiencing. Is the message you've posted what you see when the OVM_VERBOSE environment variable is set to 1 (https://wiki.archlinux.org/index.php/OSH#Troubleshooting)? If not, can you try reinstalling with that environment variable set to 1 and posting the new error message? It may give us more insight into why the installation is failing.

I've seen this error before when someone had a custom makepkg configuration that was overriding the binary stripping option specified in the PKGBUILD file. Please ensure that you're installing without a custom configuration (https://wiki.archlinux.org/index.php/OSH#Assertion_.60sts_.21.3D_-1.27_failed)

ibrokemypie commented on 2018-02-02 09:07

Fails to run for me with

FATAL: couldn't import from app bundle '/tmp/makepkg/osh/pkg/osh/usr/bin/oil.ovm' (-1)
Stripping the oil.ovm binary may cause this error.
See https://github.com/oilshell/oil/issues/47

timetoplatypus commented on 2017-10-29 19:37

@klingt.net Can you try installing OSH the old-fashioned way with makepkg? If that works, that would narrow down the scope of the problem

timetoplatypus commented on 2017-10-29 14:44

Let's take the conversation offline, I've emailed you at alinz@klingt.net

klingt.net commented on 2017-10-29 11:51

```
$ OVM_VERBOSE=1 osh
ovm_path = ovm_path_buf (/home/alinz/.cache/pacaur/osh/pkg/osh/usr/local/bin/oil.ovm)
ovm_path: /home/alinz/.cache/pacaur/osh/pkg/osh/usr/local/bin/oil.ovm
# installing zipimport hook
import zipimport # builtin
# installed zipimport hook
osh: Modules/main.c:347: Ovm_Main: Assertion `sts != -1' failed.
zsh: abort (core dumped) OVM_VERBOSE=1 osh
```

timetoplatypus commented on 2017-10-29 11:47

@klingt.net Can you try the following? It'll give us some more information.

```
$ export OVM_VERBOSE=1
$ osh
... # <--post this output, please
```

klingt.net commented on 2017-10-29 11:03

OSH 0.1.0-1 immediately fails when I try to start it:

```
$ osh
osh: Modules/main.c:347: Ovm_Main: Assertion `sts != -1' failed.
zsh: abort (core dumped) osh
```