Package Details: osquery-git 3.3.2.r0.g5188ce528-2

Git Clone URL: https://aur.archlinux.org/osquery-git.git (read-only, click to copy)
Package Base: osquery-git
Description: SQL powered operating system instrumentation, monitoring, and analytics.
Upstream URL: https://osquery.io
Licenses: BSD
Submitter: m3thodic
Maintainer: m3thodic
Last Packager: m3thodic
Votes: 7
Popularity: 0.000000
First Submitted: 2016-07-17 08:27
Last Updated: 2019-02-28 03:43

Dependencies (47)

Required by (1)

Sources (4)

Pinned Comments

m3thodic commented on 2017-02-28 01:55

*** ATTENTION *** ATTENTION *** ATTENTION *** ATTENTION *** ATTENTION ***

You may have to rm -rf /var/osquery if osqueryd fails to start!

*** ATTENTION *** ATTENTION *** ATTENTION *** ATTENTION *** ATTENTION ***

Latest Comments

1 2 3 Next › Last »

micsnare commented on 2020-09-25 08:29

Hi,

is this an outdated version? It seems the latest available version is osquery 4.5.0 ? When I try to install this, it takes forever and throws some errors at the end of the compliation process.

I've also tried to install the osquery version that is available in the community repo (seems more recent) but it also has a few bugs and cannot load the standard configuration file. I've tried getting in touch with the maintainer a few days ago, but he doesn't respond.

anatolik commented on 2019-11-27 05:36

FYI: osquery has been aded to [community] repo.

jvreeland commented on 2019-08-05 21:16

The included patches don't seem to apply anymore

m3thodic commented on 2018-04-13 05:02

@badpixel I typically use yay or yaourt which auto-resolves dependencies from the AUR -- I dunno if makepkg has that capability.

badpixel commented on 2018-04-10 19:37

when try to build i have:

% makepkg -sriC <br> ==> Making package: osquery-git 3.2.0.r4.g7818b941-1 (Tue Apr 10 16:32:53 -03 2018) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Installing missing dependencies... error: target not found: aws-sdk-cpp-git error: target not found: benchmark error: target not found: linenoise error: target not found: beecrypt error: target not found: magic error: target not found: cpp-netlib warning: skipping target: python-jinja error: target not found: rocksdb-lite error: target not found: apt error: target not found: dpkg error: target not found: rpm-org error: target not found: librdkafka-git error: target not found: libc++ ==> ERROR: 'pacman' failed to install missing dependencies. ==> WARNING: Failed to remove installed dependencies.

m3thodic commented on 2018-03-24 18:35

@viq Hey yeah sorry it took so long, there were a few pull requests I was watching to see what the resolution was gonna be between osquery and rocksdb. I spent way too long banging my head looking for a workaround. You'd think since Facebook owns both properties each respective team would've/should've addressed this issue earlier, but anyway glad to see its working for you again!

viq commented on 2018-03-23 10:34

@m3thodic it builds now, thank you!

viq commented on 2018-03-13 07:37

@m3thodic any ideas?

viq commented on 2018-03-08 21:10

I'm seeing same error with 5.10.4-2 installed.

m3thodic commented on 2018-03-08 19:18

@viq I just pushed a small change to rocksdb-lite -- please test that and try osquery again. Sorry for the confusion, they all built for me fine (I always test builds before pushing).