Package Details: ov 0.34.1-1

Git Clone URL: https://aur.archlinux.org/ov.git (read-only, click to copy)
Package Base: ov
Description: Feature-rich terminal-based text viewer
Upstream URL: https://github.com/noborus/ov
Keywords: less more pager tail text
Licenses: MIT
Submitter: YHNdnzj
Maintainer: YHNdnzj
Last Packager: YHNdnzj
Votes: 4
Popularity: 0.57
First Submitted: 2023-01-08 13:18 (UTC)
Last Updated: 2024-04-28 08:54 (UTC)

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

m040601 commented on 2024-02-26 17:56 (UTC)

To everyone,

Don't forget to cast a vote for this tool, With enough votes this might become an official Arch package.

There are currently 3 PKGBUILD's, "ov", "ov-bin" and "ov-git".

YHNdnzj,  https://aur.archlinux.org/pkgbase/ov
kseistrup, https://aur.archlinux.org/pkgbase/ov-bin
Julian, https://aur.archlinux.org/pkgbase/ov-bin

Please collaborate to avoid unnecessary reduplicate work.

Also the author, a japanese guy, has a lot more very interesting related tools, https://noborus.github.io/index.html

There is even an interesting "ovcs",

A client/server version of Terminal Pager ov.

  • By combining terminal pager with client/server and tmux, it became the strongest SQL client

kseistrup commented on 2023-09-25 09:51 (UTC)

The ov-git package is using

-ldflags="-linkmode=external -X main.Version=$_pkgver -X main.Revision=$_pkgrev"

to set versions that will appear like this:

$ ov --version
ov version v0.32.0 rev:23db449

aosho235 commented on 2023-09-25 09:26 (UTC)

ov --version is not showing the correct value. Build misconfiguration?

$ ov --version
ov version dev rev:HEAD

$ pacman -Q ov
ov 0.32.0-1

kseistrup commented on 2023-05-06 08:16 (UTC)

Thanks for the link about glibc, that makes sense. :)

YHNdnzj commented on 2023-05-06 07:34 (UTC)

@kseistrup Thank you for the feedback. Will update to install the license.

The explicit dependency on glibc, however, is not necessary according to https://wiki.archlinux.org/title/PKGBUILD#depends

In some cases this is not necessary and may or may not be listed, for example glibc cannot be uninstalled as every system needs some C library

kseistrup commented on 2023-05-06 04:40 (UTC)

Thanks for packaging ov.

It is released under the MIT license, which should be copied to /usr/share/licenses/ov/.

I believe it is dependend on glibc.