Package Details: overgrive 3.3.7-0

Git Clone URL: https://aur.archlinux.org/overgrive.git (read-only, click to copy)
Package Base: overgrive
Description: A complete Google Drive™ desktop client solution for Linux
Upstream URL: https://www.thefanclub.co.za/overgrive
Keywords: drive google grive overgrive
Licenses: unknown
Conflicts: overgrive
Provides: overgrive
Submitter: pedro00dk
Maintainer: pedro00dk
Last Packager: pedro00dk
Votes: 5
Popularity: 0.000536
First Submitted: 2018-12-22 03:46
Last Updated: 2020-01-30 01:46

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

blackhole commented on 2019-11-25 18:42

AUR is not storing your copyrighted work.

I find this strange: normally people are happy (specially for a product with a price) that the product is available on AUR and a lot of times the maintainer is the same as the copyright owner.

If I were you I would take care of the (free) remarks and collaborate to improve your products with AUR users, many of which are working in the field of software production.

As a side note, the problem is not in this AUR package, installation of the official one produces the same results

thefanclub commented on 2019-11-25 18:20

@pedro00dk - You have no right or permission to publish our copyrighted work. Remove this AUR and Git Repo.

pedro00dk commented on 2019-11-25 17:28

Hi, thefanclub guys, as I said before, it is for my own use, but anyone is free to do so. The reality is that not many of the packages in the AUR are in fact supported by their developers. Moreover, I'm not infringing on the AUR rules in https://wiki.archlinux.org/index.php/Arch_User_Repository, as this package is merely a "build script" based on the original one, your software is not being modified by any means. And, any package is "potentially dangerous" in the AUR, the users know that and they should check the build files, as you should too. If you are willing to publish your package here, I will give you the repository ownership, otherwise, I will continue publishing the package.

thefanclub commented on 2019-11-25 17:05

We are the creators of overGrive. WE DO NOT SUPPORT this AUR version. It is an un-authorised version that could be potentially dangerous to users. Refer to the original downloads on our website www.thefanclub.co.za/overgrive. For Arch / Manjaro installation instructions see : https://www.thefanclub.co.za/overgrive/installation-instructions-arch-linux For overGrive support contact us at info@thefanclub.co.za

kmvar commented on 2019-11-17 10:52

Hej,

now i use the new 3.3.3 appimage version. so it works

pedro00dk commented on 2019-11-14 22:26

Guys, I initially just packaged this software for my own use, because I don't like the way it was done with the original package (https://www.thefanclub.co.za/overgrive , .tar.xz available).

Moreover, besides the missing libraries (GObject), I also have google API syncing and KEY ahtentication problems with the package, I even tested the original package and it has the same problems. However (for me), these are intermittent problems, sometimes after restarting, everything works again.

I am not related by any means with the developers of the original package, therefore, I cannot change the code or help with software related bugs.

If you find a bug related to the package, please clone the package and try to fix by yourself and leave here a comment about the problem and how you fixed it, then I will check that and update the package, you can help even more if you leave a pull request at https://github.com/pedro00dk/overgrive-aur . It is hard for me to replicate your bugs due to system setup and communication through comments in this post.

blackhole commented on 2019-11-14 21:52

I have now the same type of problems, even starting it with a delay.

kmvar commented on 2019-11-14 21:44

Hallo, here is my answer to gi

import gi vars(gi) {'absolute_import': _Feature((2, 5, 0, 'alpha', 1), (3, 0, 0, 'alpha', 0), 16384), 'PyGIWarning': <class 'gi.PyGIWarning'>, 'path': ['/usr/lib/python2.7/site-packages/gi'], '_versions': {}, 'name': 'gi', 'get_required_version': <function get_required_version at 0x7f8d2aa3ec50>, '_overridesdir': '/usr/lib/python2.7/site-packages/gi/overrides', 'require_version': <function require_version at 0x7f8d2aa3eb50>, 'importlib': <module 'importlib' from '/usr/lib64/python2.7/importlib/__init__.py'>, 'Repository': <type 'gi.Repository'>, 'package': 'gi', 'extend_path': <function extend_path at 0x7f8d2ae2cdd0>, '_gobject': <module 'gi._gobject' (built-in)>, 'version': '3.34.0', 'doc': None, '_gi_cairo': <module 'gi._gi_cairo' from '/usr/lib/python2.7/site-packages/gi/_gi_cairo.so'>, '_API': <capsule object "gi._API" at 0x7f8d2ae7fe40>, '_gi': <module 'gi._gi' from '/usr/lib/python2.7/site-packages/gi/_gi.so'>, 'version_info': (3, 34, 0), 'builtins': {'bytearray': <type 'bytearray'>, 'IndexError': <type 'exceptions.IndexError'>, 'all': <built-in function all>, 'help': Type help() for interactive help, or help(object) for help about object., 'vars': <built-in function vars>, 'SyntaxError': <type 'exceptions.SyntaxError'>, 'unicode': <type 'unicode'>, 'UnicodeDecodeError': <type 'exceptions.UnicodeDecodeError'>, 'memoryview': <type 'memoryview'>, 'isinstance': <built-in function isinstance>, 'copyright': Copyright (c) 2001-2019 Python Software Foundation. All Rights Reserved.

Copyright (c) 2000 BeOpen.com. All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives. All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam. All Rights Reserved., 'NameError': <type 'exceptions.NameError'>, 'BytesWarning': <type 'exceptions.BytesWarning'>, 'dict': <type 'dict'>, 'input': <built-in function input>, 'oct': <built-in function oct>, 'bin': <built-in function bin>, 'SystemExit': <type 'exceptions.SystemExit'>, 'StandardError': <type 'exceptions.StandardError'>, 'format': <built-in function format>, 'repr': <built-in function repr>, 'sorted': <built-in function sorted>, 'False': False, 'RuntimeWarning': <type 'exceptions.RuntimeWarning'>, 'list': <type 'list'>, 'iter': <built-in function iter>, 'reload': <built-in function reload>, 'Warning': <type 'exceptions.Warning'>, 'package': None, 'round': <built-in function round>, 'dir': <built-in function dir>, 'cmp': <built-in function cmp>, 'set': <type 'set'>, 'bytes': <type 'str'>, 'reduce': <built-in function reduce>, 'intern': <built-in function intern>, 'issubclass': <built-in function issubclass>, 'Ellipsis': Ellipsis, 'EOFError': <type 'exceptions.EOFError'>, 'locals': <built-in function locals>, 'BufferError': <type 'exceptions.BufferError'>, 'slice': <type 'slice'>, 'FloatingPointError': <type 'exceptions.FloatingPointError'>, 'sum': <built-in function sum>, 'getattr': <built-in function getattr>, 'abs': <built-in function abs>, 'exit': Use exit() or Ctrl-D (i.e. EOF) to exit, 'print': <built-in function print>, 'True': True, 'FutureWarning': <type 'exceptions.FutureWarning'>, 'ImportWarning': <type 'exceptions.ImportWarning'>, 'None': None, 'hash': <built-in function hash>, 'ReferenceError': <type 'exceptions.ReferenceError'>, 'len': <built-in function len>, 'credits': Thanks to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands for supporting Python development. See www.python.org for more information., 'frozenset': <type 'frozenset'>, 'name': 'builtin', 'ord': <built-in function ord>, 'super': <type 'super'>, '_': None, 'TypeError': <type 'exceptions.TypeError'>, 'license': See http://www.python.org/2.7/license.html, 'KeyboardInterrupt': <type 'exceptions.KeyboardInterrupt'>, 'UserWarning': <type 'exceptions.UserWarning'>, 'filter': <built-in function filter>, 'range': <built-in function range>, 'staticmethod': <type 'staticmethod'>, 'SystemError': <type 'exceptions.SystemError'>, 'BaseException': <type 'exceptions.BaseException'>, 'pow': <built-in function pow>, 'RuntimeError': <type 'exceptions.RuntimeError'>, 'float': <type 'float'>, 'MemoryError': <type 'exceptions.MemoryError'>, 'StopIteration': <type 'exceptions.StopIteration'>, 'globals': <built-in function globals>, 'divmod': <built-in function divmod>, 'enumerate': <type 'enumerate'>, 'apply': <built-in function apply>, 'LookupError': <type 'exceptions.LookupError'>, 'open': <built-in function open>, 'quit': Use quit() or Ctrl-D (i.e. EOF) to exit, 'basestring': <type 'basestring'>, 'UnicodeError': <type 'exceptions.UnicodeError'>, 'zip': <built-in function zip>, 'hex': <built-in function hex>, 'long': <type 'long'>, 'next': <built-in function next>, 'ImportError': <type 'exceptions.ImportError'>, 'chr': <built-in function chr>, 'xrange': <type 'xrange'>, 'type': <type 'type'>, 'doc': "Built-in functions, exceptions, and other objects.\n\nNoteworthy: None is the nil' object; Ellipsis represents...' in slices.", 'Exception': <type 'exceptions.Exception'>, 'tuple': <type 'tuple'>, 'UnicodeTranslateError': <type 'exceptions.UnicodeTranslateError'>, 'reversed': <type 'reversed'>, 'UnicodeEncodeError': <type 'exceptions.UnicodeEncodeError'>, 'IOError': <type 'exceptions.IOError'>, 'hasattr': <built-in function hasattr>, 'delattr': <built-in function delattr>, 'setattr': <built-in function setattr>, 'raw_input': <built-in function raw_input>, 'SyntaxWarning': <type 'exceptions.SyntaxWarning'>, 'compile': <built-in function compile>, 'ArithmeticError': <type 'exceptions.ArithmeticError'>, 'str': <type 'str'>, 'property': <type 'property'>, 'GeneratorExit': <type 'exceptions.GeneratorExit'>, 'int': <type 'int'>, 'import': <built-in function __import__>, 'KeyError': <type 'exceptions.KeyError'>, 'coerce': <built-in function coerce>, 'PendingDeprecationWarning': <type 'exceptions.PendingDeprecationWarning'>, 'file': <type 'file'>, 'EnvironmentError': <type 'exceptions.EnvironmentError'>, 'unichr': <built-in function unichr>, 'id': <built-in function id>, 'OSError': <type 'exceptions.OSError'>, 'DeprecationWarning': <type 'exceptions.DeprecationWarning'>, 'min': <built-in function min>, 'UnicodeWarning': <type 'exceptions.UnicodeWarning'>, 'execfile': <built-in function execfile>, 'any': <built-in function any>, 'complex': <type 'complex'>, 'bool': <type 'bool'>, 'ValueError': <type 'exceptions.ValueError'>, 'NotImplemented': NotImplemented, 'map': <built-in function map>, 'buffer': <type 'buffer'>, 'max': <built-in function max>, 'object': <type 'object'>, 'TabError': <type 'exceptions.TabError'>, 'callable': <built-in function callable>, 'ZeroDivisionError': <type 'exceptions.ZeroDivisionError'>, 'eval': <built-in function eval>, 'debug': True, 'IndentationError': <type 'exceptions.IndentationError'>, 'AssertionError': <type 'exceptions.AssertionError'>, 'classmethod': <type 'classmethod'>, 'UnboundLocalError': <type 'exceptions.UnboundLocalError'>, 'NotImplementedError': <type 'exceptions.NotImplementedError'>, 'AttributeError': <type 'exceptions.AttributeError'>, 'OverflowError': <type 'exceptions.OverflowError'>}, 'file': '/usr/lib/python2.7/site-packages/gi/init.pyc', 'sys': <module 'sys' (built-in)>, 'PyGIDeprecationWarning': <class 'gi.PyGIDeprecationWarning'>, 'types': <module 'types' from '/opt/thefanclub/overgrive/venv/lib/python2.7/types.py'>, '_error': <module 'gi._error' from '/usr/lib/python2.7/site-packages/gi/_error.pyc'>, 'require_versions': <function require_versions at 0x7f8d2aa3ebd0>, '_DummyStaticModule': <class 'gi._DummyStaticModule'>, '_compat': <module 'gi._compat' from '/usr/lib/python2.7/site-packages/gi/_compat.pyc'>, 'string_types': (<type 'basestring'>,), 'require_foreign': <function require_foreign at 0x7f8d2aa3ecd0>, 'check_version': <function check_version at 0x7f8d2ae4fcd0>, '_static_binding_error': 'When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183', 'os': <module 'os' from '/opt/thefanclub/overgrive/venv/lib/python2.7/os.py'>}

devourerOfBits80 commented on 2019-11-14 17:28

This is the worst application I've ever seen on linux (maybe because this is the only one app that I had pay for it). At least once a month, I am forced to renew the Google authorization process, because overgrive forgets the API key. Sometimes application starts during login to my account, sometimes not. Once in a while requires repating the whole "first run" configuration. Today, after update Python3 to the latest version, overgrive completely doesn't work and throws exception...

File "/opt/thefanclub/overgrive/overgrive", line 5 m Z l ^ SyntaxError: invalid syntax

Terrible, just terrible...

pedro00dk commented on 2019-11-01 21:42

python-gobject is installed and can be accessed from the system python. But you forgot to test the virtual environment interpreter inside the overgrive folder. I have to know if the venv is having some trouble to access system packages.