Package Details: oxker 0.6.2-1

Git Clone URL: https://aur.archlinux.org/oxker.git (read-only, click to copy)
Package Base: oxker
Description: A simple TUI to view & control Docker containers
Upstream URL: https://github.com/mrjackwills/oxker
Keywords: container docker tui
Licenses: MIT
Submitter: orhun
Maintainer: orhun
Last Packager: orhun
Votes: 1
Popularity: 0.035549
First Submitted: 2023-02-01 20:35 (UTC)
Last Updated: 2024-03-31 14:33 (UTC)

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

orhun commented on 2023-11-21 23:28 (UTC)

Updated the version, should be fine now.

hypnagogic commented on 2023-11-19 19:02 (UTC) (edited on 2023-11-19 19:02 (UTC) by hypnagogic)

Does not build:

error[E0283]: type annotations needed
   --> src/ui/draw_blocks.rs:448:10
    |
448 |         .constraints(splits.as_ref())
    |          ^^^^^^^^^^^        ------ type must be known at this point
    |          |
    |          cannot infer type of the type parameter `C` declared on the method `constraints`
    |
    = note: multiple `impl`s satisfying `Vec<Constraint>: AsRef<_>` found in the `alloc` crate:
            - impl<T, A> AsRef<Vec<T, A>> for Vec<T, A>
              where A: Allocator;
            - impl<T, A> AsRef<[T]> for Vec<T, A>
              where A: Allocator;
help: consider specifying the generic argument
    |
448 |         .constraints::<&T>(splits.as_ref())
    |                     ++++++

error[E0283]: type annotations needed
   --> src/ui/mod.rs:253:10
    |
253 |         .constraints(top_split.as_ref())
    |          ^^^^^^^^^^^           ------ type must be known at this point
    |          |
    |          cannot infer type of the type parameter `C` declared on the method `constraints`
    |
    = note: multiple `impl`s satisfying `Vec<Constraint>: AsRef<_>` found in the `alloc` crate:
            - impl<T, A> AsRef<Vec<T, A>> for Vec<T, A>
              where A: Allocator;
            - impl<T, A> AsRef<[T]> for Vec<T, A>
              where A: Allocator;
help: consider specifying the generic argument
    |
253 |         .constraints::<&T>(top_split.as_ref())
    |                     ++++++

For more information about this error, try `rustc --explain E0283`.
error: could not compile `oxker` (bin "oxker") due to 2 previous errors
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'oxker-git-0.3.3.r0.gf24ef07-1':
error: packages failed to build: oxker-git-0.3.3.r0.gf24ef07-1

orhun commented on 2023-10-14 08:54 (UTC)

Hey @jogai, I can't reproduce that error unfortunately.

jogai commented on 2023-10-14 08:26 (UTC)

I get Failure while downloading https://github.com/mrjackwills/oxker/archive/v0.3.2.tar.gz