Package Details: pacemaker 1.1.16-8

Git Clone URL: https://aur.archlinux.org/pacemaker.git (read-only)
Package Base: pacemaker
Description: advanced, scalable high-availability cluster resource manager
Upstream URL: https://github.com/ClusterLabs/pacemaker/
Licenses: GPL2
Submitter: bidulock
Maintainer: bidulock
Last Packager: bidulock
Votes: 2
Popularity: 0.238457
First Submitted: 2016-12-07 16:08
Last Updated: 2017-05-22 21:02

Latest Comments

glenntanner3 commented on 2016-08-10 21:38

Switched to GIT version and got it installed.
------------------
Forget what i said below. There is a problem with libqb, had to use the GIT version. Still unable to install do to some compile error.

cc1: all warnings being treated as errors
make[2]: *** [Makefile:643: ipc.lo] Error 1
make[2]: Leaving directory '/home/admin/pacemaker-stable/src/pacemaker-Pacemaker-1.1.14/lib/common'
make[1]: *** [Makefile:560: all-recursive] Error 1
make[1]: Leaving directory '/home/admin/pacemaker-stable/src/pacemaker-Pacemaker-1.1.14/lib'
make: *** [Makefile:1207: core] Error 1
==> ERROR: A failure occurred in build().
Aborting...
------------------------------------------------------------
Any suggestions for getting this installed? I keep getting:
configure: error: in `/home/admin/pacemaker-stable/src/pacemaker-Pacemaker-1.1.14':
configure: error: Unable to support Corosync: corosync/libqb IPC libraries not found by pkg_config

$ pacman -Qs libqb
local/libqb 1.0-1
$ pacman -Qs coro
local/corosync 2.3.5-1

Thermi commented on 2016-06-03 16:48

@bastelfreak: I moved libxslt from makedepends to depends now. Thank you for your comment.

bastelfreak commented on 2016-05-20 16:34

libxslt is a dependency, not a make depend:

# crmadmin
crmadmin: error while loading shared libraries: libxslt.so.1: cannot open shared object file: No such file or directory

Thermi commented on 2016-03-29 22:17

I bumped to 1.1.14 thanks to bastelfreak's work.

bastelfreak commented on 2016-03-28 21:58

I updated the gist, I now export the modified CPPFLAGS and the workaround isn't needed anymore.

bastelfreak commented on 2016-03-28 20:27

Hi,
I made some updates on the PKGBUILD: https://gist.github.com/bastelfreak/203375f148f0493312cf

* Bump Version to latest 1.1.14
* Update makedepends
* Add depends
* fix license
* add --libexecdir=/usr/lib to fulfill Arch requirements
* add --enable-upstart=no, we don't use that

libqb maybe is a depend and not only makedepend, I'm not sure here. Until my pacemaker issues is resolved (http://bugs.clusterlabs.org/show_bug.cgi?id=5274) we also need to add --enable-fatal-warnings=no to the ./configure. The pkgbuild is tested against libqb 0.17.2 and works.