Package Details: package-query 1.12-1

Git Clone URL: https://aur.archlinux.org/package-query.git (read-only, click to copy)
Package Base: package-query
Description: Query ALPM and AUR
Upstream URL: https://github.com/archlinuxfr/package-query/
Licenses: GPL
Submitter: tuxce
Maintainer: archlinuxfr (Skunnyk, f2404)
Last Packager: Skunnyk
Votes: 1146
Popularity: 0.24
First Submitted: 2010-03-24 23:18 (UTC)
Last Updated: 2021-06-02 15:03 (UTC)

Latest Comments

1 2 3 4 5 6 .. 51 Next › Last »

HalJordan commented on 2024-05-20 07:18 (UTC)

package-query: error while loading shared libraries: libalpm.so.13: cannot open shared object file: No such file or directory

Ralf_Mardorf commented on 2024-03-21 22:30 (UTC) (edited on 2024-03-21 22:40 (UTC) by Ralf_Mardorf)

Sorry, something went wrong on my side. I must have changed into the wrong directory and built package-query without -git in the name, but from git and not from the git tar ball. IOW it wasn't your PKGBUILD, but some old local PKGBUILD, while it was intended to build from your PKGBUILD. Btw. without an aur helper involved.

I'm in favour of the aur in sync with the users. It would be nice, if you would bump the release to pkgrel=2, so users who prefer to be in sync with the aur package releases don't need to use pkgrel=1.1. At least I dislike to rebuild a package using the same pkgrel.

daniel_shub commented on 2024-03-21 21:15 (UTC)

@Ralf this is not a VCS package. It pulls v1.12 (the latest release) from github. If you want the -git package, you can get it at https://aur.archlinux.org/packages/package-query-git

As for bumping the pkgrel to rebuild, that is an issue with whatever AUR helper you are using and not an issue with this package. While maintainers can choose to update the package, they are not required: https://bbs.archlinux.org/viewtopic.php?id=285639

semeion commented on 2024-03-17 19:00 (UTC) (edited on 2024-03-21 20:47 (UTC) by semeion)

I can't compile on Archlinux-ARM using ARMv7 (raspberry pi 3) anymore:


==> Making package: package-query 1.12-1 (dom 17 mar 2024 15:53:09)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found package-query-1.12.tar.gz
==> Validating source files with md5sums...
    package-query-1.12.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting package-query-1.12.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a race-free mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/mnemonic/.aur/package-query/package-query/src/package-query-1.12':
configure: error: C compiler cannot create executables
See `config.log' for more details
==> ERROR: A failure occurred in build().
    Aborting...

EDIT/UPDATING: Talking on IRC (#archlinuxarm channel) the moabeat told me a nice solution:

"14:47:24 moabeat Ah, it's in the comment. You could try look at your /etc/makepkg.conf. If it contains the -mno-omit-leaf-frame-pointer in the CFLAGS variable, you might need to remove that. It seems to be unsupported on armv7h and it got introduced by mainline Arch recently."

It solved my issue!

Ralf_Mardorf commented on 2024-03-16 12:32 (UTC)

Hi, it's needed to rebuild the package against libalpm.so.14.0.0. I would like to ask you to bump the pkgrel, but actually you need to rename the package to package-query-git or you need to pull a specific branch or commit. Regards, Ralf

zaidan commented on 2022-07-13 08:17 (UTC)

Please remove the version from yajl dependency to support installing yajl-edenhill-git and yajl-git. Otherwise this package is incompatible with other packages - e.g: https://aur.archlinux.org/packages/kafkacat-avro-git

To resolve such issues, the best solution is to remove the version from the dependency: https://bbs.archlinux.org/viewtopic.php?pid=1715065#p1715065

depends=('pacman>=6.0' 'yajl')

maderios commented on 2022-02-25 11:59 (UTC)

@piussj2 "yaourt" is not an arch or aur package. It was an arch "aur helper" in the past, this not more the case.

piussj2 commented on 2022-02-24 02:34 (UTC)

Now I get:

/usr/lib/yaourt/util.sh, linha 190: 57058 Falha de segmentação (imagem do núcleo gravada)package-query "${PKGQUERY_C_ARG[@]}" "$@"

I install this version and git version is the same...

piussj2 commented on 2021-06-03 03:54 (UTC)

Thanks! =)

f2404 commented on 2021-06-02 15:06 (UTC)

The PR has been merged, version 1.12 has been released. Thanks!