Package Details: package-query 1.12-1

Git Clone URL: https://aur.archlinux.org/package-query.git (read-only, click to copy)
Package Base: package-query
Description: Query ALPM and AUR
Upstream URL: https://github.com/archlinuxfr/package-query/
Licenses: GPL
Submitter: tuxce
Maintainer: archlinuxfr (Skunnyk, f2404)
Last Packager: Skunnyk
Votes: 1160
Popularity: 0.85
First Submitted: 2010-03-24 23:18
Last Updated: 2021-06-02 15:03

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

mozo commented on 2018-05-29 18:29

You are welcome :)

maxxcan commented on 2018-05-29 17:46

@mozo The same error for mi without octopi or pamac-aur. But I fixed with your link. Thank you

cogwerkz commented on 2018-05-29 17:05

@mozo you probably have to rebuild octopi. Manually. But that should really be discussed on the octopi page, and only there, as all issues with package-query was fixed in today's update.

mozo commented on 2018-05-29 17:00

I just saying that octopi is broken too.

f2404 commented on 2018-05-29 16:33

@mozo What you need to do is just to manually rebuild package-query and install it. I understand that yaourt is working after you've done that, correct?

How is octopi (and what's that?) related here?

mozo commented on 2018-05-29 16:28

Same error here. I followed these howto: https://arcolinux.com/fixing-the-error-message-package-query-error-while-loading-shared-libraries-libalpm-so-10/

Now "package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file" error is gone at "yaourt -Syau" but is still here when I try to open octopi. It stoped working completely.

damico commented on 2018-05-29 11:52

Hi @cogwerkz I just upgraded and started to show this error: "package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory No database errors have been found!"

I manually clone and compiled package-query and now it's fixed - git clone https://aur.archlinux.org/package-query.git - cd package-query/ - makepkg -si

cogwerkz commented on 2018-05-29 08:52

@itsme have you updated it today before you posted this report?

Because that error which is related to libalpm changes in pacman 5.1.0 has already been fixed. It's even listed in the changelog here and in the comments. Right below yours.

itsme commented on 2018-05-29 08:29

package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory ==> ERROR: unable to update package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory No database errors have been found!

f2404 commented on 2018-05-29 00:08

@emvigo: Done, thanks!