Package Details: packettracer 7.2.1-1

Git Clone URL: https://aur.archlinux.org/packettracer.git (read-only)
Package Base: packettracer
Description: Network design and emulation software for Cisco's Networking Academy instructors and students.
Upstream URL: http://www.netacad.com/about-networking-academy/packet-tracer
Licenses: custom
Submitter: Vamp898
Maintainer: runnytu
Last Packager: runnytu
Votes: 100
Popularity: 0.68
First Submitted: 2009-02-18 07:52
Last Updated: 2019-03-12 20:28

Pinned Comments

runnytu commented on 2019-11-04 05:50

New versions of packettracer are autoinstallables via run file, download it from netacad webpage and run it.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

runnytu commented on 2018-01-25 19:36

@z3ntu, It was already done, it's in the 80th line of the PKGBUILD.

z3ntu commented on 2018-01-25 13:54

In the .desktop file the icon path has to be changed to /usr/share/packettracer/art/app.png

z3ntu commented on 2018-01-16 09:42

@presianbg: I had probably the same error, uninstalling jdk from the AUR resolved the error..

Just-Punk commented on 2017-11-15 12:02

OMG ) This is wine-version in result I see

runnytu commented on 2017-11-11 14:39

@hoobastank, for me it's working ok, I'm only in X64, maybe multilib it's causing issues, the error with the certificate it's not relevating.

hoobastank commented on 2017-11-03 07:11

@runnytu

My system is already uptodate.

------------------- CLI log -------------------
sudo pacman -Ss SSL | grep installed
core/openssl 1.1.0.f-2 [installed]
core/openssl-1.0 1.0.2.l-1 [installed]
multilib/lib32-openssl 1:1.1.0.f-1.1 [installed]
multilib/lib32-openssl-1.0 1.0.2.l-2 [installed]
------------------- CLI log -------------------

On the other hand if I run packet tracer from CLI in debug mode, logs give some hint like that below. As you see below it seems to be related to SSL problem, but I'm not sure. On the other hand an URL which is seen on the debug log gives "insecure connection error" on the browser. (https://analytics01.cisco.netacad.com/)

I've this problem both on PT 7.1 and 7.0 version but same versions on Windows works without any error.

------------------- error on the browser -------------------
analytics01.cisco.netacad.com uses an invalid security certificate.
The certificate is only valid for the following names: *.netacad.com, netacad.com The > certificate expired on July 7, 2017, 2:59 AM. The current time is November 1, 2017, 1:21 PM.
Error code: SSL_ERROR_BAD_CERT_DOMAIN

------------------- error on the browser -------------------


------------------- log from PT 7.1 -------------------
Debug: reply QNetworkReplyHttpImpl(0x47e8860)
Debug: errors ("The host name did not match any of the valid hosts for this certificate", "The certificate has expired")
Debug: cert Organization ()
Debug: cert CommonName ("*.netacad.com")
Debug: cert LocalityName ()
Debug: cert OrganizationalUnitName ("PositiveSSL Wildcard", "Domain Control Validated")
Debug: cert CountryName ()
Debug: cert StateOrProvinceName ()
Debug: cert DistinguishedNameQualifier ()
Debug: cert SerialNumber ()
Debug: cert EmailAddress ()
...
...
...
Debug: CAnalyticsTracker::finished_request() - error - url: "https://analytics01.cisco.netacad.com/Service02/analytics/v1/heartbeat7/%7B8319ed4e-2b4d-4a5c-b579-37d64e4b7a98%7D/linux/ptdesktop/7.1.0.0222/app%5Etrack%5Einit%5E0/"
Debug: CAnalyticsTracker::finished_request() - error - data: ""
Debug: CAnalyticsTracker::finished_request() - error - code: 203
Debug: CAnalyticsTracker::finished_request() - error - reply headers: ("Date", "Server", "Content-Length", "Connection")
Debug: CAnalyticsTracker::finished_request() - error - reply: ""
Debug: "WARN - error:203,url:https://analytics01.cisco.netacad.com/Service02/analytics/v1/heartbeat7/%7B8319ed4e-2b4d-4a5c-b579-37d64e4b7a98%7D/linux/ptdesktop/7.1.0.0222/app%5Etrack%5Einit%5E0/,data:"
...
...
...
Warning: QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to
------------------- log from PT 7.1 -------------------

runnytu commented on 2017-11-03 00:07

@presianbg & @hoobastank, it seems to be a heartbeat vulnerability check fail, try to update all ssl packages to latest version to assurance that heartbeat vulnerability is solved.

hoobastank commented on 2017-11-01 08:58

I've successfully installed as @runnytu said, but user login screen isn't loading. There is only a white screen. It is same both on 7.1 and 7.0 version. It works without any problem with guest user but you know it's limited. Is there any solution?

presianbg commented on 2017-10-31 18:59

Hi, I'm having troubles with running latest packettracer:


*** Error in `/usr/share/packettracer/bin/PacketTracer7': free(): invalid pointer: 0x00007f5adfffe3c0 ***
Aborted (core dumped)


Update: uninstalling jre(aur) resolved this.

erkexzcx commented on 2017-10-03 08:58

# Help Files that are optinal uncomment to include them (55 MB)
# cp -r ./help/* "${pkgdir}/usr/share/packettracer/help"

This is not up to you to decide what part of package to exclude. All you have to do is maintain an AUR script which installs whole application just like developer designed it. It's developer responsibility to exclude it if it wants so, not yours.