Package Details: pacman-git 6.0.0alpha1.r86.gc294b7cb-1

Git Clone URL: https://aur.archlinux.org/pacman-git.git (read-only, click to copy)
Package Base: pacman-git
Description: A library-based package manager with dependency support
Upstream URL: https://www.archlinux.org/pacman/
Licenses: GPL
Conflicts: pacman
Provides: pacman=6.0.0alpha1
Submitter: None
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 27
Popularity: 1.18
First Submitted: 2009-09-07 17:32
Last Updated: 2021-04-08 00:19

Required by (189)

Sources (5)

Pinned Comments

eschwartz commented on 2019-05-31 04:58

For convenience I provide an unofficial repository containing prebuilt versions of this and a number of other AUR packages. See https://wiki.archlinux.org/index.php/Unofficial_user_repositories#eschwartz

The packages are signed using my [community] packaging key and are therefore trustworthy. :)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

maggie commented on 2013-03-31 11:01

@falconindy Can you please make this package build latest git rather than point to a static tarball? I do not know enough about it to do it myself. Your commands are different from standard git packages. Thank you.

RunningDroid commented on 2013-03-20 17:20

@josephgbr You should use one of the packages here to add the features you need to install pacman-git: http://allanmcrae.com/2013/03/pacman-4-1-0rc1/

@falconindy Can you add fakechroot as a checkdepends, enough tests fail without it that makepkg --check fails.

rafaelff commented on 2013-03-10 06:11

Can someone please point me out how to get over the current lack of GIT download agent for this package?

I'm translating pacman and, therefore, willing to test the translations. I'm not normally a user of this package, so I'm not following changes here, but I understand and read about changes in download methods, and now it fails to build as expected. Please help me on this subject?

AlD commented on 2013-02-05 09:47

If you depend on http access:
source=('git+http://projects.archlinux.org/git/pacman.git')

falconindy commented on 2012-12-02 13:55

Bleh, yeah. Fixed. Didn't want to clobber my existing clone when testing.

eworm commented on 2012-12-02 13:48

The repo is cloned to "pman", not "pacman". This is a typo, no?

falconindy commented on 2012-12-02 03:49

You're welcome. Please don't mark this out of date because the provides array is "wrong".

luolimao commented on 2012-12-02 03:47

Thanks for the update

luolimao commented on 2012-12-02 03:22

Please, as RetroX mentions, do add the version to the provides array

luolimao commented on 2012-11-25 20:29

How do you install this package? makepkg throws me an error about git URLs not being handled. I tried
DLAGENTS=('git::/usr/bin/git clone %u %o')
combined with --skipinteg, but then it said that for the cd command, that the 'pacman' directory was nonexistent.
DLAGENTS=('git::/usr/bin/git clone %u pacman')
didn't work either.