Package Details: pacmanager-bin 4.5.5.7-2

Git Clone URL: https://aur.archlinux.org/pacmanager-bin.git (read-only)
Package Base: pacmanager-bin
Description: Perl Auto Connector PAC Manager
Upstream URL: https://sites.google.com/site/davidtv/
Licenses: GPL3
Submitter: beingluca
Maintainer: beingluca
Last Packager: beingluca
Votes: 14
Popularity: 0.871415
First Submitted: 2015-10-04 04:11
Last Updated: 2017-06-09 05:59

Pinned Comments

beingluca commented on 2016-06-15 02:34

Original deb package is hosted on Google Drive by the author of pacmanager.

PLEASE recompile ALL perl dependencies when upgrading perl:
perl-crypt-blowfish
perl-crypt-cbc
perl-crypt-rijndael
perl-expect
perl-gnome2-gconf
perl-gnome2-vte
perl-gtk2-ex-simple-list
perl-gtk2-unique
perl-io-stty
perl-io-tty
perl-net-arp
perl-socket6
perl-yaml
uuid

Otherwise pac will not start.

Latest Comments

1 2 3 4 Next › Last »

figue commented on 2018-09-05 23:24

@ejosvp something like this??

yaourt -S --asdeps uuid perl-gnome2-gconf glade-perl perl-crypt-blowfish perl-gnome2-vte perl-expect perl-crypt-rijndael perl-gtk2-ex-simple-list perl-io-stty perl-io-tty perl-net-arp  perl-yaml perl-crypt-cbc perl-gtk2-unique perl-socket6

ejosvp commented on 2018-09-05 22:33

How can I recompile perl dependencies? I reinstalled perl-data-uuid and perl-uuid, but I'm still getting this error:

Can't locate OSSP/uuid.pm in @INC (you may need to install the OSSP::uuid module) (@INC contains: /opt/pac/lib /opt/pac/lib/ex /opt/pac/lib/edit /usr/lib/perl5/5.28/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at /opt/pac/lib/PACMain.pm line 39. BEGIN failed--compilation aborted at /opt/pac/lib/PACMain.pm line 39. Compilation failed in require at /usr/bin/pac line 62. BEGIN failed--compilation aborted at /usr/bin/pac line 62.

josemslopes commented on 2018-09-05 13:27

I am getting this error when execute pac.

Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine", at /opt/pac/lib/edit/PACMethod.pm line 45.

I fixed with installation of gtk-engine-murrine.

Can you add as dependency?

beingluca commented on 2017-07-27 10:36

@rethus
I tried a fresh install (without any cached package) and it went smooth, apart from a few 503/504 with a couple of archives hosted on cpan.org.

$ pacman -Qo /usr/lib/perl5/site_perl/OSSP/uuid.pm
/usr/lib/perl5/site_perl/OSSP/uuid.pm is owned by uuid 1.6.2-14

I suggest you reinstall uuid from aur and give it another try.

rethus commented on 2017-07-27 09:38

@beingluca: could you give a command, how to recompile "ALL perl dependencies"?

I got this error-message:
Can't locate OSSP/uuid.pm in @INC (you may need to install the OSSP::uuid module) (@INC contains: /opt/pac/lib /opt/pac/lib/ex /opt/pac/lib/edit /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at /opt/pac/lib/PACMain.pm line 39.
BEGIN failed--compilation aborted at /opt/pac/lib/PACMain.pm line 39.
Compilation failed in require at /usr/bin/pac line 62.
BEGIN failed--compilation aborted at /usr/bin/pac line 62.

Even if package for uuid is installed:
pacman -Qm |grep uuid
perl-data-uuid 1.221-1
perl-uuid 0.05-1
perl-uuid-tiny 1.04-1
uuid 1.6.2-14

beingluca commented on 2017-06-27 06:13

@Some1 please recompile ALL perl dependencies. The pinned comment is now up to date.

Some1 commented on 2017-06-27 05:46

I got:

$ pac
ARP.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)

(notice the twisted keys, instead of comment from dare023 @ 2016-07-04 10:21)
I already recompiled all perl packages in the pinned thread.
What could i do to get pac running again?

*edit:
rebuilded now ALL pearl packages - worked, thanks!

beingluca commented on 2017-06-09 06:07

Latest perl upgrade (v 5.26) gave me some headaches. For those using this package in a long time:
gconf-perl is now replaced by perl-gnome2-gconf, you may need a forced install.

$ sudo pacman -Rdd gconf-perl && yaourt -S perl-gnome2-gconf

Remember to recompile perl packages (see pinned comment)!

figue commented on 2016-08-04 21:57

I've created pacmanager-git package in AUR, build from main developer's master branch in github. There are included several patches, such as new xfreerdp commands (thanks roepi to notice the pull request), plus a couple of patches more to fix little bugs I've found, like embed xfreerdp windows.

Feel free to test.

roepi commented on 2016-08-03 08:14

With regards to download from Google Drive use this URL schema (wget 'https://drive.google.com/uc?export=download&id=FILEID') and replace FILEID with the actual file ID. See (https://unix.stackexchange.com/questions/136371/how-to-download-a-folder-from-google-drive-using-terminal/148674#148674) for more information.
For this concrete package use
source=("pac-${pkgver}-all.deb::https://drive.google.com/uc?export=download&id=0B4jA_htRqlMbY2p6aThBUWxjOTg")
in the PKGBUILD for the pac-4.5.5.7-all.deb file.