Package Details: pacpl 6.1.1-2

Git Clone URL: https://aur.archlinux.org/pacpl.git (read-only, click to copy)
Package Base: pacpl
Description: Convert multiple audio types from one format to another.
Upstream URL: http://pacpl.sourceforge.net/
Licenses: GPL
Submitter: jonarnold
Maintainer: mgd
Last Packager: mgd
Votes: 1
Popularity: 0.002671
First Submitted: 2017-04-08 23:42
Last Updated: 2019-08-18 22:51

Latest Comments

hueypokerbrainz commented on 2020-04-09 17:21

In order to install this package I had to:

  • change PKGBUILD

    line 46:

    WAS:

    cp -p ChangeLog.txt ChangeLog
    

    IS:

    cp -p ChangeLog ChangeLog.txt
    

Don't know why this step is even necessary, but that's a different issue.

  • downgrade my automake from 1.16.2-1 to 1.15-2

The 1-15 version is somehow embedded in aclocal.m4:

# AM_AUTOMAKE_VERSION(VERSION)
# ----------------------------
# Automake X.Y traces this macro to ensure aclocal.m4 has been
# generated from the m4 files accompanying Automake X.Y.
# (This private macro should not be called outside this file.)
AC_DEFUN([AM_AUTOMAKE_VERSION],
[am__api_version='1.15'
dnl Some users find AM_AUTOMAKE_VERSION and mistake it for a way to
dnl require some minimum version.  Point them to the right macro.
m4_if([$1], [1.15], [],
      [AC_FATAL([Do not call $0, use AM_INIT_AUTOMAKE([$1]).])])dnl
])

and I didn't know how to fix it.

  • to run this package, I had to install perl-string-shellquote

Thanks!

kinoe commented on 2018-11-01 09:23

til now i can't use pacpl as a servicemenue/ rightclick in dolphin see my previous comment anyone else experiencing this?

jonarnold commented on 2018-09-09 21:45

@kinoe - Sorry, I don't have time to look at this right now. I will see if someone else can maintain the package.

kinoe commented on 2018-08-29 08:01

installation successful but had to move /usr/etc/pacpl to /etc/pacpl manually and softlink the pacpl.desktop to kservices5

successfully ran 'pacpl xyz.mp3 --to ogg' via commandline

but via Dolphin servicemenu (rightclicking) i got this error in journalctl:

kwin_x11[756]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 15671, resource id: 75497590, major code: 18 (ChangeProperty), minor code: 0

kwin_x11[756]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 15734, resource id: 75497591, major code: 18 (ChangeProperty), minor code: 0

So it seems that it's got to do with x11 ?!

no other servicemenu here produces this error, installed Perl version 5.28.0-1

excerpt of pacpl.conf:

KDIALOG options for Dolphin & Konqueror

Output directory

1: prompt

0: use input file directory KDE_DIR = 1

Encoder options

1: prompt

0: use default encoder options

KDE_OPTS = 1

Pietro_Pizzi commented on 2017-10-17 21:11

THX! It works now.

jonarnold commented on 2017-09-26 20:25

@Pietro_Pizzi It looks like there are some outages at SourceForge. You can check their Twitter for status: https://twitter.com/sfnet_ops

Pietro_Pizzi commented on 2017-09-26 20:17

Is this a temporary problem or is something wrong?

==> Retrieving sources...
-> Cloning code git repo...
Cloning into bare repository '/tmp/yaourt-tmp-pietro/aur-pacpl/code'...
fatal: read error: Connection reset by peer
==> ERROR: Failure while downloading code git repo
Aborting...

gigante commented on 2017-08-01 20:18

Maybe the following package (dependency) is missing:
https://aur.archlinux.org/packages/perl-module-install/