Package Details: pacsync-hg 8-3

Git Clone URL: (read-only)
Package Base: pacsync-hg
Description: A pacman frontend which manages packages based on a holistic view of the system
Upstream URL:
Licenses: custom
Submitter: zerathidune
Maintainer: zerathidune
Last Packager: zerathidune
Votes: 7
Popularity: 0.000036
First Submitted: 2010-11-25 23:29
Last Updated: 2015-06-09 15:12

Dependencies (0)

Required by (0)

Sources (1)

Latest Comments

zerathidune commented on 2014-03-19 07:32

I cleaned up the PKGBUILD a bit:

* The url link had been dead for a long time; it now points to the bitbucket page.
* The package function had a number of commands superfluously ending in || return 1. This used to be standard practice, but is no longer done.

I also bumped the pkgrel. There are no functional changes; The files contained by the generated package are the same.

zerathidune commented on 2013-06-01 20:58

Thanks for the heads up. Fixed.

Unia commented on 2013-06-01 11:07

The pacsync script should be placed in /usr/bin, not /usr/sbin. The upcoming filesystem update requires this[1].

Just change the path in the PKGBUILD and everything should work:

install -Dm755 pacsync $pkgdir/usr/bin/pacsync || return 1


zerathidune commented on 2012-08-25 19:34

Updated, fixed a bug. Thanks to Jente for reporting it.

zerathidune commented on 2012-04-02 04:32

Minor update; mostly just a small change to the man page. I've also moved to bitbucket.

zerathidune commented on 2012-02-12 18:16

A few code changes - most importantly, you can now generate a set dynamicall; if a .set or .mask file is executable, instead of reading the contents of the set from the file, it will be run and it's output will be used.

This is handy if you want to use the same config on different machines, with slight variations.

zerathidune commented on 2011-06-02 02:10

Just updated - no actual code changes, but needed to fix the PKGBUILD since I'd moved the location of my hg repos. mercurial is also no longer a build dependendcy; the hg web interface can serve tarballs, so I"m using that.

zerathidune commented on 2011-01-04 03:55

Updated with a small fix; pacsync now correctly updates outdated packages when there are no new packages to add - previously without packages to add pacsync would incorrectly skip this step.