Package Details: pagmo-git r3632.f580121d-1

Git Clone URL: https://aur.archlinux.org/pagmo-git.git (read-only)
Package Base: pagmo-git
Description: Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (git version)
Upstream URL: https://github.com/esa/pagmo2
Keywords: optimization
Licenses: GPLv3
Conflicts: pagmo
Provides: pagmo
Submitter: bchretien
Maintainer: acxz
Last Packager: acxz
Votes: 2
Popularity: 0.696532
First Submitted: 2014-03-20 17:54
Last Updated: 2019-05-22 00:27

Dependencies (6)

Required by (1)

  • libdart (requires pagmo) (optional)

Sources (1)

Latest Comments

acxz commented on 2019-05-22 00:28

Updated to work as expected.

acxz commented on 2019-05-11 02:51

This package fails building for me. I have submitted an orphan request since I do not know how to get into contact with the maintainer.

fagotto commented on 2016-03-27 10:02

I think that the broken optional dependency to ipopt should be replaced with coin-or-ipopt (coin-or-ipopt-svn) since they provide the same package that was once provided by ipopt

fagotto commented on 2015-10-27 19:19

Since we have switched to python3.5 I had to replace python3.4 with python3.5 in
-D PYTHON_LIBRARY=/usr/lib/python3.4
-D PYTHON_INCLUDE_DIR=/usr/include/python3.4m

bchretien commented on 2014-10-23 11:56

@lothar_m: this looks like an upstream issue (I would expect it to be -pthread, not -lpthread). If you can confirm that, you can report it on GitHub: https://github.com/esa/pagmo

lothar_m commented on 2014-10-23 11:44

Same problem here. i get the following error: "/usr/bin/ls cannot find -lpthreads"
It seems to have something to do with the makefile supplied.

valandil commented on 2014-08-26 15:20

This does not build. This new PKGBUILD does. Please update.
https://gist.github.com/valandil/d0601d0a5952f7e3db9b#file-pkgbuild