Package Details: pak 1.0-2

Git Clone URL: https://aur.archlinux.org/pak.git (read-only)
Package Base: pak
Description: A package manager wrapper written in swift designed to unify different package managers
Upstream URL: https://gitlab.com/moussaelianarsen/pak
Licenses: GPL3
Provides: pak
Replaces: pak-pacman, pak-yay
Submitter: Arsen6331
Maintainer: Arsen6331
Last Packager: Arsen6331
Votes: 1
Popularity: 0.327311
First Submitted: 2019-07-16 03:17
Last Updated: 2019-07-17 15:45

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

yochananmarqos commented on 2019-10-22 17:24

Your packages should have the -git suffix. See VCS package guidelines.

None of the binaries will run without Swift installed:

pak: error while loading shared libraries: libswiftGlibc.so: cannot open shared object file: No such file or directory

Since your pak-config packages depend on swift-language, there's no need to include it here.

Include both provides() and conflicts() arrays.

No need to use mkdir as install -D creates the leading directory.

Your pak-config packages are installing the default pak.cfg instead of the corresponding one from the plugins directory.

pkgname=pak-git
pkgver=r76.672a6de
pkgrel=1
pkgdesc="A package manager wrapper written in swift designed to unify different package managers"
arch=('x86_64')
url="https://gitlab.com/moussaelianarsen/pak"
license=('GPL3')
depends=('pak-config')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://gitlab.com/moussaelianarsen/pak.git')
sha256sums=('SKIP')

pkgver() {
    cd "$srcdir/${pkgname%-git}"
    printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

build() {
    cd "$srcdir/${pkgname%-git}"
    swiftc pak.swift
}

package() {
    cd "$srcdir/${pkgname%-git}"
    install -Dm755 "${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
}