Package Details: palemoon-gtk3-bin 1:33.0.0-1

Git Clone URL: https://aur.archlinux.org/palemoon-gtk3-bin.git (read-only, click to copy)
Package Base: palemoon-gtk3-bin
Description: Open source web browser based on Firefox focusing on efficiency.
Upstream URL: https://linux.palemoon.org/
Licenses: GPL, MPL, LGPL
Conflicts: palemoon
Provides: palemoon
Submitter: micwoj92
Maintainer: micwoj92
Last Packager: micwoj92
Votes: 6
Popularity: 0.080603
First Submitted: 2021-06-18 15:15 (UTC)
Last Updated: 2024-02-05 17:39 (UTC)

Pinned Comments

micwoj92 commented on 2021-06-18 15:16 (UTC)

Please do not delete this package, it is different than https://aur.archlinux.org/packages/palemoon-bin.

Latest Comments

1 2 3 Next › Last »

ajacocks commented on 2023-09-23 03:31 (UTC)

No, there are no other current ways to get the alternative architectures, at the moment. Unless the other maintainer wants to completely redo the package. There are lots of other packages that have many different packages for them, for slightly different builds.

Don’t forget that archlinuxarm and archlinux32 also use the AUR. Yes, they are not officially supported, but we should still consider their needs where it doesn’t negatively impact x86_64.

yochananmarqos commented on 2023-09-22 19:32 (UTC)

@micwoj92: Ah, I failed to notice earlier that the binaries here were from openSUSE.

You're right about additional architectures not being officially supported, however it is allowed to provide additional architectures besides x86_64. However, packages that only provide unsupported architectures is not permissible.

Either way, it's still a duplicate package and I've submitted a merge request.

micwoj92 commented on 2023-09-22 19:23 (UTC)

@yochananmarqos this is impossible as upstream provides only x86_64 binaries. https://www.palemoon.org/download.shtml

@ajacocks I could argue that this argument is irrelevant as "the Arch Linux" is only available as x86_64 distro, so the additional architectures make no sense.

yochananmarqos commented on 2023-09-22 18:26 (UTC)

@ajacocks: Then ask the maintainer to add additional architectures instead of creating a duplicate package.

ajacocks commented on 2023-09-22 17:47 (UTC)

Just to base on the .deb packages, allowing for more architectures

micwoj92 commented on 2023-09-22 17:10 (UTC)

Any reason for this package over palemoon-gtk3-bin?

ndvio commented on 2022-12-21 05:37 (UTC)

Error:

url: (22) The requested URL returned error: 404

The error occurs because the URL is incorrect, it refers to an old version 31.4.1, which is already in the archive: https://archive.palemoon.org/palemoon/31.x/31.4.1/palemoon-31.4.1.linux-x86_64-gtk3.tar.xz

Current version at the moment: 31.4.2: https://linux.palemoon.org/datastore/release/palemoon-31.4.2.linux-x86_64-gtk3.tar.xz

micwoj92 commented on 2022-11-02 14:14 (UTC)

If palemoon-gtk3 conflicts with palemoon and palemoon-gtk3-bin also conflicts with palemoon then these 2 naturally conflict with each other. It is only needed to specify the "default" package, it being palemoon in this case.

RubenKelevra commented on 2022-11-02 14:13 (UTC)

I think your other package 'palemoon-gtk' should be marked as conflicting. And what about the 'palemoon-bin' package?

micwoj92 commented on 2022-11-02 14:12 (UTC)

For historical reasons. gtk3 versions are officially provided only since version 29.