Package Details: palemoon 28.6.0.1-1

Git Clone URL: https://aur.archlinux.org/palemoon.git (read-only)
Package Base: palemoon
Description: Open source web browser based on Firefox focusing on efficiency.
Upstream URL: https://www.palemoon.org/
Keywords: browser goanna web
Licenses: GPL, MPL, LGPL
Submitter: artiom
Maintainer: WorMzy
Last Packager: WorMzy
Votes: 121
Popularity: 1.698286
First Submitted: 2014-06-05 10:54
Last Updated: 2019-07-04 22:45

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

kzoli429 commented on 2017-08-30 14:27

Although enough memory/disk space seem to be available, building failed with:
"
...
{standard input}: Assembler messages:
2:14.21 {standard input}: Fatal error: can't close Unified_cpp_js_src4.o: No space left on device
2:14.23 In the directory /tmp/makepkg/palemoon/src/pmbuild/js/src
2:14.23 The following command failed to execute properly:
2:14.23 g++-5 -o Unified_cpp_js_src4.o -c -I../../dist/system_wrappers -include /tmp/makepkg/palemoon/src/Pale-Moon/config/gcc_hidden.h -DFFI_BUILDING -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX="lib" -DDLL_SUFFIX=".so" -DMOZ_GLUE_IN_PROGRAM -DAB_CD= -DNO_NSPR_10_SUPPORT -I/tmp/makepkg/palemoon/src/Pale-Moon/js/src -I. -Ictypes/libffi/include -I/tmp/makepkg/palemoon/src/Pale-Moon/intl/icu/source/common -I/tmp/makepkg/palemoon/src/Pale-Moon/intl/icu/source/i18n -I../../dist/include -I/tmp/makepkg/palemoon/src/pmbuild/dist/include/nspr -fPIC -D_FORTIFY_SOURCE=2 -O2 -DMOZILLA_CLIENT -include ../../js/src/js-confdefs.h -MD -MP -MF .deps/Unified_cpp_js_src4.o.pp -D_FORTIFY_SOURCE=2 -O2 -Wall -Wsign-compare -Wtype-limits -Wno-invalid-offsetof -Wcast-align -march=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -O2 -msse2 -mfpmath=sse -fomit-frame-pointer /tmp/makepkg/palemoon/src/pmbuild/js/src/Unified_cpp_js_src4.cpp
2:14.23 make[5]: *** [/tmp/makepkg/palemoon/src/Pale-Moon/config/rules.mk:937: Unified_cpp_js_src4.o] Error 1
2:14.24 make[4]: *** [/tmp/makepkg/palemoon/src/Pale-Moon/config/recurse.mk:74: js/src/target] Error 2
2:14.24 make[3]: *** [/tmp/makepkg/palemoon/src/Pale-Moon/config/recurse.mk:37: compile] Error 2
2:14.24 make[2]: *** [/tmp/makepkg/palemoon/src/Pale-Moon/config/rules.mk:541: default] Error 2
2:14.24 make[1]: *** [/tmp/makepkg/palemoon/src/Pale-Moon/client.mk:398: realbuild] Error 2
2:14.24 make: *** [client.mk:171: build] Error 2
2:14.27 262 compiler warnings present.
2:15.36 Failed to parse ccache stats output: cache hit rate 0.00 %
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build palemoon.
==> Restart building palemoon ? [y/N]
"

WorMzy commented on 2017-08-23 20:09

Thanks for the heads up. :)

The gcc5 drop shouldn't be too much of a problem. The current gcc5 package hasn't been touched in over a year, so there's probably not much risk in users installing it from the ALA once it disappears from the repos. Unfortunately I think it's unlikely that upstream will support/recommend a modern gcc any time soon.

It doesn't look like that fix for 2.26 causes any problems for 2.25, so I'll push out a pkgrel bump adding it and the job limit change shortly.

AndyRTR commented on 2017-08-23 18:25

When building against new toolchain in testing the following fix is required:

# fix build with glibc 2.26
sed -i "s:xlocale:locale:" Pale-Moon/intl/icu/source/i18n/digitlst.cpp

And please drop the make job limitation in mozconfig. The build can finish much faster without that limit on a recent cpu.

And be prepared: https://www.archlinux.org/todo/gcc5-removal/ !

WorMzy commented on 2017-07-14 10:00

Looks like the new default CFLAGS (as of pacman 5.0.2-2) don't work with gcc5. I'm not sure if this should be reported as a bug (to Arch, not Palemoon), or if PKGBUILDs that still use gcc5 should work around the problem. Unfortunately I'm stuck in a datacenter all day today so I can't research/test/get a new PKGBUILD out for a few hours but you should be able to fix the problem in the time being by exporting the old CFLAGS (and probably CXXFLAGS and LDFLAGS for good measure) at the top of the build function in the PKGBUILD.

e.g.
build() {
export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro"
...

anton-tsyganenko commented on 2017-07-14 08:47

I'm getting an error when building it:

0:01.54 configure:3304: gcc-5 -o conftest -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -D_FORTIFY_SOURCE=2 -O2 -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now conftest.c 1>&5
0:01.54 gcc-5: error: unrecognized command line option '-fno-plt'
0:01.54 configure: failed program was:
0:01.54
0:01.54 #line 3299 "configure"
0:01.55 #include "confdefs.h"
0:01.55
0:01.55 main(){return(0);}
0:01.55 configure: error: installation or configuration problem: C compiler cannot create executables.
0:01.55 *** Fix above errors and then restart with\
0:01.55 "/usr/bin/make -f client.mk build"
0:01.55 make[2]: *** [/tmp/yaourt-tmp-anton/aur-palemoon/src/Pale-Moon/client.mk:363: configure] Error 1
0:01.55 make[1]: *** [/tmp/yaourt-tmp-anton/aur-palemoon/src/Pale-Moon/client.mk:375: /tmp/yaourt-tmp-anton/aur-palemoon/src/pmbuild/Makefile] Error 2
0:01.55 make: *** [client.mk:171: build] Error 2
0:01.55 0 compiler warnings present.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build palemoon.

WorMzy commented on 2017-06-24 13:31

No, I think you're right and I misinterpreted the announcement. The caveat at the bottom of the original announcement seems to still apply:

"this currently has no impact on the Pale Moon browser. It will only become relevant if/when we move our Pale Moon application from our current Mozilla+Goanna 3 platform across to UXP in the future."

Still, if you are still willing to be a co-maintainer, I'm happy to add you as one.

wolf commented on 2017-06-24 12:46

I'm not sure where you got the "in the near future" from it (but maybe me reading comprehension sucks), but if nobody else volunteers, I might as well do it since I have no plans to stop using palemoon at the moment. So I would need some AUR package anyway.

WorMzy commented on 2017-06-21 18:33

PSA: Looks like palemoon will be switching to gtk3 in the near future[1]. I have no intention of continuing to maintain this package once that happens. As such, if there is anyone who wants to step up as a co-maintainer, with the intention of taking over as full maintainer when gtk3 becomes default, please let me know in the comments or drop me an email.

[1] https://forum.palemoon.org/viewtopic.php?t=15806&p=116121#p116121

bruno commented on 2017-06-20 14:40

sorry,
effectively, i'm running out of space on /tmp.

it works fine !
sorry and thanks for your quick reply

WorMzy commented on 2017-06-20 11:26

Are you running out of space? Where are you attempting to build?