Package Details: pamac-aur 10.1.1-1

Git Clone URL: https://aur.archlinux.org/pamac-aur.git (read-only, click to copy)
Package Base: pamac-aur
Description: A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support
Upstream URL: https://gitlab.manjaro.org/applications/pamac
Keywords: gui installer libalpm package pacman yay
Licenses: GPL3
Conflicts: pamac, pamac-tray-appindicator
Provides: pamac=10.1.1-1
Submitter: Zeph
Maintainer: Zeph
Last Packager: Zeph
Votes: 330
Popularity: 10.44
First Submitted: 2013-12-05 12:57
Last Updated: 2021-04-27 16:30

Dependencies (27)

Required by (5)

Sources (3)

Pinned Comments

Zeph commented on 2020-04-04 20:29

V9.4.1 : Optional flatpak and/or snapd plugin, edit PKGBUILD and modify line 4 and/or 5

ENABLE_FLATPAK=0
ENABLE_SNAPD=0

to

ENABLE_FLATPAK=1
ENABLE_SNAPD=1

Zeph commented on 2020-03-19 09:25

Pamac display empty results when browsing categories

Issue : https://gitlab.manjaro.org/applications/pamac/issues/772

You can fix by downgrade archlinux-appstream-data or use this command :

zcat /usr/share/app-info/xmls/community.xml.gz | sed 's|<em>||g;s|<\/em>||g;' | gzip > "new.xml.gz"
sudo cp new.xml.gz /usr/share/app-info/xmls/community.xml.gz
sudo appstreamcli refresh-cache --force

for appastreamcli install package appstream

Latest Comments

« First ‹ Previous ... 8 9 10 11 12 13 14 15 16 17 18 ... Next › Last »

khriss commented on 2018-06-08 13:24

Hi guys, I've just installed Pamac, the workaround I found was to install all of the dependencies by separated 1 by 1 (quite tedious I know), I followed the above list "dependencies (22)" and at the end pacaur -S pamac-aur. The package compiled correctly with no errors.

Lone_Wolf commented on 2018-06-05 22:32

Understood, a possibility would be to ask arch devs for a virtual provide, say polkit-agent . All polkit authentication agents then should provide it. No idea if they would accept it though.

Cromer commented on 2018-06-05 19:36

@Lone_Wolf, that won't solve the deps issue. It needs a polkit agent, not pure polkit.

Lone_Wolf commented on 2018-06-05 19:29

Cromer says :

@MindConsumer, it is impossible to be a real dependency. I use cinnamon which >means that I need "polkit-gnome" you are using stand-alone compiz which means you > need "lxsession", or people that use mate need "mate-polkit", etc. I don't want > all of those installed obviously since I only need one of them(polkit-gnome). It > is the responsibility of the person installing pamac to install the correct one > needed for their system based off what they have installed.

If pacman had rich dependencies this could be resolved, but that is a limitation > of pacman.

Or you look for something all those have in common and have this package depend on https://www.archlinux.org/packages/extra/x86_64/polkit/

FredBezies commented on 2018-06-05 07:18

You'll need soon to change project URL. This one is new one: https://gitlab.manjaro.org/applications/pamac

You can read this on github.com url:

"This repo has been archived. Our code is now hosted at

https://gitlab.manjaro.org/

See you there!"

Cromer commented on 2018-06-03 16:34

@MindConsumer, it is impossible to be a real dependency. I use cinnamon which means that I need "polkit-gnome" you are using stand-alone compiz which means you need "lxsession", or people that use mate need "mate-polkit", etc. I don't want all of those installed obviously since I only need one of them(polkit-gnome). It is the responsibility of the person installing pamac to install the correct one needed for their system based off what they have installed.

If pacman had rich dependencies this could be resolved, but that is a limitation of pacman.

Anonymous comment on 2018-06-03 16:23

Still?! :: pkgbrowser: installing pacman (5.1.0-2) breaks dependency 'pacman<5.1'

@Cromer: tnx for the clarification. I had to install the optional dependency: "lxsession - needed for authentification in Xfce, LXDE etc."

spsf64 commented on 2018-06-02 14:37

Anyone noticed the option "Clean Cache" under preferences, is not working? Is this upstream bug?

FredBezies commented on 2018-06-02 11:12

6.4.0 is out with pacman 5.1.0 support.

https://github.com/manjaro/pamac/releases/tag/v6.4.0

jianyue commented on 2018-06-02 01:42

A nice software , make me install software easily.But I like old version better.