Package Details: pan-git 1:v0.154.r42.g1f422ca-1

Git Clone URL: (read-only, click to copy)
Package Base: pan-git
Description: Pan is a Usenet newsreader that's good at both text and binaries. Development version.
Upstream URL:
Licenses: GPL
Conflicts: pan
Provides: pan
Submitter: Mymaud
Maintainer: mpento
Last Packager: mpento
Votes: 31
Popularity: 0.000000
First Submitted: 2009-10-15 20:08 (UTC)
Last Updated: 2023-10-23 13:34 (UTC)

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

mpento commented on 2023-10-23 13:38 (UTC)

Updated 'gmime' depends to 'gmime3'

6bo74 commented on 2023-10-21 20:18 (UTC)

Please add gmime3 to makedeps, it's on the standard repos. WIthout it:

checking for GLIB - version >= 2.17.6... yes (version 2.78.0)
checking for GMIME... no
configure: error: Package requirements (gmime-3.0 >= 3.0.0) were not met:

Package 'gmime-3.0', required by 'virtual:world', not found
==> ERROR: A failure occurred in build().
error: failed to build 'pan-git-1:v0.150.r0.g4c6043e-1':
error: packages failed to build: pan-git-1:v0.150.r0.g4c6043e-1

eclairevoyant commented on 2023-05-21 00:47 (UTC) (edited on 2023-05-21 00:48 (UTC) by eclairevoyant)

This should switch to using gmime3, not gmime (which is version 2). As per upstream readme:

Pan requires these libraries:

GLib 2.17.6 or higher (optionally GLib 2.26.0 or higher to support multiple Pan instances)

GTK 3.0.0 or higher

GMime 3.0.0 or higher (optionally with PGP cryptography support)

ostroffjh commented on 2022-03-12 16:36 (UTC)

Thanks for the update, yay no longer keeps trying to update. My command was just "yay" and I'm pretty sure it was the "v" making it think what was installed was not the same as what it wanted to install. My stupid on not recognizing that "g" couldn't be part of a commit, thanks for the clue. All seems to be good now.

mpento commented on 2022-03-12 15:46 (UTC)

@ostroffjh: I couldn't reproduce the problem you are seeing when using Yay, can you provide the complete command you are using?

The commit is valid, the 'g' is throwing you off, it's a suffix for the previous data field. Drop it and you get: 4c6043e

Please see for details.

mpento commented on 2022-03-12 14:52 (UTC)

Updated to v0.150.r0.g4c6043e

ostroffjh commented on 2022-03-11 17:03 (UTC)

Still having an odd problem. yay tells me: :: 1 Packages to upgrade. 1 aur/pan-git 1:v0.150.r0.g4c6043e-1 -> 1:0.145.r15.g476b5a6-1 even after re-installation. I don't know if the problem is the "v" added to the actually installed current version, or that the installed version is 150, but the name of the package uses 145. In addition, I can't find any commit with g4c6043e. Am I simply doing something wrong?

ostroffjh commented on 2022-01-30 16:52 (UTC)

There does seem to be a problem. The package advertises as ...r15... but installs as ...r14... so yay wants to update every time, but just installs the same package. I think the pkgver in PKGBUILD needs to match the listed version.

ostroffjh commented on 2022-01-29 21:01 (UTC)

@ak2021: this is a git build. Just install it again and you will have the latest version.

ak2021 commented on 2021-11-06 22:48 (UTC)

The version is now 1:v0.148.r0.ga70bd74-1