Package Details: pan-git 140.r22.g04f6c89-1

Git Clone URL: https://aur.archlinux.org/pan-git.git (read-only)
Package Base: pan-git
Description: Pan is a Usenet newsreader that's good at both text and binaries. Development version.
Upstream URL: http://pan.rebelbase.com/
Licenses: GPL
Conflicts: pan
Provides: pan
Submitter: Mymaud
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 30
Popularity: 0.263110
First Submitted: 2009-10-15 20:08
Last Updated: 2016-08-09 19:39

Latest Comments

FredBezies commented on 2016-04-04 09:55

April 4th, 2016 : time to upgrade to Pan 0.140 :D

FredBezies commented on 2015-12-14 15:59

The only thing to do here is to open a bug report on https://bugzilla.gnome.org/

Pinerto commented on 2015-12-14 14:25

After the update, the pan does not restart.
In scope to restart, one must delete the preferences.xml file first or the two line there, which cause the problem:

<string name='last-opened-msg' value=''/>
<string name='last-visited-group' value=''/>

If these two line are manually deleted,the program start like should be without deleting the preferences file.
But after closing, these two lines are recreated in the preferences.xml , and pan are unable to restart again.

Pls, do something... .
Thanks in advance.

orbisvicis commented on 2013-05-02 13:31

GtkSpell3 support added upstream... gtk3 build should be fine now.

skydrome commented on 2013-04-09 06:19

updated.
reverted to gtk2 since build failed with deprecation errors with gtk3. Maybe somebody can look into that. Just change _USE_GTK3=n in the pkgbuild to build with gtk3.
Also, gtkspell3 detection fixed.

FredBezies commented on 2013-04-08 19:12

@josephgbr : I disown this package as I do not use it anymore.

Feel free to adopt it.

rafaelff commented on 2013-04-08 19:02

Hey, can you update the PKGBUILD with the support for VCS packages provided by pacman 4.1 ? If you need example, I suggest the package 'networkmanager-openconnect-git' (but there are others already)

FredBezies commented on 2013-03-29 08:34

As gnome-common is working with automake-1.13, removed automake-1.12 from makedepends.

FredBezies commented on 2013-02-25 07:56

Added automake-1.12 as makedepends.

FredBezies commented on 2013-02-13 20:30

Orphaning this package. Feel free to adopt it !

FredBezies commented on 2012-12-02 18:15

"Nacampified" package and cleaned it up a little. Hope it will work again ;)

Anonymous comment on 2012-12-02 16:18

Thanks. TBH i'm not sure about updating the desktop db, as this isnt needed in the stable version i am using, so it may not needed in git as well.
Although it might be nice to get something like mime support into pan.
Namcap should tell you if its actually needed.

FredBezies commented on 2012-12-02 07:36

New version following dolby comments.

Anonymous comment on 2012-12-02 03:33

Also
a) homepage is http://pan.rebelbase.com
b) description is wrong. this is no longer a testing repo but the official one
c) pan-dev in conflicts doesnt exist
d) it needs an install file which at least updates the desktop db.

Anonymous comment on 2012-12-02 03:28

if gnome-common and gnome-doc-utils are needed they are makedependencies not runtime dependencies.

FredBezies commented on 2012-10-02 20:41

Starting from 2 october 2012 : gtk3 version with webkit engine used for html support. Git version is now tagged as 0.140.

FredBezies commented on 2012-04-30 16:54

30 april 2012 : based on git version for version 0.137.

- Cleaned up a little PKGBUILD
- Disabled gtk3 option, busted to death for now

Anonymous comment on 2012-02-15 09:45

thank you

FredBezies commented on 2012-01-22 11:41

@kveku : thanks for the tip. Updated with --gnutls option.

kevku commented on 2012-01-22 10:42

--with-gnutls for ssl support

FredBezies commented on 2012-01-19 07:26

Disabling gnome-doc-help for now, it is busted.

FredBezies commented on 2012-01-17 06:25

Thanks for the info. Fixed.

dhaines commented on 2012-01-16 21:40

gnome-doc-utils needs to be added to the depends array, otherwise it won't build.

FredBezies commented on 2012-01-16 20:16

As gmime 2.6.x is now the extra version, updating PKGBUILD.

FredBezies commented on 2012-01-08 13:51

Thanks for the building problem. Will contact author asap.

mr_spuck commented on 2012-01-08 13:47

The sources from the git repository want gmime 2.6 which isn't available from the official repos nor from AUR.

FredBezies commented on 2011-12-10 16:12

Added --with-openssl --with-gtkspell --enable-libnotify to fix a strange crash.

FredBezies commented on 2011-12-09 20:23

Adopted it, and made it more AUR compliant ;)

FredBezies commented on 2011-12-07 21:52

Git repo changed :

Just use this in PKGBUILD :

url="http://git.gnome.org/browse/pan2"
_gitroot="git://git.gnome.org/pan2"

FredBezies commented on 2011-11-28 11:55

Reported bug upstream : https://bugzilla.gnome.org/show_bug.cgi?id=665032

FredBezies commented on 2011-11-28 11:44

Still crashing on building !

In file included from socket-impl-main.cc:47:0:
socket-impl-main.h:164:41: error: 'X509' has not been declared
In file included from socket-impl-main.cc:47:0:
socket-impl-main.h:174:28: error: 'X509' has not been declared
make[3]: *** [socket-impl-main.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from ../../pan/tasks/nntp-pool.h:29:0,
from upload-queue.h:31,
from upload-queue.cc:25:
../../pan/tasks/socket-impl-main.h:164:41: error: 'X509' has not been declared
In file included from ../../pan/tasks/nntp-pool.h:29:0,
from upload-queue.h:31,
from upload-queue.cc:25:
../../pan/tasks/socket-impl-main.h:174:28: error: 'X509' has not been declared
make[3]: *** [upload-queue.o] Error 1
In file included from socket-impl-openssl.cc:103:0:
socket-impl-main.h:164:41: error: 'X509' has not been declared
In file included from socket-impl-openssl.cc:103:0:
socket-impl-main.h:174:28: error: 'X509' has not been declared
make[3]: *** [socket-impl-openssl.o] Error 1
In file included from ../../pan/tasks/nntp-pool.h:29:0,
from queue.h:31,
from queue.cc:25:
../../pan/tasks/socket-impl-main.h:164:41: error: 'X509' has not been declared
In file included from ../../pan/tasks/nntp-pool.h:29:0,
from queue.h:31,
from queue.cc:25:
../../pan/tasks/socket-impl-main.h:174:28: error: 'X509' has not been declared
make[3]: *** [queue.o] Error 1
make[3]: Leaving directory `/home/fred/download/pan-git/src/pan2-build/pan/tasks'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/fred/download/pan-git/src/pan2-build/pan'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/fred/download/pan-git/src/pan2-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Can anyone report it upstream, please ?

FredBezies commented on 2011-11-06 19:11

Cannot get it build recently, building process crashing with something related to openssl :

socket-impl-main.cc:62:5: error: 'SSL_CTX' does not name a type
socket-impl-main.cc:64:87: error: 'SSL_CTX' has not been declared
socket-impl-main.cc: In constructor 'pan::ThreadWorker::ThreadWorker(const pan::StringView&, int, pan::Socket::Creator::Listener*, bool, int*)':
socket-impl-main.cc:65:74: error: class 'pan::ThreadWorker' does not have any field named 'context'
socket-impl-main.cc: In member function 'virtual void pan::SocketCreator::create_socket(const pan::StringView&, int, pan::WorkerPool&, pan::Socket::Creator::Listener*, bool)':
socket-impl-main.cc:149:71: error: 'ssl_ctx' was not declared in this scope
make[3]: *** [socket-impl-main.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/home/fred/download/pan-git/src/pan2-build/pan/tasks'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/fred/download/pan-git/src/pan2-build/pan'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/fred/download/pan-git/src/pan2-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Any hope to report it upstream ?

Mymaud commented on 2011-10-22 14:48

Switch from the lastcoder to judgefudge repo :
- nzb builder
- upload functionality
- new icons
- new filter
- ...

Mymaud commented on 2011-06-18 21:53

autoconf and automake added
Thanks for the feedback Tindzk.

tindzk commented on 2011-06-17 19:48

Mymaud, the dependencies autoconf and automake are missing.

Mymaud commented on 2011-05-20 17:04

gtk3 added, and LC_ALL too. But that compile for me without the LC_ALL to C.

Thanks kevku for the tips.

kevku commented on 2011-05-19 12:26

needs gtk3 and
LC_ALL="C" before configure and make to compile properly