Package Details: panda3d 1.10.5-1

Git Clone URL: https://aur.archlinux.org/panda3d.git (read-only, click to copy)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Licenses: BSD
Submitter: wonder
Maintainer: croxis
Last Packager: croxis
Votes: 36
Popularity: 0.008297
First Submitted: 2010-01-30 22:41
Last Updated: 2020-01-12 00:18

Dependencies (48)

Required by (1)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

corro commented on 2012-05-09 17:06

@liesmich.txt: If you don't rely on the maya2012 tools, try to add --no-maya2012 in the PKGBUILD on line 38:

python2 makepanda/makepanda.py --everything --no-maya2012

Anonymous comment on 2012-05-09 08:59

Hi there,

I can't build this release.
Compiling breaks with the following message:
http://pastebin.com/wjYKhTux

Any ideas?

corro commented on 2012-05-03 18:08

Beware that opencv 2.4.0 breaks panda3d startup. You need to disable opencv support with --no-opencv in PKGBUILD if you have opencv installed.

corro commented on 2012-04-27 15:50

@lvdota: These are just optional dependencies. If you don't use them (most people don't) you may safely ignore those warnings.

Anonymous comment on 2012-04-27 15:24

need help please ....

patching file panda/src/express/nodePointerTo.I
WARNING: Could not locate thirdparty package eigen, excluding from build
Generating library cache...
WARNING: Could not locate thirdparty package artoolkit, excluding from build
WARNING: Could not locate thirdparty package fcollada, excluding from build
WARNING: Could not locate thirdparty package fftw, excluding from build
WARNING: Could not locate thirdparty package fmodex, excluding from build
WARNING: Could not locate thirdparty package osmesa, excluding from build
WARNING: Could not locate thirdparty package opencv, excluding from build
WARNING: Could not locate thirdparty package squish, excluding from build
WARNING: Could not locate thirdparty package vrpn, excluding from build
WARNING: Could not locate thirdparty package rocket, excluding from build

corro commented on 2012-04-21 06:56

I do not intend to manage this package for a long time, it just bugs me when packages don't build anymore. But in the meantime I'll take over panda3d-cvs too, thanks for the hint.

Anonymous comment on 2012-04-20 20:09

Good to hear that it's working that way.
By the way, you can also disable ODE completely writing --no-ode at the end of the makepanda.py line.

@corro:
How about also taking over panda3d-cvs? I maintained both 'till a few days ago, but I switched the distro.
Good luck

corro commented on 2012-04-20 13:16

Replaced dependency 'ode' with 'ode-compat' (AUR) because panda3d does not seem to work with ODE 0.12. Please read the comment on ode-compat before building the package or it won't compile!

cross commented on 2012-04-15 21:18

build with gcc 4.7.0-4 fails on [ 9%] Building C++ object built/tmp/p3pipeline_composite1.o
In file included from built/include/nodePointerTo.h:85:0,
from panda/src/pipeline/pipelineCyclerTrueImpl.h:26,
from panda/src/pipeline/pipelineCyclerBase.h:25,
from panda/src/pipeline/pipelineCycler.h:19,
from panda/src/pipeline/cycleDataLockedReader.h:21,
from panda/src/pipeline/cycleDataLockedReader.cxx:15,
from panda/src/pipeline/p3pipeline_composite1.cxx:15:
built/include/nodePointerTo.I: In instantiation of �NodePointerTo<T>& NodePointerTo<T>::operator=(const NodePointerTo<T>&) [with T = CycleData]�:
panda/src/pipeline/pipelineCyclerTrueImpl.I:466:30: required from here
built/include/nodePointerTo.I:136:3: error: �reassign� was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
built/include/nodePointerTo.I:136:3: note: declarations in dependent base �NodePointerToBase<CycleData>� are not found by unqualified lookup
built/include/nodePointerTo.I:136:3: note: use �this->reassign� instead

Anonymous comment on 2012-03-16 12:09

you're right, without ODE compiles ok.

Thanks a lot.