Package Details: pandoc-cabal 1.15.0.6-1

Git Clone URL: https://aur.archlinux.org/pandoc-cabal.git (read-only)
Package Base: pandoc-cabal
Description: Conversion between markup formats (cabal sandbox build)
Upstream URL: http://johnmacfarlane.net/pandoc/
Licenses: GPL
Conflicts: haskell-pandoc, pandoc
Provides: pandoc=1.15.0.6
Submitter: joni
Maintainer: None
Last Packager: joni
Votes: 8
Popularity: 0.000000
First Submitted: 2014-07-22 13:59
Last Updated: 2015-08-18 09:23

Dependencies (5)

Required by (104)

Sources (1)

Latest Comments

timofonic commented on 2017-07-17 21:08

What happens? Are there a way to announce outdated packages and mark them as orphaned?

eigengrau commented on 2017-06-26 07:20

This currently fails to build for two reasons:

1. The Arch ghc package is no longer shipping static libraries for core packages. This can be addressed by depending on the new package, ghc-static.

2. Official haskell-* packages also don’t ship static libraries (I’m not sure if they used to ship them). The issue that results from this is that the build will fail with linker errors if some dependency of pandoc is installed from the repos. These packages won’t be installed into the sandbox, but during linking the build will error out because the static libraries are missing.

I haven’t yet found a solution for 2. If you have any ideas please let me know since I also maintain some statically built packages. It’s possible to disable the global package database during the build by using «GHC_PACKAGE_PATH» and «--package-db=clear», but this won’t work because this will hide all packages shipped with GHC, too.

dno commented on 2015-05-31 22:37

Please update to 1.14.0.2

groover commented on 2015-04-16 14:15

Please update to 1.13.2.1-1.

joni commented on 2015-01-29 21:00

In general I would agree. But in this case I opted not to put the 'provide', because this package does not actually install the haskell libraries but only the pandoc binary. You are still right on the 'conflict' option, though.

haawda commented on 2015-01-25 17:04

Shouldn't this conflict to and provide "haskell-pandoc" instead of "pandoc"?

joni commented on 2014-10-21 23:49

Updated the package. AFAICT only pandoc-citeproc needs ICU.

nineinchnick commented on 2014-10-21 05:41

icu has been updated.

joni commented on 2014-08-23 09:38

I can not reproduce this, unfortunately. Do you have the latest cabal-install? Do you have a custom ~/.cabal/config? In which phase of the build does it fail?

gdw commented on 2014-08-16 20:50

Didn't work for me:

Downloading the latest package list from hackage.haskell.org
/home/gdw/tmp/yaourt-tmp-gdw/aur-pandoc-cabal/./PKGBUILD: line 21: 19237 Killed cabal update
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build pandoc-cabal.