Package Details: pantheon-dock-bzr r1050-1

Git Clone URL: https://aur.archlinux.org/pantheon-dock-bzr.git (read-only)
Package Base: pantheon-dock-bzr
Description: The Pantheon Dock
Upstream URL: https://launchpad.net/pantheon-dock
Licenses: GPL3
Conflicts: pantheon-dock, plank
Provides: pantheon-dock, plank
Submitter: alucryd
Maintainer: alucryd
Last Packager: alucryd
Votes: 10
Popularity: 0.000750
First Submitted: 2012-11-20 14:08
Last Updated: 2015-06-09 10:05

Required by (17)

Sources (1)

Latest Comments

alucryd commented on 2013-05-16 16:26

evilgnome: I've taken bamf-bzr over and removed all deps that had nothing to do there.

evilgnome commented on 2013-05-15 05:13

I build this with bamf instead of bamf-bzr to spare myself the crazy dependencies, and it seems to work fine. Just posting in case anyone else wants to do that.

alucryd commented on 2013-02-26 20:59

kozec: That's because gnome-common is outdated, it won't recognize automake 1.13. Installing automake-1.12 indeed fixes it, but you can also install gnome-common-git instead and have it use automake 1.13.

kozec commented on 2013-02-26 20:55

I'm having weird problem here...

==> Starting make...
(snip)
checking for automake >= 1.11...
testing automake-1.12... not found.
testing automake-1.11... not found.
***Error***: You must have automake >= 1.11 installed
to build plank. Download the appropriate package for
from your distribution or get the source tarball at
http://ftp.gnu.org/pub/gnu/automake/automake-1.11.tar.gz

Automake version in official repo is 1.13, after installing automake-1.12 from aur error disappears.

alucryd commented on 2013-01-27 20:44

@superlex: gala-bzr should require pantheon-dock-bzr, not plank-bzr. You should ask the maintainer to correct that.

Anonymous comment on 2013-01-27 20:00

Ok, thanks for explanation.

However problems occur if a package requires a specific bzr version of plank-bzr.
For example, gala-bzr requires plank-bzr>=682.

From Wiki:
"Putting provides=('qt') will cause to fail those dependencies that require a specific version of qt."
https://wiki.archlinux.org/index.php/PKGBUILD#provides

alucryd commented on 2013-01-27 18:48

@superlex: That would be rather pointless. First pantheon-dock and this one do not use the same versioning, and plank-bzr's version is completely independent from this one. Second, there is and likely will never be hard dependency on a specific bzr revision of pantheon-dock-bzr.

Anonymous comment on 2013-01-27 18:37

Please change provides() array to

provides=("pantheon-dock=$pkgver" "plank-bzr=$pkgver")

Thanks.

alucryd commented on 2013-01-08 11:38

Tried installing automake-1.11, it did the trick. Also, autogen.sh seems to use gnome-autogen.sh from gnome-common to check for automake. Unless gnome-common is updated to look for 1.13, this will not detect it.

alucryd commented on 2013-01-06 11:20

@neodarkness: You could try installing this for the time being: https://aur.archlinux.org/packages/automake-1.11/
I can't test right now, but I fixed some of my packages by changing variables like AM_CONFIG_HEADER in configure.ac to the new standard, but it seems this one will need a bypass of the version detection to work. I'll try to have a look tomorrow, I too am using testing and have automake 1.13.

All comments