Package Details: pantheon-files-bzr r2107-1

Git Clone URL: https://aur.archlinux.org/pantheon-files-bzr.git (read-only)
Package Base: pantheon-files-bzr
Description: The Pantheon File Manager
Upstream URL: https://launchpad.net/pantheon-files
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: pantheon-files
Provides: pantheon-files
Submitter: Ner0
Maintainer: alucryd
Last Packager: alucryd
Votes: 48
Popularity: 0.563373
First Submitted: 2012-11-22 11:05
Last Updated: 2016-04-10 18:56

Latest Comments

misc commented on 2015-04-13 14:40

Here's a small patch to fix some of the broken top bar icons:
http://pastie.org/pastes/10089965/text

view-column-symbolic was replaced as it doesn't actually exist in standard Adwaita and media-playback-pause-symbolic looks the most similar.

Alas, TopMenu.vala uses some weird custom ButtonWithMenu class that has no obvious parameters for size, so it's still displayed oversized.

alucryd commented on 2015-04-11 20:03

Moved to [community].

alucryd commented on 2014-04-02 07:26

Build everything with libgee06 and don't use bzr deps.

mildred commented on 2014-04-02 07:21

It is missing gee-1.0.vapi

-- checking for modules 'gtk+-3.0;gio-2.0;gee-1.0'
-- package 'gee-1.0' not found

if I install gee-1.0.vapi from package extra/libgee06 (!) it won't build because it will load both libgee-0.8 and libgee-1.0:

Loaded package `/usr/share/vala/vapi/gee-0.8.vapi'
Loaded package `/usr/share/vala/vapi/gee-1.0.vapi'

gee-1.0.vapi:7.3-7.53: error: `Gee.Functions' already contains a definition for `get_compare_func_for'
gee-0.8.vapi:7.3-7.57: note: previous definition of `get_compare_func_for' was here

alucryd commented on 2014-03-17 17:36

Okay, so you've been ignoring my messages here and the email I sent you. Now I'm tired of people complaining to me because your packages have wrong deps and all that so I'll be taking over pantheon-files-bzr, pantheon-files-plugin-dropbox-bzr and gala-bzr.

theOptimizedCode commented on 2014-02-28 07:18

Compilation failed: 36 error(s), 0 warning(s)
libcore/CMakeFiles/marlincore.dir/build.make:74: recipe for target 'libcore/marlincore_valac.stamp' failed
make[2]: *** [libcore/marlincore_valac.stamp] Error 1

All w.r.t gee-1.0.vapi

alucryd commented on 2014-02-12 10:50

Hey, I'd like to maintain gala-bzr, pantheon-files-bzr and pantheon-files-plugin-dropbox-bzr as well. Now that I maintain almost all of Pantheon, and have pushed some parts in [community] already, it will help keep Pantheon in harmony and prevent things like what orschiro reported. Would that be okay with you?

orschiro commented on 2014-02-12 10:35

Fails to build:

==> Missing dependencies:
-> granite-bzr>=589

~ ❯ pacman -Q | grep granite
granite-bzr r687-1

NightExcessive commented on 2014-02-09 20:59

pantheon-files 0.1.6 has been released: https://launchpad.net/pantheon-files/+announcement/12437

alucryd commented on 2013-11-28 09:33

0.1.5.1 (and probably even 0.1.5 now) won't build. I submitted a bug report upstream: https://bugs.launchpad.net/pantheon-files/+bug/1255897

misc commented on 2013-06-29 12:10

r1173 removed that menu entirely. The GSettings are supposed to be reached via eg. dconf now.

misc commented on 2013-06-28 17:25

IIRC they completely removed it and wrote that people should use dconf/gconf for the remaining options.

Also, compilation now fails for me with:
/usr/include/gee-1.0/gee.h:755:6: Anmerkung: »struct GeeAbstractCollection *« erwartet, aber Argument hat Typ »struct GeeCollection *«

sh4nks commented on 2013-06-27 08:42

how do I restore the "Preferences"-Menu?

sh4nks commented on 2013-06-27 08:17

how do I restore the "Preferences"-Menu?

idainet commented on 2013-06-26 08:39

I was unable to build it using granite-566-1, but succeeded with granite-591-1. So the minimal version need to be increased, 424 => 591

misc commented on 2012-12-28 00:16

For those with a dislike for files's twice as wide topbar: If the "insert (app_menu, -1)" line along with its following one in src/View/Chrome/TopMenu.vala is commented out, the bar becomes as slim as marlin's again.

This will also disable the settings icon; however that's not much of a problem as all the options there are accessible via toggling the menu bar with F8.

A more elegant way would be to change the AppMenu constructor in granite's src/granite/lib/Widgets/AppMenu.vala so that it doesn't display the "Menu" string anymore, but I don't know enough vala to do this (leaving it empty will insert to a lot of default text, removing the variable from the constructor won't compile, and inserting a single place still allocates the vertical space).

alucryd commented on 2012-11-20 19:07

@bjesus: Missed that, thx!

bjesus commented on 2012-11-20 19:04

please add libpantheon-bzr as a dependency

d3Xt3r commented on 2012-11-10 20:45

@Ner0: Thanks, I didn't realize that! I was misled by this message:

warning: granite-bzr-365-1 is up to date -- reinstalling

Which led me to abort the installation, but after proceeding with the update, I saw "Version found: 441". :)

Thanks for your help!

Ner0 commented on 2012-11-07 14:20

-bzr packages always install the latest version, just install granite-bzr.

d3Xt3r commented on 2012-11-07 08:51

@hcjl: Where did you get the newer granite-bzr? The one in the AUR is still 364-1 ...

Ner0 commented on 2012-11-06 11:23

You need newer granite. I've updated the package.

hcjl commented on 2012-11-06 11:22

thx. updating granite-bzr to 436-1 did the trick.

Ner0 commented on 2012-11-06 11:08

Try updating granite-bzr.

hcjl commented on 2012-11-06 11:03

Building the new version (933-1 -> 1002-1) fails with 7 errors an 46 warnings. Here are the errors:

/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:189.34-189.58: error: The name `ThinPaned' does not exist in the context of `Granite.Widgets'
var lside_pane = new Granite.Widgets.ThinPaned ();
^^^^^^^^^^^^^^^^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:189.17-189.61: error: var declaration not allowed with non-typed initializer
var lside_pane = new Granite.Widgets.ThinPaned ();
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:190.13-190.22: error: The name `lside_pane' does not exist in the context of `Marlin.View.Window.new'
lside_pane.show();
^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:192.13-192.22: error: The name `lside_pane' does not exist in the context of `Marlin.View.Window.new'
lside_pane.pack1(sidebar, false, false);
^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:193.13-193.22: error: The name `lside_pane' does not exist in the context of `Marlin.View.Window.new'
lside_pane.pack2(main_box, true, true);
^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:213.35-213.44: error: The name `lside_pane' does not exist in the context of `Marlin.View.Window.new'
window_box.pack_start(lside_pane, true, true, 0);
^^^^^^^^^^
/tmp/yaourt-tmp-jle/aur-files-bzr/src/files-build/src/View/Window.vala:217.13-217.22: error: The name `lside_pane' does not exist in the context of `Marlin.View.Window.new'
lside_pane.position = Preferences.settings.get_int ("sidebar-width");

Ner0 commented on 2012-08-27 13:24

I forgot to bump the granite version, try it again.

popsch commented on 2012-08-27 09:32

I get this error:

...
- granite-bzr>=355 (building from AUR)
...

==> Install or build missing dependencies for files-bzr:
error: target not found: granite-bzr>=355

florianbw commented on 2012-07-13 11:32

It conflicts with marlin - can this be resolved?

misc commented on 2012-06-02 17:58

By xapantu, the other active Marlin developer:

"Marlin and Pantheon Files can live together, Marlin is the upstream project, Pantheon Files is a rebranded version of Marlin, but the projects won't diverge a lot, core things will go to marlin, and if the elementary team want some UI fixes that we (Marlin developers) don't like, they will put them in Pantheon Files.

Don't worry, this is managed efficiently, so, we won't lose time because of these two projects ;) ."

Ner0 commented on 2012-05-31 20:09

Yeah, the latest rev doesn't build after xapantu's commits.

misc commented on 2012-05-31 18:51

xapantu has just merged the new commits from marlin into files; ammonkey announced his return to marlin on Saturday: https://answers.launchpad.net/marlin/+question/193884

Ner0 commented on 2012-05-30 21:47

Interesting, we'll see what the further development wil bring to both of them, for now the only difference is that elementary has dropped varka and extended-actions in favour of granite and contractor.
Although it would be better if they joined their efforts.

misc commented on 2012-05-30 20:56

Well, it seems to be more than that given the latest commits to marlin and varka (needs to be updated for the other to compile). Somebody at reddit speculated whether ammonkey was fed up with the Elementary people taking the credit while leaving him to do all the work, and thus pretending (?) to abandon it to force them into actually acting. Maybe that's indeed the case.

misc commented on 2012-05-25 13:29

Maybe ammonkey just wants to leave marlin with mostly crash-free code. But dunno.

Ner0 commented on 2012-05-25 05:13

Umm, it seems that Marlin development has continued.

misc commented on 2012-05-24 18:59

Fixed now. All files still needs to replace marlin is contractor to work.

mdias commented on 2012-05-18 15:48

Yep, the context menus aren't working here either.

mdias commented on 2012-05-18 15:47

Yep, not working here either.

Ner0 commented on 2012-05-13 21:59

This is not yet ready for everyday use. Use marlin for the time being.

misc commented on 2012-05-13 16:05

Continued development, finally.

Btw, are context menus and certain hotkeys (like copy, cut & paste) not working for anybody else?