Package Details: paper-plane 0.1.0beta.5-1

Git Clone URL: https://aur.archlinux.org/paper-plane.git (read-only, click to copy)
Package Base: paper-plane
Description: Chat over Telegram on a modern and elegant client
Upstream URL: https://github.com/paper-plane-developers/paper-plane
Keywords: chat gnome gtk4 rust tdlib telegram
Licenses: GPL3
Conflicts: paper-plane
Provides: paper-plane
Submitter: alissonlauffer
Maintainer: alissonlauffer
Last Packager: alissonlauffer
Votes: 1
Popularity: 0.081829
First Submitted: 2023-05-17 02:17 (UTC)
Last Updated: 2023-11-06 23:20 (UTC)

Latest Comments

pants commented on 2024-02-05 17:35 (UTC)

I find a build failure in a clean chroot resulting from one of the rust dependencies wanting libclang. Adding clang in makedepends resolves this for me.

alissonlauffer commented on 2023-11-13 21:02 (UTC)

@sbeve72 the actual error is above the snippet you sent.

sbeve72 commented on 2023-11-13 10:48 (UTC) (edited on 2023-11-13 10:50 (UTC) by sbeve72)

FAILED: src/paper-plane 
/usr/bin/env CARGO_HOME=/home/sbeve72/.cache/yay/paper-plane/src/build/cargo-home /usr/bin/cargo build --manifest-path /home/sbeve72/.cache/yay/paper-plane/src/paper-plane/Cargo.toml --target-dir /home/sbeve72/.cache/yay/paper-plane/src/build/src --release && cp src/release/paper-plane src/paper-plane
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: paper-plane-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
paper-plane - exit status 4

Getting the above error while compiling using yay. The command I used was yay -S paper-plane

alissonlauffer commented on 2023-09-28 17:51 (UTC)

@VxlerieUwU The gtk4-paper-plane package is still required, as the application actually needs a patched gtk4 package, as it requires a not yet upstreamed patch that adds a reversed list mode.

VxlerieUwU commented on 2023-09-28 14:06 (UTC)

gtk4-paper-plane is no longer required since 4.12.2 is now packaged in archlinux extra repo

MarsSeed commented on 2023-08-08 15:50 (UTC)

Hi,

Please be aware that the current version should be 0.1.0beta.3 instead of 0.1.0.beta.3.

The reason behind it is that the vercmp command used by makepkg and pacman for version comparison considers the following to be true:

0.1.0beta.3 < 0.1.0 < 0.1.0.beta.3