Package Details: paper-plane-git 0.1.0beta.4.r0.g2aa316c-1

Git Clone URL: https://aur.archlinux.org/paper-plane-git.git (read-only, click to copy)
Package Base: paper-plane-git
Description: Chat over Telegram on a modern and elegant client
Upstream URL: https://github.com/paper-plane-developers/paper-plane
Keywords: chat gnome gtk4 rust tdlib telegram
Licenses: GPL3
Conflicts: paper-plane
Provides: paper-plane
Submitter: alissonlauffer
Maintainer: alissonlauffer
Last Packager: alissonlauffer
Votes: 13
Popularity: 0.000441
First Submitted: 2023-05-14 19:47 (UTC)
Last Updated: 2023-09-25 18:55 (UTC)

Pinned Comments

alissonlauffer commented on 2022-10-09 17:33 (UTC) (edited on 2023-06-05 17:53 (UTC) by alissonlauffer)

Note that this is a dev package, and during the development, devs may need to switch back to libadwaita-git at any time to test new features from upcoming libadwaita releases.

alissonlauffer commented on 2022-05-21 07:10 (UTC) (edited on 2022-10-09 18:01 (UTC) by alissonlauffer)

Using gtk4 from extra is not possible right now, unless manually patching the app to not use the reversed list patch (see https://github.com/melix99/telegrand/commit/1ec2f6a19c1dcf0ae82f1d3ea52a77a8626e6d06). A custom gtk4 version is used to fix scrolling issues by adding a reversed list mode patch.

You can use the patched gtk4-telegrand package as a drop-in replacement of the gtk4 package just fine, as there shouldn't be issues with it and a package rebuild isn't required. Telegrand will probably switch back to gtk4 once those patches are upstreamed into gtk.

Latest Comments

1 2 3 Next › Last »

Bitals commented on 2023-05-17 02:55 (UTC)

Not appstream-glib, just appstream. The first does not depend on the second, and the second one is needed. The error persists. Fixed after manual appstream install.

Bitals commented on 2023-05-17 01:23 (UTC) (edited on 2023-05-17 01:23 (UTC) by Bitals)

01:18:09 paper-plane/meson.build:16:0: ERROR: Dependency lookup for libadwaita-1 with method 'pkgconfig' failed: Could not generate cargs for libadwaita-1:
01:18:09 Package appstream was not found in the pkg-config search path.
01:18:09 Perhaps you should add the directory containing `appstream.pc'
01:18:09 to the PKG_CONFIG_PATH environment variable
01:18:09 Package 'appstream', required by 'libadwaita-1', not found

I think this should be added as a dependency.

yochananmarqos commented on 2023-05-14 19:07 (UTC)

The URL has been updated to https://github.com/paper-plane-developers/paper-plane

q234rty commented on 2023-02-15 05:19 (UTC)

This fails to build without blueprint-compiler:

Fallback to subproject blueprint-compiler which provides program blueprint-compiler

telegrand/data/resources/meson.build:1:0: ERROR: Automatic wrap-based subproject downloading is disabled

alissonlauffer commented on 2022-11-28 19:56 (UTC)

@Bitals you must rebuild tdlib against openssl 3.0. By the way, I've just updated libtd-dev to 1.8.8, so it's a good time to rebuild it.

Bitals commented on 2022-11-28 17:39 (UTC)

openssl-1.1 is a dependency:

03:02:16   = note: /usr/sbin/ld: warning: libssl.so.1.1, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/12.2.0/../../../../lib/libtdjson.so, not found (try using -rpath or -rpath-link)
03:02:16           /usr/sbin/ld: warning: libcrypto.so.1.1, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/12.2.0/../../../../lib/libtdjson.so, not found (try using -rpath or -rpath-link)
...
03:02:16 error: could not compile `telegrand` due to previous error

robertomorrison commented on 2022-11-25 10:18 (UTC) (edited on 2022-11-25 10:19 (UTC) by robertomorrison)

Could you add aarch64 architecture to the PKGBUILD? I confirmed that it's working fine. Since you're also the maintainer of gtk4-telegrand, could you add it there as well

alissonlauffer commented on 2022-10-09 17:33 (UTC) (edited on 2023-06-05 17:53 (UTC) by alissonlauffer)

Note that this is a dev package, and during the development, devs may need to switch back to libadwaita-git at any time to test new features from upcoming libadwaita releases.

dusansimic commented on 2022-10-03 06:48 (UTC)

Package doesn't need to depend on libadwaita-git since telegrand requires libadwaita >= 1.2 which is now available in arch repos.