Package Details: papis 0.12-1

Git Clone URL: (read-only, click to copy)
Package Base: papis
Description: Papis is a powerful and highly extensible command-line based document and bibliography manager.
Upstream URL:
Licenses: GPL
Submitter: JP-Ellis
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 12
Popularity: 0.22
First Submitted: 2018-08-13 20:42 (UTC)
Last Updated: 2022-08-01 08:47 (UTC)

Pinned Comments

JP-Ellis commented on 2021-01-17 10:01 (UTC)

Version 0.11.1 has been updated, and is patched to allow the current version of python-isbnlib.

Latest Comments

JP-Ellis commented on 2021-01-17 10:01 (UTC)

Version 0.11.1 has been updated, and is patched to allow the current version of python-isbnlib.

SZanko commented on 2020-12-29 15:22 (UTC)

To Update to Version 0.11 change pkgver=0.11 sha256sums=('e54739a1771ba4da4afe30b0b52dfc220543926765f975d14e8ddce508f4fdf9' '261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608') and comment out patch on line 40

JP-Ellis commented on 2020-02-20 03:37 (UTC)

@johnabs The convention is that pkgname should track the latest released version while pkgname-git tracks master. Having said that, I will consider including patches for certain bugs (usually specific to Arch Linux), and will do so by including the commit patches from upstream. General fixes/improvements that are part of the usual software development will usually not be included.

For example, the two patch files currently included have been pushed upstream and will be included in the next release, but were only of relevance for Arch Linux (hence why you noticed they are no longer necessary for this newer version).

You are quite welcome to create your own papis-git AUR package, meanwhile, I will wait until the next official release of papis (which will hopefully arrive sooner rather than later).

Thanks for pointing out the missing python-stevedore. I will add it to the PKGBUILD.

johnabs commented on 2020-02-20 02:37 (UTC)


There's a new update in master that Alex and Ale helped me get working with the bug where this hangs after using the picker. Also, there are 2 missing dependencies (python-stevedore, and python-typing_extensions(the latter required for the new commit, it would seem). Additionally, it seems that the two patches that are present are no longer necessary for this newer version. I have an updated PKGBUILD that addresses these issues and pulls from the master branch by default. Would it be more appropriate to create this build I've worked on as a papis-git pkg, or would you like a copy of this updated version to update this particular pkg? (Sorry, I hope this doesn't come off as rude, I'm a bit new to AUR etiquette) Thank you for your time and consideration.


jtlab commented on 2019-12-23 08:24 (UTC) (edited on 2019-12-23 08:47 (UTC) by jtlab)

@JP-Ellis It works now, thanks for your reply.

Just to make sure, so I know what the issue was: you mean reinstall all AUR packages, but there was only papis in site packages. The command you posted also only included papis.

Do I have any control over where the package is installed, or do these python compatiblity issues need to be resolved by package maintainers only?

JP-Ellis commented on 2019-12-23 02:34 (UTC)

@jtlab When there's a major Python update (Python 3.7 -> 3.8), you have to re-install all AUG packages. Until you have done so, you will still have packages in /usr/lib/python3.7). There were some incompatibilities with papis 0.9 which I have now fixed, so perhaps you still had papis in python3.7 simply because it failed to install correctly. It installs correctly into /usr/lib/python3.8 for me now.

In case you need to check for other packages with Python 3.8, you can get a list of all packages which with:

find /usr/lib/python3.7 -exec pacman -Qoq '{}' + | sort -u

JP-Ellis commented on 2019-12-23 02:27 (UTC)

The new release (0.9-2) includes two upstream patches that fixes compatibility issues with Arch Linux's Python packages.

jtlab commented on 2019-12-16 21:26 (UTC) (edited on 2019-12-16 21:28 (UTC) by jtlab)

When I install this package with yay, the papis module is installed into /usr/lib/python3.7/site-packages/papis. I have python 3.8 installed though.

Oddly, all dependencies are installed into /usr/lib/python3.8/site-packages/. My /usr/lib/python3.7/site-packages folder only contains papis and papis-0.9-py3.7.egg-info after install.

Of course this leads to the following error:

The 'papis==0.9' distribution was not found and is required by the application

When I manually copy both dirs (papis and papis-0.9-py3.7.egg-info) from /usr/lib/python3.7/site-packages to /usr/lib/python3.8/site-packages, papis works as expected.

I cloned the official papis github repos to test installing papis from source into user space using the following command derived from the PKGBUILD file: python build && python install --user --optimize=1 --skip-build. The papis module will be installed in .local/lib/python3.8/site-packages.

Since it never happens with installation through pip or setuptools, I assume there is something wrong with this package. My apologies in advance if I am wrong.

JP-Ellis commented on 2019-12-02 22:23 (UTC)

@BrainDamange Apologies for the mishap with the upgrade to 0.9. There is actually an ongoing issue with upper limits on dependencies. I have created an issue and pull request upstream ( and I will update papis then. In the meantime, I'm going to revert back the upgrade on AUR.

BrainDamage commented on 2019-12-02 22:01 (UTC)

the package is missing the following deps: python-doi python-stevedore

thoth101010 commented on 2018-11-21 18:55 (UTC) (edited on 2018-11-21 19:01 (UTC) by thoth101010)

Thank you for your advice, now python-prompt_toolkit is up-to-date.

It seems that python-parse is also required by papis.

( and wants outdated versions of python-slugify and python-click )

JP-Ellis commented on 2018-11-14 01:26 (UTC)

@darehanl Thanks for the feedback. I've updated the dependencies to reflect exactly what's in I've made the changes in the latest version (0.7.4). For earlier versions, you'll have to modify the PKGBUILD yourself unfortunately.

darehanl commented on 2018-11-13 15:58 (UTC)

Thanks for packaging. Seems like there's a few more requirements.

filetype>=1.0.1: No AUR package yet. I just used pip to install this. PyYAML>=3.12: python-pyaml in Community python-slugify==1.2.5: Downgraded AUR python-slugify isbnlib<4.0.0,>=3.9.1: python-isbnlib in AUR

JP-Ellis commented on 2018-11-09 22:53 (UTC) (edited on 2018-11-09 22:55 (UTC) by JP-Ellis)

@thoth101010 Indeed, the latest version of papis requires a more recent version of python-prompt_toolkit than is currently provided ( This has been flagged as out of date for a few months now, and I hope they upgrade soon. (Though I suspect the issue is that ipython and jupyter both require v1 of python-prompt_toolkit).

There are a couple of options you can consider:

  1. Modify the papis PKGBUILD to use python-prompt_toolkit-2 from the AUR, but note that you can't have v1 and v2 two of python-prompt_toolkit-2 concurrently installed.
  2. Install v0.6 of papis in the meantime. You can obtain the PKGBUILD for v0.6 of papis at commit 11e476d.

thoth101010 commented on 2018-11-09 14:20 (UTC) (edited on 2018-11-09 14:21 (UTC) by thoth101010)

It seems that the version of python-prompt_toolkit available on community is only the version 1.0.15-2, but a version >=2.0.0 is required by the package.

Error: Could not find all required packages:
    python-prompt_toolkit>=2.0.0 (Wanted by: papis)

benneti commented on 2018-09-04 19:54 (UTC)

I additionally needed python-pyaml and then still get a missing library problem: raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'filetype>=1.0.1' distribution was not found and is required by papis

JP-Ellis commented on 2018-08-23 12:39 (UTC)

Thanks for the feedback :) I see that python-prompt_toolkit and python-future are indeed a missed dependencies.

As for python-urwidtrees, I think you mean that python-urwid is necessary; I can't find where urwidtrees comes in, but I do see that urwid is used.

kjvbrt commented on 2018-08-23 12:05 (UTC)


the package also depends on: python-urwidtrees python-prompt_toolkit python-future

All the best, Kjvbrt