Package Details: partitionmanager-git 2.2.1.r1167.bedfee3-1

Git Clone URL: https://aur.archlinux.org/partitionmanager-git.git (read-only)
Package Base: partitionmanager-git
Description: A KDE utility that allows you to manage disks, partitions, and file systems. (GIT version)
Upstream URL: http://kde.org/applications/system/kdepartitionmanager
Licenses: GPL2
Conflicts: partitionmanager
Provides: partitionmanager
Submitter: arojas
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 139
Popularity: 0.000276
First Submitted: 2014-02-15 13:33
Last Updated: 2016-10-08 15:24

Latest Comments

sl1pkn07 commented on 2016-10-09 02:10

Try install kpmcore-git

BoBeR182 commented on 2016-10-09 02:07

/tmp/yaourt-tmp-bober/aur-partitionmanager-git/src/partitionmanager/src/gui/createpartitiontabledialog.cpp: In member function ‘void CreatePartitionTableDialog::onMSDOSToggled(bool)’:
/tmp/yaourt-tmp-bober/aur-partitionmanager-git/src/partitionmanager/src/gui/createpartitiontabledialog.cpp:65:24: error: ‘const class Device’ has no member named ‘totalLogical’
if (on && device().totalLogical() > 0xffffffff) {
^~~~~~~~~~~~
make[2]: *** [src/CMakeFiles/partitionmanager.dir/build.make:347: src/CMakeFiles/partitionmanager.dir/gui/createpartitiontabledialog.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:119: src/CMakeFiles/partitionmanager.dir/all] Error 2
make: *** [Makefile:128: all] Error 2

ievans3024 commented on 2015-09-10 22:43

When attempting to upgrade from an older version, pacaur tries to install kpmcore-git but fails because the older version of partitionmanager-git owns some files kpmcore-git is trying to install.

Easy enough to uninstall partitionmanager and reinstall, but it may be worthwhile to see if anything in the package functions can handle that particular scenario.

This may be relevant, so I'm including it:

$ pacaur -Qo /usr/lib/libkpmcore.so
/usr/lib/libkpmcore.so is owned by partitionmanager-git 1.2.1.r921.a630a5c-1

qqqqqqqqq9 commented on 2015-06-09 09:09

Hi,
the dependency kmpcore-git doesn't exist.

sl1pkn07 commented on 2015-02-09 03:13

oh, i see. yes. my fault

fixed

sorry and greetings

igor_isaias commented on 2015-02-09 03:09

@sl1pkn07, the package version is wrong! I have the same error of @Frontier:

"(...) most AUR helpers (Octopi, PacmanXG etc) keep reporting that the package needs updating."

aur/partitionmanager-git v1.2.0.r.-1 -> v1.2.0.r885.c0307bf-1

sl1pkn07 commented on 2015-02-06 14:34

the package version is like a upstream version

http://sl1pkn07.wtf/bleh63.png

https://projects.kde.org/projects/extragear/sysadmin/partitionmanager/repository/revisions/cb6e73c7b014abe2e5ea232947716e5f61ddbef0

greetings

Frontier commented on 2015-02-06 09:25

Hi,

There is something wrong with the package version string; even after updating, most AUR helpers (Octopi, PacmanXG etc) keep reporting that the package needs updating.

sl1pkn07 commented on 2014-08-08 15:21

now partitionmanager start ported to KF5. for the moment don't work with kde4. sorry

greetings

sl1pkn07 commented on 2014-08-08 15:20

now partitionmanager start ported to KF5. for the momento don't work with kde4. sorry

greetings

All comments