Package Details: passwordsafe-debian 0.93BETA-1

Git Clone URL: https://aur.archlinux.org/passwordsafe-debian.git (read-only)
Package Base: passwordsafe-debian
Description: Simple and secure password manager, from Debian package
Upstream URL: http://passwordsafe.sourceforge.net
Licenses: Artistic License 2.0
Conflicts: pwsafe, pwsafe-cvs
Provides: passwordsafe, pwsafe
Submitter: ninian
Maintainer: rfnash
Last Packager: rfnash
Votes: 8
Popularity: 0.000000
First Submitted: 2012-09-20 22:15
Last Updated: 2015-06-17 03:56

Latest Comments

oznah commented on 2014-08-20 20:17

I uninstalled and re-installed and now, no issues

rfnash commented on 2014-07-31 03:49

oznah and rkelly: I haven't noticed slow start times myself. I tried starting under xmonad and pekwm and still didn't notice any problems. I'm not sure what could be causing the problem, nor how to go about figuring it out. You might have better luck reporting the problem to upstream.

oznah commented on 2014-07-30 15:09

0.93BETA-1 - starts up very slow for me as well

rkelly commented on 2014-03-06 18:41

0.93BETA-1 takes a long time to launch. I try to start it up, and it sometimes takes up to a minute to show the splash screen. Sometimes clicking around on the desktop seems to speed it up. I'm seeing this behavior using two window managers (xmonad and pekwm). Thanks.

rfnash commented on 2014-01-12 21:35

Thanks for letting me know. I updated the dependencies as you suggested.

EvertVP commented on 2014-01-11 21:09

wxgtk got updated to 3.0 in the packaging system. This verion of passwordsafe isn't compatible with that, it needs wxgtk2.8. Luckily this package is still mantained in the official repositories. I suggest updating the dependencies of this package to depends=('xerces-c' 'wxgtk2.8' 'ykpers')

tazee commented on 2013-10-10 04:53

Uptill now I was using Wine to run this. Now I can use this and uninstall wine. Thanks for maintaining it.

ninian commented on 2013-09-25 07:47

Version 0.92BETA has been released, incorporating YubiKey authentication support (was previously a separate branch). As I'm not interested in this and hunting down the dependencies, I'm orphaning the package. But if anyone wants to pick it up, here's the PKGBUILD needed. Just add the YubiKey packages in the 'depends' array:

pkgname=passwordsafe-debian
pkgver=0.92BETA
pkgrel=1
pkgdesc="Simple and secure password manager, from Debian package"
arch=('i686' 'x86_64')
url="http://passwordsafe.sourceforge.net"
license=('Artistic License 2.0')
conflicts=('pwsafe' 'pwsafe-cvs')
provides=('pwsafe' 'passwordsafe')
depends=('xerces-c' 'wxgtk' <ADD YUBIKEY PACKAGES>)
install="$pkgname.install"
source=(http://downloads.sourceforge.net/project/passwordsafe/Linux-BETA/0.92/passwordsafe-debian-0.92BETA.i686.deb)
md5sums=('a802346674658f323ce4699e227c92a1')

[ "$CARCH" = "x86_64" ] && source=(http://downloads.sourceforge.net/project/passwordsafe/Linux-BETA/0.92/passwordsafe-debian-0.92BETA.amd64.deb)
[ "$CARCH" = "x86_64" ] && md5sums=('04ec5b9ef9a3d29e8f32b2e6e6616a9c')


package() {
cd "$srcdir"
if [ "$CARCH" = "x86_64" ]; then
ar x $pkgname-$pkgver.amd64.deb
else
ar x $pkgname-$pkgver.$arch.deb
fi
tar xzf data.tar.gz -C "$pkgdir/"
cd "$pkgdir/usr/share"
mkdir -p applications
mkdir -p pixmaps
cp pwsafe/pwsafe.desktop applications/
cp pwsafe/pwsafe.png pixmaps/
}

ninian commented on 2012-12-26 09:46

Updated to version 0.9BETA.

ninian commented on 2012-11-21 22:34

Thank you for testing - wxgtk added as a dependency.

EvertVP commented on 2012-11-21 20:30

Got error message:

pwsafe: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0: cannot open shared object file: No such file or directory

Added wxgtk: https://www.archlinux.org/packages/extra/x86_64/wxgtk/
Worked.

ninian commented on 2012-11-21 20:20

PKGBUILD updated to also include x86_64.
Should work, but I don't have a 64-bit system to test it on.

EvertVP commented on 2012-11-21 19:09

Makepkg makes a .deb

EvertVP commented on 2012-11-21 19:06

==> ERROR: passwordsafe-debian is not available for the 'x86_64' architecture.
Note that many packages may need a line added to their PKGBUILD
such as arch=('x86_64').

Could you update the pkgbuild file?