Package Details: patator 0.9-1

Git Clone URL: (read-only, click to copy)
Package Base: patator
Description: A multi-purpose bruteforcer
Upstream URL:
Licenses: GPL2
Submitter: alub
Maintainer: ljmf00
Last Packager: ljmf00
Votes: 18
Popularity: 0.000000
First Submitted: 2012-01-08 10:32 (UTC)
Last Updated: 2021-04-03 16:36 (UTC)

Dependencies (13)

Required by (0)

Sources (1)

Latest Comments

MarsSeed commented on 2022-05-26 23:07 (UTC)

This is compatible with Python 3. Several optional dependencies are broken or missing. Could you maybe switch this package to Python 3?

zoorat commented on 2021-11-10 14:11 (UTC)

missing dependencies "python2-pycurl" , "python2-pysnmp"

PushThemBricks commented on 2021-06-05 00:12 (UTC)

Hello, I would like to suggest some changes to the PKGBUILD file, patator (and its modules) now work with python3 so we can replace its python2 dependency along with the optional dependencies to their python3 counterparts, since python3 is the default interpreter on Arch. Here is the diff between the current PKGBUILD and the one with my proposed changes:

--- PKGBUILD_old    2021-04-03 13:35:02.000000000 -0300
+++ PKGBUILD            2021-06-04 13:20:39.583647691 -0300
@@ -7,18 +7,18 @@
-  'python2-paramiko: SSH'
-  'python2-pycurl: HTTP'
+  'python-paramiko: SSH'
+  'python-pycurl: HTTP'
   'openldap: LDAP'
   'impacket: SMB'
   'mysql-python: MySQL'
-  'python2-psycopg2: PostgreSQL'
-  'python2-crypto: VNC'
-  'python2-pydns: DNS'
-  'python2-pysnmp: SNMP'
-  'python2-ipy: NETx keywords'
+  'python-psycopg2: PostgreSQL'
+  'python-cryptography: VNC'
+  'python-pydns: DNS'
+  'python-pysnmp: SNMP'
+  'python-ipy: NETx keywords'
   'java-runtime: keystore files'
   'unzip: zip archives'
@@ -26,7 +26,7 @@

 build() {
-  sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|g' -i "$srcdir/${pkgname}-$pkgver/${pkgname}.py"
+  sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python|g' -i "$srcdir/${pkgname}-$pkgver/${pkgname}.py"

Sirat18 commented on 2014-12-10 12:24 (UTC)

Moved to git and currently v0.7-beta there.

alub commented on 2013-04-04 12:42 (UTC)

@fxbru: I have put all dependencies (including python2-pycurl) as optdepends because this script has many non-intersecting uses and fetching java-runtime or openldap seems exagerated if you only want to bruteforce HTTP.

fxbru commented on 2013-04-04 12:36 (UTC)

Hi, thanks for this PKGBUILD. Should'nt be extra/python2-pycurl>=7.19 added as a depedency, as it is required for the http_fuzz module ?