Package Details: patool-py2 1.12-2

Git Clone URL: https://aur.archlinux.org/patool.git (read-only)
Package Base: patool
Description: portable command line archive file manager (Python2)
Upstream URL: https://wummel.github.io/patool/
Keywords: archiv
Licenses: GPL
Conflicts: patool
Submitter: None
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 5
Popularity: 0.000002
First Submitted: 2013-02-25 06:33
Last Updated: 2017-01-22 03:44

Dependencies (6)

Required by (3)

Sources (1)

Latest Comments

1 2 Next › Last »

TrialnError commented on 2017-01-24 09:47

Since ever, or since the change where I added --optimize=1?
If the first, then it should probably be brought to upstream

gandalf3 commented on 2017-01-22 20:52

The contents of /usr/lib/python3.6/site-packages/patool-1.12-py3.6.egg-info/ seem to be lacking read permissions, 640 rather than 644.

This causes all python imports to fail

TrialnError commented on 2015-01-26 12:05

@jschmoe: It seems yaourt cannot handle packages that are from the same PKGBuild and conflicting each other. This is a fault in yaourt. The issue should be avoided if you remove the conflicts line (aka both packages should be build).
The naming and setting of variables itself is correct (see Split-PKGBuilds. The pkgbase var can just hold the main and only name. In pkgname you can declare all the names of all the packages you want to create with the PKGBuild)
The conclicts line is somewhat necessary because the binary is installed with both python versions under patool and I didn't want to rename one of the binaries (Could be misleading if patool2 or whatever). And it doesn't make sense to have both python versions installed.

jschmoe commented on 2015-01-24 11:50

i still get the following error until i change pkgname=('patool' 'patool-py2')
into pkgname=('patool') in the PKGBUILD. maybe you can't have two names there?!
haven't tried to install patool-py2 but i think the installation works with pkgname=('patool-py2')

resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: patool-py2 and patool are in conflict
==> WARNING: Your packages are saved in /tmp/yaourt-....

TrialnError commented on 2015-01-21 14:09

@jschmoe: And how to diff between the python2 and python3 packages? They're separate packages, not one package that installs python2 and python3 version

@dront78: DL is working for me (but there is a redirect now). But will change it to the pypi dl-link as the homepage now points to it

TrialnError commented on 2015-01-21 14:07

@jschmoe: And how to diff between the python2 and python3 packages? They're separate packages, not one package that installs python2 and python3 version

@dront78: DL is working for me. But will change it to the pypi dl-link as the homepage now points to it

dront78 commented on 2015-01-18 15:34

could you fix also

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading 1.7.tar.gz
Aborting...
==> ERROR: Makepkg was unable to build patool.
==> Restart building patool ? [y/N]
==> -------------------------------
==>
==> ERROR: unable to update

jschmoe commented on 2015-01-18 10:26

in PKGBUILD please change:
pkgname=('patool' 'patool-py2')
into
pkgname=('patool')

TrialnError commented on 2015-01-15 11:23

@wil93: This PKGBuild now provides a python2 version of patool

wil93 commented on 2015-01-10 01:39

Hi, could you add patool for python2? (in a separate package or in this same package)