Package Details: pcmanfm-git 0.0.0.0-1

Git Clone URL: https://aur.archlinux.org/pcmanfm-git.git (read-only)
Package Base: pcmanfm-git
Description: An extremely fast, lightweight, yet feature-rich file manager with tabbed browsing
Upstream URL: http://pcmanfm.sourceforge.net/
Licenses: GPL
Conflicts: pcmanfm
Provides: pcmanfm
Submitter: tdy
Maintainer: None
Last Packager: quomoow
Votes: 124
Popularity: 0.000016
First Submitted: 2010-01-16 01:05
Last Updated: 2016-10-21 19:47

Dependencies (7)

Required by (5)

Sources (1)

Latest Comments

quomoow commented on 2016-10-23 23:30

Package not working please wait

quomoow commented on 2016-10-20 20:07

added libfm-gtk-lib what not work cos of non-existend dependency (yet) help me or give me a time

kyrias commented on 2016-05-18 09:24

I don't really have time to maintain this properly at the moment since I don't use it anymore. Someone who does, please adopt it.

gauthma commented on 2016-01-24 23:09

When trying to install this with pkgbuilder it complains that it can't find any .SRCINFO file...

Problem with pkgbuilder or with the AUR package?

aethel commented on 2015-10-27 16:41

@Kyrias

One of the dependencies seems to be broken, I fixed it locally doing this:
- change libfm-gtk-git to libfm-gtk3-git
- add --with-gtk=3 to ./configure args

Thanks!

City-busz commented on 2015-04-15 17:24

The pcmanfm.install file shouldn't be added to the sources=() array. And 'pkg-config' shouldn't be added to the makedepends=() array, because it's part of the base-devel group.

LeonardK commented on 2014-08-02 09:17

is udisks no optional dep anymore?

orschiro commented on 2014-05-11 21:15

@Kyrias

Can you please add lxmenu-data as an optional dependency?

It is actually preferred over gnome-menus, smaller and resolves an issue with empty open with dialogs.

See also this bug report: https://sourceforge.net/p/pcmanfm/bugs/864/?limit=25

Thanks!

kyrias commented on 2013-11-01 21:17

No idea of how that happened, fixed now though.

psychotrome commented on 2013-11-01 17:52

Fails to clone git repository with:

fatal: unable to access 'https://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm/': SSL: no alternative certificate subject name matches target host name 'pcmanfm.git.sourceforge.net'

Changing "git+https://*" to just "git://*" fixed it. (Sourceforge support told me they don't allow https cloning through irc.)

kyrias commented on 2013-10-22 16:39

No problem, feel free to tell me if there's anything you'd like changed.

stevenvdb commented on 2013-10-22 11:25

sry marked wrongly as outdated

jleclanche commented on 2013-08-03 20:02

Please change dependency from libfm-git to libfm-gtk-git.

Alister.Hood commented on 2013-07-22 05:01

I think this needs to be updated to depend on libfm-gtk-git instead.

KaiSforza commented on 2013-04-10 21:44

This should be updated to reflect the new pacman 4.1 source array and version scheme.

jynnantonix commented on 2013-02-27 06:50

@desperat

I just rebuilt the package and the md5sums are valid. Whatever the issue is must have been on your end.

jynnantonix commented on 2013-02-27 06:47

@desperat

I just rebuilt the package and the md5sums are valid. Whatever the issue is must have been on your end.

desperat commented on 2013-02-15 16:02

My suggestion: try "spacefm-git" instead.

desperat commented on 2013-02-15 15:23

jynnantonix version - automake patch md5 sum wrong as well in libfm-git

M4rQu1Nh0S commented on 2013-01-23 08:31

jynnantonix version work good!
maintainer, use this!

jynnantonix commented on 2013-01-15 08:57

Fails with "You must have automake >= 1.11 installed." and then later "configure.ac:13: error: 'AM_PROG_CC_STDC': this macro is obsolete."

I uploaded patches and an updated PKGBUILD here (https://github.com/jynnantonix/PKGBUILDs/tree/master/pcmanfm-git)

I've also submitted the patches upstream:
automake(https://sourceforge.net/tracker/?func=detail&aid=3600900&group_id=156956&atid=801864)
configure.ac(https://sourceforge.net/tracker/?func=detail&aid=3600913&group_id=156956&atid=801864)

oblique commented on 2012-07-23 00:01

please replace make with: make LDFLAGS="-lm ${LDFLAGS}"

Alister.Hood commented on 2012-07-18 07:01

Yes, I tend to follow bugs after reporting them :)
To be honest, I haven't upgraded automake again to test it. I was just trusting that it really is fixed.

Anonymous comment on 2012-07-17 09:36

@Alister.Hood The problem with automake 1.12 has been fixed now in the libfm Git master:

http://pcmanfm.git.sourceforge.net/git/gitweb.cgi?p=pcmanfm/libfm;a=commit;h=35f0fe5d59c6209148660d2c3af33956fd0c6631

Alister.Hood commented on 2012-06-03 12:16

I reported that as a bug https://sourceforge.net/tracker/?func=detail&aid=3531471&group_id=156956&atid=801864

And I used downgrade to downgrade from automake 1.12 so I could build it.

gymka commented on 2012-05-27 09:09

@gumper it want's either automake 1.10 either 1.11, not atleast 1.10(why? imho it's stupid logic) before line "./autogen.sh" add line "sed -i 's/if \[ "$AM_INSTALLED_VERSION" != "1\.10"/if \[ "$AM_INSTALLED_VERSION" != "1.12"/' ./autogen.sh" and it will work as it should.

gumper commented on 2012-05-19 02:39

When building libfm-git it fails and tells me that I need to have automake 1.10 or 1.11 installed. I have versions 1.12-1 and version 1.10.3-1 installed. Any idea why I get this message?

mango commented on 2012-03-14 05:52

add depends: lxmenu-data

ridikulusrat commented on 2012-01-20 16:33

@anonymous-arch: Has this patch been accepted upstream?

anonymous-arch commented on 2012-01-20 14:10

The right-click crash is a call to a NULL function pointer on line 1329 in main-win.c because the parent class's signal handler was NULL. This patch fixes the crash:

--- a/src/main-win.c 2012-01-17 22:32:03.000000000 -0000
+++ b/src/main-win.c 2012-01-17 22:49:19.000000000 -0000
@@ -1326,7 +1326,14 @@
act = gtk_ui_manager_get_action(win->ui, "/Next2");
gtk_action_activate(act);
}
- return GTK_WIDGET_CLASS(fm_main_win_parent_class)->button_press_event(w, evt);
+ if(GTK_WIDGET_CLASS(fm_main_win_parent_class)->button_press_event)
+ {
+ return GTK_WIDGET_CLASS(fm_main_win_parent_class)->button_press_event(w, evt);
+ }
+ else
+ {
+ return FALSE;
+ }
}

static void on_reload(GtkAction* act, FmMainWin* win)

Anonymous comment on 2012-01-15 11:33

Bug with closing pcmanfm while rigth-clicking affects me too. Removing ./config/{libfm,pcmanfm} not helps.
Pcmanfm works well if I use detailed list view- in this mode right-clicking works correctly.
Version of pcmanfm from repo works correctly with right-click in all modes.
Sorry for my english.

smoge commented on 2011-12-27 22:53

Try to remove ./config/{libfm,pcmanfm}. If it happens again report the issue to upstream. Or even better, isolate the commit that broke it with git bisect and report it.

Anonymous comment on 2011-12-22 03:00

Just installed pcmanfm-git (Dec 22, 2011).
I get "Segmentation fault" when right-clicking.
Anyone knows why?

Hund commented on 2011-05-19 09:56

==> Connecting to git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm...
fatal: Not a git repository (or any of the parent directories): .git
-> Local files updated
fatal: repository 'pcmanfm' does not exist
==> ERROR: A failure occurred in build().
Aborting...

drexya commented on 2011-05-11 11:47

If you don't like the very small size of the icons in the toolbar, add this to the PKGBUILD just before "msg "Starting make..."" :

sed -e '/gtk_toolbar_set_icon_size(GTK_TOOLBAR(win->toolbar), GTK_ICON_SIZE_SMALL_TOOLBAR);/d' \
-e '/gtk_toolbar_set_style(GTK_TOOLBAR(win->toolbar), GTK_TOOLBAR_ICONS);/d' \
-i "src/main-win.c"

Andrwe commented on 2011-01-02 16:34

Hi,

there is an failure in the makedepends:
makedepends=('git' 'intltool' 'pkgconfig')

"pkgconfig" is since some time called "pkg-config" it only works until now because the package provides "pkgconfig" but this may be changed in future.
Would you please correct this?

Regards
Andrwe

jskier commented on 2010-10-14 00:38

Desktop is displayed properly but I can't use the file manager itself, it segfaults:

pcmanfm[3190]: segfault at 2c ip 00007f069bfc5d44 sp 00007fff97523bd0 error 6 in libglib-2.0.so.0.2600.0[7f069bf84000+e6000]

Anonymous comment on 2010-09-17 21:11

Please add lxmenu-data as dependency, the file-open dialog doesn't work without it.

Det commented on 2010-07-31 08:50

conflicts=pcmanfm?

└┌(%:~)┌- pql pcmanfm |grep bin
pcmanfm /usr/bin/
pcmanfm /usr/bin/pcmanfm
┌┌(det@Archlinux)┌(71/pts/3)┌(11:48am:07/31/10)┌-
└┌(%:~)┌- pql pcmanfm-git |grep bin
pcmanfm-git /usr/bin/
pcmanfm-git /usr/bin/pcmanfm

swiftgeek commented on 2010-06-29 00:55

What about http://blog.lxde.org/?p=759 ?

knedlyk commented on 2010-06-09 07:18

Problem with fo.po fixed.

Anonymous comment on 2010-06-05 08:07

file=`echo fo | sed 's,.*/,,'`.gmo \
&& rm -f $file && /usr/bin/msgfmt -o $file fo.po
fo.po:38: `msgid' and `msgstr' entries do not both end with '\n'
/usr/bin/msgfmt: found 1 fatal error
make[2]: *** [fo.gmo] Error 1
make[2]: Leaving directory `/tmp/clyde-james/pcmanfm-git/pcmanfm-git/src/pcmanfm-build/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/clyde-james/pcmanfm-git/pcmanfm-git/src/pcmanfm-build'
make: *** [all] Error 2

Anonymous comment on 2010-05-26 22:44

What is the deal with the busted 'new tab' icon? its been like this for over a month, just seems wierd of all the things they havent fixed that. I just get a default icon for the plus/crosshair icon, regardless of theme. stable pcmanfm doesnt have the issue. Just wondering if anyone has found a workaround.

knedlyk commented on 2010-05-23 19:55

You should add in PKGBUILD before ./autogen.sh:

sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" configure.ac
sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" data/Makefile.am
sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" po/POTFILES.skip

Or better to rename pcmanfm2.desktop.in:

cp data/pcmanfm2.desktop.in data/pcmanfm.desktop.in

knedlyk commented on 2010-05-23 19:52

Should add in PKGBUILD before ./autogen.sh:

sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" configure.ac
sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" data/Makefile.am
sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" po/POTFILES.skip

knedlyk commented on 2010-05-23 19:39

Should add in PKGBUILD before ./autogen.sh :

sed -i -e "s/pcmanfm.desktop/pcmanfm2.desktop/" configure.ac

Duologic commented on 2010-05-11 14:51

I've installed gvfs but no automounting. Any ideas?

karabaja4 commented on 2010-03-31 01:02

Optional dependencies (at the moment pcmanfm 0.9.3):

gvfs - mounting of local and remote drives
gnome-menus - for applications menu and "Open with..." dialog