Package Details: pcmanfm-qt-git 0.10.1.40.gc23f78e-1

Git Clone URL: https://aur.archlinux.org/pcmanfm-qt-git.git (read-only)
Package Base: pcmanfm-qt-git
Description: The LXQt file manager, Qt port of PCManFM
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: pcmanfm-qt
Provides: pcmanfm-qt
Submitter: adaptee
Maintainer: jleclanche
Last Packager: jleclanche
Votes: 46
Popularity: 0.186724
First Submitted: 2013-03-05 06:33
Last Updated: 2016-04-20 03:04

Required by (3)

Sources (1)

Latest Comments

ArthurBorsboom commented on 2016-03-21 12:28

If I am correct, libfm-qt-git should be set as a dependency, since the package does not compile on my system without it.

stefonarch commented on 2015-12-09 11:46

Thanks, it seems fixed now, once reinstalled pcmanfm-qt-git:
$ yaourt -Qi pcmanfm-qt-git
Name : pcmanfm-qt-git
Version : 0.10.1-1

pmattern commented on 2015-12-09 11:37

@contadino
This was due to setting textual tag "split-libfm-qt", see https://github.com/lxde/pcmanfm-qt/releases. AUR helpers (at least those I know) always compare the version that's installed on the system with the one stated by AUR's API, and textual versions are per se considered older than numerical ones.
I just added another tag "0.10.1" which should fix the problem.

stefonarch commented on 2015-12-09 10:20

There'is still something wrong with the package versions for me, yaourt *always" wants to update pcmanfm-qt-git:

$ yaourt -Syua
:: Synchronizing package databases...
...
Foreign packages: - 102 / 102

==> Software upgrade (new version) :
aur/pcmanfm-qt-git split.libfm.qt.14.ga753304-1 -> 0.9.0.14.g643dcf6-1
....
$ yaourt -Qi pcmanfm-qt-git
Name : pcmanfm-qt-git
Version : split.libfm.qt.14.ga753304-1


LeonardK commented on 2015-12-07 11:50

This doesn't build without libfm-qt anymore as pointed out before, so it should be changed to build split by default, ie. add:

makedepends('libfm-qt-git')
CMAKE_PREFIX_PATH=/usr/share/cmake/fm-qt

pmattern commented on 2015-12-04 11:35

@hotvic
> [...] "libfm-qt-git" is a make depend and maybe a depend too ?
But that's exactly what I said in my previous comment!? In fact libfm-qt-git is a runtime dependency of PCManFM-Qt, see e. g. output of 'ldd /usr/bin/pcmanfm-qt | grep libfm', and if it gets stated in variable depends it will be treated as build dependency automatically, too.

hotvic commented on 2015-12-03 22:42

In addition to @pmattern please note that "libfm-qt-git" is a make depend and maybe a depend too ?

pmattern commented on 2015-12-01 11:31

Now that libfm-qt was moved into a repository on its own this package has to depend on libfm-qt-git.

toni10 commented on 2015-02-12 10:05

hi,
Anyone knows if `pcmanfm-qt` has a file search option?

I used `pcmanfm` which had one under: Tools -> Find files ....

Thanks

toni10 commented on 2015-02-12 10:04

hi,
Anyone knows if does `pcmanfm-qt` have a file search option?

I used `pcmanfm`which had one under: Tools - Find files ....

Thanks

pmattern commented on 2015-01-22 21:12

Package fails to install as it's treating /usr/lib64 as directory. Same problem and hence solution (-DCMAKE_INSTALL_LIBDIR=lib) as seen with e. g. liblxqt-git recently.

Would help save a lot of time while testing LXQt if you could fix this.

ArthurBorsboom commented on 2014-10-18 07:38

/tmp/yaourt-tmp-arthur/aur-pcmanfm-qt-git/src/pcmanfm-qt/pcmanfm/application.cpp:360:3: error: ‘commitData’ is not a member of ‘QApplication’
QApplication::commitData(manager);

jleclanche commented on 2014-07-08 01:21

http://sourceforge.net/p/lxde/mailman/message/32572840/

ooijevaer commented on 2014-07-08 01:09

I haven't been able to clone the Git repo to install this package these last few days, even though the repo is accessible through the web. Changing the PKGBUILD source variable to:

source=("git://github.com/lxde/$_pkgname.git")

fixed the problem. Please consider updating the PKGBUILD.

misgod commented on 2014-07-05 14:37

You should install qt5-x11extras and qt5-tools

MightyPork commented on 2014-07-03 12:44

This package fails to upgrade / install, with error:
CMake Error at CMakeLists.txt:20 (find_package):
By not providing "FindQt5X11Extras.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"Qt5X11Extras", but CMake did not find one.

Could not find a package configuration file provided by "Qt5X11Extras" with
any of the following names:

Qt5X11ExtrasConfig.cmake
qt5x11extras-config.cmake

Add the installation prefix of "Qt5X11Extras" to CMAKE_PREFIX_PATH or set
"Qt5X11Extras_DIR" to a directory containing one of the above files. If
"Qt5X11Extras" provides a separate development package or SDK, be sure it
has been installed.

flu commented on 2014-06-29 08:31

It fails configuration/compilation on my machine without the package 'qt5-x11extras' installed.

blackhole commented on 2014-06-09 20:02

If I move an icon to some other place in the desktop it will stick at the top left corner.
Tried everything, I have also added a new user with completly new configuration, no way...

I have checked desktop-items-0.conf. There are some dektop items that are not really present. But deleting the fille will not solve the problem.

It is a known bug?

blackhole commented on 2014-05-14 19:51

No search tool inside this package?

blackhole commented on 2014-05-14 19:50

No search tool inside this package?

jleclanche commented on 2014-05-12 07:10

Try installing oxygen-icons.

Alister.Hood commented on 2014-05-12 07:09

Hi guys, I have hardly any icons, e.g. no folder icons or icons in the toolbar. Is there a trick to get icons?

flexiondotorg commented on 2014-05-09 14:01

Please add a `.install` files as `namcap` reports the following:

pcmanfm-qt-git E: Mime type handler found. Add "update-desktop-database -q" to the install file

goetzc commented on 2014-03-20 22:19

It now requires libfm-git

jleclanche commented on 2014-02-20 10:41

Just install libqtxdg-git first. It provides libqtxdg.

Theredbaron1834 commented on 2014-02-20 04:22

Fails to install by default. To fix simply edit the pkgbuild, and replace libqtlxdg with libqtlxdg-git (there is no liblxqt package anymore).

stevenvdb commented on 2013-10-22 11:27

check http://wiki.lxde.org/en/Build_LXDE-Qt_From_Source#pcmanfm-qt for new source link and dependencies

adaptee commented on 2013-10-06 03:37

The problem within fm-simple-job.h is fixed in libfm-git master.

esclapion commented on 2013-10-05 13:39

works now, thanks :)

Ilya87 commented on 2013-10-05 06:42

There is a typo in include/libfm/fm-simple-job.h (string 26)
#include <fm-job.h>
should be #include "fm-job.h"

esclapion commented on 2013-10-04 15:47

/usr/local/include/libfm/fm-simple-job.h:26:20: erreur fatale: fm-job.h : Aucun fichier ou dossier de ce type

esclapion commented on 2013-10-04 15:47

adaptee commented on 2013-05-17 01:53

ensure your libfm-git is up-to-date.

nuc commented on 2013-05-17 00:20

Build fails: https://gist.github.com/Nuc1eoN/5596136

nuc commented on 2013-05-17 00:18

Build fails:
Updating '/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/pcmanfm/pcmanfm-qt_pt.qm'...
Generated 0 translation(s) (0 finished and 0 unfinished)
Ignored 180 untranslated source text(s)
[ 45%] [ 46%] [ 47%] [ 48%] Building CXX object libfm-qt/CMakeFiles/fm-qt.dir/bookmarkaction.cpp.o
Building CXX object libfm-qt/CMakeFiles/fm-qt.dir/sidepane.cpp.o
Building CXX object libfm-qt/CMakeFiles/fm-qt.dir/icontheme.cpp.o
Building CXX object libfm-qt/CMakeFiles/fm-qt.dir/libfmqt.cpp.o
/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/libfmqt.cpp:20:22: schwerwiegender Fehler: libfm/fm.h: Datei oder Verzeichnis nicht gefunden
#include <libfm/fm.h>
^
Kompilierung beendet.
make[2]: *** [libfm-qt/CMakeFiles/fm-qt.dir/libfmqt.cpp.o] Fehler 1
make[2]: *** Warte auf noch nicht beendete Prozesse...
Bringe 'translations/pcmanfm-qt_lt_LT.ts' auf aktuellen Stand...
Found 180 source text(s) (0 new and 180 already existing)
[ 49%] Generating pcmanfm-qt_lt_LT.qm
Updating '/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/pcmanfm/pcmanfm-qt_lt_LT.qm'...
Generated 0 translation(s) (0 finished and 0 unfinished)
Ignored 180 untranslated source text(s)
[ 49%] Built target pcmanfm_translations
Scanning dependencies of target update_translations
[ 49%] Built target update_translations
In file included from /tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/icontheme.cpp:21:0:
/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/icontheme.h:25:22: schwerwiegender Fehler: libfm/fm.h: Datei oder Verzeichnis nicht gefunden
#include "libfm/fm.h"
^
Kompilierung beendet.
make[2]: *** [libfm-qt/CMakeFiles/fm-qt.dir/icontheme.cpp.o] Fehler 1
In file included from /tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/bookmarkaction.cpp:21:0:
/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/bookmarkaction.h:25:22: schwerwiegender Fehler: libfm/fm.h: Datei oder Verzeichnis nicht gefunden
#include <libfm/fm.h>
^
Kompilierung beendet.
make[2]: *** [libfm-qt/CMakeFiles/fm-qt.dir/bookmarkaction.cpp.o] Fehler 1
In file included from /tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/sidepane.h:27:0,
from /tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/sidepane.cpp:21:
/tmp/packerbuild-1000/pcmanfm-qt-git/pcmanfm-qt-git/src/pcmanfm-qt-build/libfm-qt/placesview.h:25:22: schwerwiegender Fehler: libfm/fm.h: Datei oder Verzeichnis nicht gefunden
#include <libfm/fm.h>
^
Kompilierung beendet.
make[2]: *** [libfm-qt/CMakeFiles/fm-qt.dir/sidepane.cpp.o] Fehler 1
make[1]: *** [libfm-qt/CMakeFiles/fm-qt.dir/all] Fehler 2
make: *** [all] Fehler 2
==> FEHLER: Ein Fehler geschah in build().
Breche ab ...
The build failed.