Package Details: pd-l2ork 20161118.r1722.de1ee11-1

Git Clone URL: https://aur.archlinux.org/pd-l2ork.git (read-only)
Package Base: pd-l2ork
Description: L2Ork (Linux Laptop Orchestra) version of PureData
Upstream URL: http://l2ork.music.vt.edu/main/?page_id=56
Licenses: BSD
Conflicts: pd-l2ork
Submitter: paum
Maintainer: pure-aur
Last Packager: pure-aur
Votes: 9
Popularity: 0.135109
First Submitted: 2013-01-28 10:47
Last Updated: 2016-11-19 18:10

Dependencies (45)

Sources (3)

Latest Comments

aggraef commented on 2017-02-17 12:10

@wintermute: Thanks for your report, but you posted to the wrong package. :) The libunicap package is actually to blame here, which is maintained by someone else, so please complain there: https://aur.archlinux.org/packages/libunicap/. The required changes are trivial, see https://gist.github.com/agraef/aac0b12a4c1db02521920bf5fc08b1b4

wintermute commented on 2017-02-14 08:01

I'm unable to install this, with the error:
Dependency `pkgconfig intltool' of `purr-data' does not exist.

aggraef commented on 2017-01-27 21:28

Updated the link to my Bitbucket page with the binary repository which is at https://l2orkaur.bitbucket.io/ now. (Bitbucket recently went from using http to https for the web pages, that's why. But it's exactly the same page.)

kalimerox commented on 2016-07-07 10:50

aggraef thank you so much for this!! I managed to install flite the way you described and everything works! :)

aggraef commented on 2016-07-04 16:50

kalimerox, it's a common problem of all the flite packages in the AUR, and nobody seems to know how to fix it. If you download the package with `yaourt -G flite1` and run `cd flite1` and then `makepkg -i`, it should build and install all right. Or you can just use the binary packages at https://l2orkaur.bitbucket.io/, that will save you a lot of trouble and time.

kalimerox commented on 2016-07-04 14:49

Hi there, I cant get pd-l2ork to run on my computer...

I stumble over installing flite, I tried all the different versions and non of them can be compiled to my system (manjaro) do you have any idea why? It happens on both my machines.. I get this error:

../../..//tmp/yaourt-tmp-kalimerox/aur-flite/lib/libflite.shared.a: No such file or directory
make[2]: *** [../../config/common_make_rules:116: /tmp/yaourt-tmp-kalimerox/aur-flite/obj/src/audio/.build_so] Error 1
make[1]: *** [../config/common_make_rules:133: /tmp/yaourt-tmp-kalimerox/aur-flite/obj/src/.make_build_dirs] Error 2
make: *** [config/common_make_rules:133: /tmp/yaourt-tmp-kalimerox/aur-flite/obj//.make_build_dirs] Error 2
==> ERROR: A failure occurred in build().


aggraef commented on 2016-06-15 22:44

Please note that I turned this package into a static snapshot of the latest upstream release now (upstream version 20160614 at the time of this writing), so you'll hopefully see less intermittent failures of the package, and also less updates. For those of you who prefer to live on the bleeding edge I've created a new pd-l2ork-git package here: https://aur.archlinux.org/packages/pd-l2ork-git

aggraef commented on 2016-06-08 22:26

Obviously this package can be tricky to install and it also takes a long time to build which wastes everybody's time. So I made a binary package available in the package repository at https://l2orkaur.bitbucket.io/. (Please follow the link for instructions on how to add the repo to your pacman.conf.)

Franek commented on 2016-06-08 20:20

For future readers: The main source of error turned out to be that I had linked /bin/sh to dash (not bash, as usual) on my system, and that the pd-l2ork build scripts contain bashisms. So just make sure that /bin/sh links to bash when building pd-l2ork.

Franek commented on 2016-06-07 17:37

Done:
https://github.com/agraef/aur-pkgbuilds/issues/1
I appreciate any help, but it's not urgent.

All comments