Package Details: peazip-qt-build 6.4.1-1

Git Clone URL: https://aur.archlinux.org/peazip-qt-build.git (read-only)
Package Base: peazip-qt-build
Description: Free cross-platform file archiver (compiles from source)
Upstream URL: http://peazip.org
Licenses: GPL3
Conflicts: peazip, peazip-gtk2, peazip-gtk2-build, peazip-qt, peazip-qt-opensuse, peazip-qt-opensuse-latest
Provides: peazip, peazip-qt
Submitter: uncle
Maintainer: uncle
Last Packager: uncle
Votes: 7
Popularity: 0.338544
First Submitted: 2015-09-07 22:41
Last Updated: 2017-05-07 22:38

Latest Comments

FadeMind commented on 2017-02-02 15:03

Improved and fixed PKGBUILD

https://github.com/FadeMind/mnjpkgbuilds/tree/master/00-PEAZIP.PKG/peazip-qt-build

Regards

FadeMind commented on 2017-02-02 08:13

I have one issue. `conf.txt` file is in read-only mode (root permissions).
I workaround this via

sudo chown 1000:100 /opt/peazip/res/conf.txt

uncle commented on 2016-11-22 01:36

I updated the PKGBUILD so that it explicitly specifies Arch's (non-default) lazarus directory location, thanks for the tip, @fdservices ;-)

fdservices commented on 2016-08-19 07:47

To make this work I had to run lazarus and set the correct directory in the set up.

Don't take my word for it, but it may be that "--lazarusdir=/usr/lib/lazarus" should be added to the lazarus command.

fdservices commented on 2016-08-19 06:59

I have a build error:
==> Starting build()...
Error: (lazarus) invalid Lazarus directory "": directory lcl not found
Error: (lazarus) Building failed: project_pea.lpi
Error: (lazarus) invalid Lazarus directory "": directory lcl not found
Error: (lazarus) Building failed: project_gwrap.lpi
Error: (lazarus) invalid Lazarus directory "": directory lcl not found
Error: (lazarus) Building failed: project_peach.lpi

uncle commented on 2016-03-06 19:09

This package works now.

uncle commented on 2015-12-01 00:03

The file structure and design of the peazip linux package seems to have changed drastically from 5.8.1 to 5.9.0. I don't have the time right now to re-write the PKGBUILD so for the time-being I have rolled the package back to 5.8.1. I will take a closer look at it in the next few days and see if I can figure it out.

uncle commented on 2015-09-27 00:42

I have been having problems getting this to run on my system recently, but am working on a fix.