Package Details: peazip-qt5 9.7.1-1

Git Clone URL: https://aur.archlinux.org/peazip-qt5.git (read-only, click to copy)
Package Base: peazip-qt5
Description: Free file archiver utility, open, extract RAR TAR ZIP archives
Upstream URL: https://peazip.github.io/
Licenses: GPL3
Conflicts: peazip
Provides: peazip
Submitter: huyz
Maintainer: huyz
Last Packager: huyz
Votes: 18
Popularity: 0.21
First Submitted: 2021-05-27 15:19 (UTC)
Last Updated: 2024-02-23 13:12 (UTC)

Dependencies (11)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

MBK commented on 2024-02-13 13:59 (UTC)

The 9.7.0-1 PKGBUILD sets up a bad link for 7zip to /usr/bin/7zz. 7zz does not exist with 7zip-full, the link should point to /usr/bin/7z.

MBK commented on 2024-01-25 15:26 (UTC) (edited on 2024-01-25 15:31 (UTC) by MBK)

The build (of v9.6.0-1) fails now that Lazarus has been updated to v3.0.

The peazip developer has posted this:

The error stopping the build can be fixed adding LazFileUtils in uses section of peach.pas

This is due to some functions moved from fileutil to LazFileUtils in Lazarus 3.x. The change allows to build the sources both in Lazarus 2.x and 3.x

He is currently testing the next release of PeaZip with Lazarus 3.x, to be sure all works as expected on different target operating system, it should be ready in a few weeks.

cpatrick08 commented on 2023-05-12 02:06 (UTC)

The Upstream URL has changed to https://peazip.github.io/

MoetaYuko commented on 2023-03-03 13:14 (UTC)

Please consider providing desktop integration packages. There are additional .desktop files provided in the freedesktop_integration folder, where a readme file is also available. Support for different file managers can be packaged as split packages, as beyond compare does in https://aur.archlinux.org/packages/bcompare-kde5

huyz commented on 2022-04-20 07:04 (UTC)

@IncredibleLaser Fixed.

IncredibleLaser commented on 2022-04-19 14:41 (UTC)

This fails building in a clean chroot because it has git sources but doesn't have git in makedepends.

yochananmarqos commented on 2020-03-10 19:06 (UTC) (edited on 2020-03-10 19:30 (UTC) by yochananmarqos)

This does not depend on lazarus-qt5, that's just the vIDE frontend. This project uses Qt4, not Qt5, anyway. qt4pas and lazarus need to be added to makedepends.

EDIT: This package appears to depend on an old version of icu and will not run:

Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)" 

linarcx commented on 2018-05-13 10:16 (UTC) (edited on 2018-05-13 10:16 (UTC) by linarcx)

Hi. when i want to install the package:

Dependency lazarus-qt4' ofpeazip-qt-build' does not exist.

FadeMind commented on 2017-02-02 15:03 (UTC)

Improved and fixed PKGBUILD https://github.com/FadeMind/mnjpkgbuilds/tree/master/00-PEAZIP.PKG/peazip-qt-build Regards