Package Details: pencil2d-git 2517.3cc8eba2-1

Git Clone URL: https://aur.archlinux.org/pencil2d-git.git (read-only, click to copy)
Package Base: pencil2d-git
Description: Animation/drawing software, that lets you create traditional hand-drawn animation using both bitmap and vector graphics
Upstream URL: http://www.pencil2d.org/
Licenses: GPL
Conflicts: pencil2d
Provides: pencil2d
Submitter: benjarobin
Maintainer: benjarobin
Last Packager: benjarobin
Votes: 15
Popularity: 0.000000
First Submitted: 2013-09-15 14:29 (UTC)
Last Updated: 2017-08-26 09:23 (UTC)

Latest Comments

tuby commented on 2017-10-21 19:41 (UTC)

i wrote a pkgbuild for 2017-5-14 bin released on their google drive, https://gist.github.com/tuby2017/dd13a25ae368b78f457a3ed4873512fa. Recent ones are only appimage , maybe could extract those.

jneem commented on 2017-08-22 21:48 (UTC)

This package seems to require qt5-xmlpatterns as an additional depencency. Before installing it, I got the error cd core_lib/ && ( test -e Makefile || /usr/bin/qmake -o Makefile /home/jneeman/.cache/pacaur/pencil2d-git/src/pencil2d/core_lib/core_lib.pro PREFIX=/usr ) && make -f Makefile Project ERROR: Unknown module(s) in QT: xmlpatterns make: *** [Makefile:135: sub-core_lib-make_first-ordered] Error 3 ==> ERROR: A failure occurred in build(). Aborting...

benjarobin commented on 2017-07-05 21:38 (UTC)

Thank you for the comments. The only side effect is that the application binary is now named Pencil2D instead of pencil2d

J5lx commented on 2017-07-05 21:05 (UTC)

Actually you can also just call qmake with PREFIX=/usr and then use make install INSTALL_ROOT="${pkgdir}" now, see https://github.com/pencil2d/pencil/pull/671#issuecomment-301484555. This will install the upstream desktop entry, MIME package and icon. It will currently also install the static QuaZIP library though, which is unintended, so you should also add options=('!staticlibs') to the PKGBUILD.

Popolon commented on 2017-07-05 07:49 (UTC)

There is an error in the PKGBUILD: app/Pencil2D Need to be replaced by bin/Pencil2D

StuckUpCreations commented on 2016-05-30 01:03 (UTC)

thankyou very much!

benjarobin commented on 2016-05-29 11:06 (UTC) (edited on 2016-05-29 12:50 (UTC) by benjarobin)

Fixed in git : https://github.com/pencil2d/pencil/pull/507

StuckUpCreations commented on 2016-05-29 09:56 (UTC)

i get the following error... pencilapplication.cpp:4:31: fatal error: PencilApplication.h: No such file or directory #include "PencilApplication.h" ^ Makefile:71: recipe for target 'sub-app-make_first' failed make: *** [sub-app-make_first] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build pencil2d-git.

lyoneel commented on 2015-02-11 13:51 (UTC)

Why this is making conflict with pencil - Sketching and GUI prototyping tool? maybe the conflicting package is pencilanimation? and i think this will need to provide "pencil2d" and not pencil.

lyoneel commented on 2015-02-11 13:51 (UTC)

Why this is making conflict with pencil - Sketching and GUI prototyping tool? maybe the conflicting package is pencilanimation? and i think this will need to provide "pencil2d" and not pencil.

echinotrix commented on 2014-07-06 18:15 (UTC)

Did not compile for me. make[1]: /usr/lib/qt/bin/lrelease: Command not found Adding qt5-tools helped, maybe it should be added as a dependency?

fplolz commented on 2014-05-28 06:09 (UTC)

loosk like it is broken again.. patches don't apply to the new revision anymore

pientro commented on 2014-03-10 21:50 (UTC)

yep. Now work! Thx

benjarobin commented on 2014-03-10 21:27 (UTC)

pencil2d is now compiling against qt5. I did patch some files to be able to compile. It looks like is working... If anyone have trouble please let me now since I am not an user of this software.

pientro commented on 2014-03-10 19:02 (UTC)

yep... at the moment there are some problem with the git version.. please read: http://www.pencil2d.org/forums/topic/pencil2d-and-archlinux-problem/

benjarobin commented on 2014-02-26 00:48 (UTC)

otto, please update the package or just disown the package, I will be happy to maintained it...

tim.cooper commented on 2014-02-26 00:28 (UTC)

The help patch is currently causing build errors: ==> Updated version: pencil2d-git 1102.ce2ab54-1 ==> Starting prepare()... patching file src/interface/mainwindow2.cpp Hunk #1 FAILED at 1033. 1 out of 1 hunk FAILED -- saving rejects to file src/interface/mainwindow2.cpp.rej ==> ERROR: A failure occurred in prepare(). Aborting... ==> ERROR: Makepkg was unable to build pencil2d-git.

mathieu.clabaut commented on 2014-01-16 09:50 (UTC)

The executable conflicts with the pencil package (http://pencil.evolus.vn/). Perhaps could you rename the executable to "pencil2d" according to the package name ?

otto commented on 2013-11-18 09:00 (UTC)

Edited. I took out the patches.

blurymind commented on 2013-10-22 11:28 (UTC)

Please update the PKGBUILD to remove the patches. They have been already applied in the source at git https://github.com/pencil2d/pencil/blob/master/src/external/linux/linux.cpp Currently the patches here clash with the source at git and cause pencil not to build. If you get the phonon error, just edit the PKGBUILD and remove all the lines with the patches.