Package Details: pentadactyl-git r7170.41d023a-4

Git Clone URL: https://aur.archlinux.org/pentadactyl-git.git (read-only)
Package Base: pentadactyl-git
Description: Vim-like five-fingered interface for Firefox
Upstream URL: http://dactyl.sourceforge.net/pentadactyl
Keywords: Firefox Vim
Licenses: MIT
Conflicts: pentadactyl
Provides: pentadactyl
Submitter: AsmundEr
Maintainer: AsmundEr
Last Packager: AsmundEr
Votes: 55
Popularity: 0.000000
First Submitted: 2015-04-10 19:06
Last Updated: 2016-05-05 13:32

Latest Comments

1 2 3 4 5 6 ... Next › Last »

parnmatt commented on 2016-08-16 13:55

@polysen, Cheers, that works great with standard firefox

polyzen commented on 2016-08-15 22:16

parnmatt, now there's aur/firefox-pentadactyl-signed[].

[] https://aur.archlinux.org/packages/firefox-pentadactyl-signed

polyzen commented on 2016-08-15 21:26

Ah, so just -esr, then.. Upstream still has their max version set to 47.

I don't know how far Will's fork has diverged, but apparently just bumping the maxver will not be enough. Read this[] comment and forward.

[] https://github.com/5digits/dactyl/issues/168#issuecomment-237757168

parnmatt commented on 2016-08-15 21:12

Ah, it's because this still has maxversion = 47.* rather than 48.*

parnmatt commented on 2016-08-15 21:08

I have just built firefox-unbranded, and this is not compatable; even with xpinstall.signitures.required = false

polyzen commented on 2016-08-15 20:21

parnmatt, this package is still valid for users of firefox-esr, firefox-unbranded, and maybe others.

A simple solution could be to have another package called pentadactyl-devel-signed, pentadactyl-willsALMANJ, or something (as it wouldn't be using Git).

parnmatt commented on 2016-08-15 20:14

@polyzen noted github:willsALMANJ, apparently their version works up until v50
I conquer that this package should either follow his master branch or at least his releases until official version/builds are compatible again.

polyzen commented on 2016-05-05 13:50

Considering this is a -git package, that may be what needs to be done. Perhaps someone will package an unbranded Firefox to use instead.

Otoh, there are signed, unofficial builds:
https://github.com/willsALMANJ/pentadactyl-signed/releases

Perhaps this can be changed from -git to -master( or something), and follow those?

AsmundEr commented on 2016-05-05 13:34

Thanks everyone for the heads up and for investigating. Pushed updated PKGBUILD now with the MaxVer change commented out.

In the long term, the strategy will likely to make this package depend on the LTS version of Firefox, and conflict with plain Firefox. Ideas/thoughts on this?

polyzen commented on 2016-05-05 13:27

maciejjo, penta master has maxver at 47, but this PKGBUILD changes it to 46. Flagged out-of-date.

parnmatt, apparently we have until 47:
https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox?as=u&utm_source=inproduct#w_override-add-on-signing-advanced-users