Package Details: pentadactyl-git r7170.41d023a-4

Git Clone URL: https://aur.archlinux.org/pentadactyl-git.git (read-only)
Package Base: pentadactyl-git
Description: Vim-like five-fingered interface for Firefox
Upstream URL: http://dactyl.sourceforge.net/pentadactyl
Keywords: Firefox Vim
Licenses: MIT
Conflicts: pentadactyl
Provides: pentadactyl
Submitter: AsmundEr
Maintainer: AsmundEr
Last Packager: AsmundEr
Votes: 55
Popularity: 0.000000
First Submitted: 2015-04-10 19:06
Last Updated: 2016-05-05 13:32

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

parnmatt commented on 2015-11-23 14:28

I am pretty sure. By fresh install, I installed Arch on this new machine on Friday. It looks as though the Version is (newer?) different; I checked that the PKGBUILD matched.

~ ❯❯❯ pacman -Qi firefox
Name : firefox
Version : 42.0-2
Description : Standalone web browser from mozilla.org
Architecture : x86_64
URL : https://www.mozilla.org/firefox/
Licences : MPL GPL LGPL
Groups : None
Provides : None
Depends On : gtk2 mozilla-common libxt startup-notification mime-types
dbus-glib alsa-lib desktop-file-utils hicolor-icon-theme
libvpx icu libevent nss hunspell sqlite ttf-font
Optional Deps : networkmanager: Location detection via available WiFi networks
gst-plugins-good: h.264 video
gst-libav: h.264 video
upower: Battery API
Required By : None
Optional For : pentadactyl-git
Conflicts With : None
Replaces : None
Installed Size : 94.61 MiB
Packager : Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
Build Date : Tue 10 Nov 2015 13:51:57 GMT
Install Date : Fri 20 Nov 2015 18:43:40 GMT
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature

~ ❯❯❯ pacman -Qi pentadactyl-git
Name : pentadactyl-git
Version : r7173.2ae30e8-1
Description : Vim-like five-fingered interface for Firefox
Architecture : any
URL : http://dactyl.sourceforge.net/pentadactyl
Licences : MIT
Groups : None
Provides : pentadactyl
Depends On : None
Optional Deps : firefox [installed]
Required By : None
Optional For : None
Conflicts With : pentadactyl
Replaces : None
Installed Size : 1980.00 KiB
Packager : Unknown Packager
Build Date : Fri 20 Nov 2015 19:32:27 GMT
Install Date : Fri 20 Nov 2015 19:32:40 GMT
Install Reason : Explicitly installed
Install Script : No
Validated By : None

AsmundEr commented on 2015-11-23 14:21

parnmatt, that's strange. Are you completely sure you have installed pentadactyl-git with the latest PKGBUILD? I'm typing this with a working pentadactyl plugin on Firefox 42.0-2, which is the latest version available on Arch.

What is the output of `pacman -Qi firefox` and `pacman -Qi pentadactyl-git` on your machine?

parnmatt commented on 2015-11-23 14:18

That was the case I have had previously, however it is not the case here I'm afraid: https://imgur.com/M1fjKsP

polyzen commented on 2015-11-23 14:02

parnmatt, it should only say the extension is not verified, but still let you use it

parnmatt commented on 2015-11-23 13:54

That's grand news, however with a fresh build it is saying it is not compatable with FF 42.0 even though max version has been set to 44 .

AsmundEr commented on 2015-11-04 17:11

(Read in my best James May impression)
Good news! The new Dacia^H^H^H^H^H Firefox feature which requires package signing has been deferred to FF 44 [1]. Pentadactyl-git should continue working on 42 and 43. I will bump the MaxVersion fix later today.

[1] https://wiki.mozilla.org/Addons/Extension_Signing

parnmatt commented on 2015-10-01 13:00

Can confirm, successful fix, with an apt commit message. Strange indeed.
Cheers for the swift response @AsmundEr.

AsmundEr commented on 2015-10-01 12:32

Updated now.

AsmundEr commented on 2015-10-01 12:27

Ah, I can confirm this. Thanks for the heads up. Bumping the MaxVersion to 42 fixes the problem, I'm submitting an updated PKGBUILD now.

parnmatt commented on 2015-10-01 11:17

41.1.0-1 is fine, it's the new 41.0.1-1 that isn't for me