Package Details: pentadactyl-git r7170.41d023a-4

Git Clone URL: https://aur.archlinux.org/pentadactyl-git.git (read-only)
Package Base: pentadactyl-git
Description: Vim-like five-fingered interface for Firefox
Upstream URL: http://dactyl.sourceforge.net/pentadactyl
Keywords: Firefox Vim
Licenses: MIT
Conflicts: pentadactyl
Provides: pentadactyl
Submitter: AsmundEr
Maintainer: AsmundEr
Last Packager: AsmundEr
Votes: 55
Popularity: 0.000000
First Submitted: 2015-04-10 19:06
Last Updated: 2016-05-05 13:32

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

maciejjo commented on 2015-03-06 07:19

Ok, after manual reinstall it works. Indeed, I wasn't aware of an update to the package.

AsmundEr commented on 2015-03-05 20:05

I see that heftig comments on one of the packages he maintains that it is normal for hg/git packages to not have an updated pkgver: https://aur.archlinux.org/packages/opentyrian-hg/

AsmundEr commented on 2015-03-05 19:55

For a package that pulls from a hg repo I don't know how I could the header updated all the time. Except perhaps uploading a new PKGBUILD every day with some cron script, but that feels like a bad solution.

Note that the pkgver() function in the PKGBUILD should ensure that the final version of the built package is correct, but it has to actually clone the repo before that information is available. That may be why cower gets confused. I will have a look at other -hg packages to see if there is a more clever way.

tridus commented on 2015-03-05 19:45

@AsmundEr: Shouldn't you update the package header? It currently shows the previous version, i.e. Package Details: pentadactyl-hg 7140.59c43695e9ee-1, while current version is: pentadactyl-hg 7157.c3febd64bcc2-1. Some people (and AUR helpers) may be lead to believe there is no update available, when there is.

AsmundEr commented on 2015-03-05 12:15

I'm running this (version 1.2pre-hg7157) on FF 36, no problems. What problems have you experienced?

maciejjo commented on 2015-03-05 08:59

Any progress for FF 36 support? I now have it freezed at last 35 release.

tridus commented on 2015-02-26 22:22

@AsmundEr: Cower is really simple, when using the -u option all it does is to check foreign packages for updates in the AUR. Then I download with the -d option and compile it manually with makepkg.

I see that above this page it says:

"Package Details: pentadactyl-hg 7140.59c43695e9ee-1"

Maybe it checked that and didn't find any update.

AsmundEr commented on 2015-02-26 21:50

tridus: thanks for checking. Good that it worked in the end. I'm not familiar with cower, but that packagename from your earlier build indicates that it was built from an older PKGBUILD, as I switched the architecture from "i686" to "any" about a month ago. The 7140 in the version string is from when I last uploaded a PKGBUILD, it should be replaced when you build by the pkgver() function in the PKGBUILD. Maybe cower gets confused with packages that pull from mercurial?

tridus commented on 2015-02-26 21:42

@AsmundEr: I keep my system up to date. I use cower and makepkg. At the end of the compilation it finally worked.

The resultant file I got was:

pentadactyl-hg-7157.c3febd64bcc2-1-any.pkg.tar.xz

While before I had:

pentadactyl-hg-7140.59c43695e9ee-1-i686.pkg.tar.xz

Clearly I had to compile again.

This means one needs to compile regularly, even without notification?





AsmundEr commented on 2015-02-26 20:54

Also: are you guys *completely* sure that you are in fact installing the "pentadactyl-hg" package, and not the "pentadactyl" package? The other package is outdated and has not been updated for several years.