Package Details: perl-boost-geometry-utils 0.15-1

Git Clone URL: https://aur.archlinux.org/perl-boost-geometry-utils.git (read-only)
Package Base: perl-boost-geometry-utils
Description: Boost::Geometry::Utils - Bindings for the Boost Geometry library
Upstream URL: https://metacpan.org/release/Boost-Geometry-Utils/
Licenses: GPL, PerlArtistic
Submitter: swiftgeek
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 10
Popularity: 0.000000
First Submitted: 2012-06-23 10:12
Last Updated: 2015-06-10 12:40

Latest Comments

swiftgeek commented on 2014-07-16 01:30

Use master branch (slic3r-git, select branch/commit from interactive mode) until next slic3r version appears
As You can see slic3r (in master) doesn't depend anymore on this package

mpan commented on 2014-07-16 01:04

A patch is available: <https://rt.cpan.org/Public/Bug/Display.html?id=96145>. Worked for me at least to the point that the package builds and passes tests. slic3r still fails, however (don't know yet if this package is the reason).

Debian has already included this in their git¹ in a response to bug#750224².

It seems that the package is dead, btw. No updates for a year, no response to both the bug report and the patch.

____
¹ http://anonscm.debian.org/gitweb/?p=pkg-perl/packages/libboost-geometry-utils-perl.git;a=commit;h=59c27dac1d4a55d85481c620c212fcb67f715daf
² https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=750224

swiftgeek commented on 2014-06-05 15:54

This package awaits for upstream fix for perl 5.20, same as with perl-math-clipper (which is now fixed)

swiftgeek commented on 2013-06-23 15:25

Backup of 0.13
https://gist.github.com/swiftgeek/2c787f43fbbae21c6f1d

swiftgeek commented on 2013-06-15 22:47

Not anymore, that was a really short downtime ;)

ejona86 commented on 2013-06-15 22:45

www.cpan.org seems down right now. http://cpan.perl.org/CPAN/authors/id/A/AA/AAR/Boost-Geometry-Utils-0.13.tar.gz is an alternative download location.

swiftgeek commented on 2013-04-12 11:14

If it looks like here https://github.com/alexrj/Slic3r/issues/1111#issuecomment-16108813

then You can (probably) safely ignore it. Otherwise use -git and ignore it

swiftgeek commented on 2013-04-12 11:01

If it looks like here https://github.com/alexrj/Slic3r/issues/1111#issuecomment-16108813
then You can (probably) safely ignore it. Otherwise use -git and ignore it

xoan commented on 2013-04-12 10:56

`pollyclip.t` is still failed in `slic3r-0.9.9` package.

0.06 is the last version which I can compile slic3r with no errors.

swiftgeek commented on 2013-04-09 07:20

Beware of upgrading 0.06 → 0.07
Latest snapshot of Slic3r (0.9.9) may not work with it, as to this date (git) Slic3r isn't passing test with 0.07.

swiftgeek commented on 2012-06-23 10:14

A slic3r dependency

Feel free to ask for adoption: i'm not maintaining this package unless it will be needed by slic3r
Cheers