Package Details: perl-compass-points 0.02-2

Git Clone URL: https://aur.archlinux.org/perl-compass-points.git (read-only, click to copy)
Package Base: perl-compass-points
Description: Convert between compass point names, abbreviations and values
Upstream URL: https://metacpan.org/dist/Compass-Points
Keywords: azimuth compass directions library perl point
Licenses: GPL, PerlArtistic
Submitter: dpeukert
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 0
Popularity: 0.000000
First Submitted: 2021-12-12 14:06 (UTC)
Last Updated: 2022-06-01 08:20 (UTC)

Pinned Comments

dpeukert commented on 2021-12-12 14:08 (UTC)

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/main/perl-compass-points

Latest Comments

MarsSeed commented on 2022-06-01 15:50 (UTC)

Hi,

Please don't do empty bumps of pkgrel next time. It makes sense when you control a binary repo, but the AUR is not a closed build system and the majority of its users are end-users doing their own builds (mostly via AUR helpers).

The [perl] package from Arch has a pacman ALPM hook that warns users if there are perl module files installed in a versioned directory that mismatches the system-installed Perl version.

Therefore the users will know if they need to manually rebuild their AUR-based Perl packages after an upstream [perl] package update.

Then, if you as an AUR package maintainer do this bump, such users have to do that rebuild a second time.

And no, it doesn't help even if you do the bump the same second Arch repo updates its Perl version: because there are downstream distros based on Arch Linux and the users of those can and do use the AUR as well. These downstream repos usually import Arch-built packages with some delay (Manjaro's most conservative stable branch usually has a delay of one month or more.)

For delayed downstream distros, your bump today will cause those distro users to do a superfluous rebuild with the earlier Perl 5.34, because they still have that version. Then, when their distros import the new Perl 5.36, those users still need to rebuild this AUR package manually .

I hope you understand the pain I am expressing on behalf of the average AUR user (who are quite large in number), and decide to accommodate all of us next time by not doing another changeless pkgrel bump.

Thank you.

dpeukert commented on 2021-12-12 14:08 (UTC)

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/main/perl-compass-points