Package Details: perl-config-inifiles 2.88-2

Git Clone URL: https://aur.archlinux.org/perl-config-inifiles.git (read-only)
Package Base: perl-config-inifiles
Description: A Perl module for reading .ini-style configuration files
Upstream URL: http://search.cpan.org/dist/Config-IniFiles/
Licenses: GPL, PerlArtistic
Submitter: sinister99
Maintainer: fukawi2
Last Packager: fukawi2
Votes: 31
Popularity: 0.867642
First Submitted: 2007-08-21 01:18
Last Updated: 2016-04-18 04:38

Latest Comments

fukawi2 commented on 2016-04-18 04:38

Right, there are environment variables that interfere. I understand now. Fixed, thanks.

ivan_p commented on 2016-04-15 15:16

@fukawi2
To understand you can run `set | grep PERL_` in terminal: installation path is overriden by these variables.

Anyways, here is the fixed PKGBUILD:
https://gist.github.com/ivanpu/cf9a33da58aa02206825c2fe44aee398

fukawi2 commented on 2016-02-16 01:24

@kevku I don't understand. Can you give some more information please? What files are being written to your home directory? I don't see anything in the example PKGBUILD in the wiki about home directories.

kevku commented on 2016-02-14 15:54

this pkgbuild needs fixing so that it doesnt install in your home folder, see the 2nd PKGBUILD example at https://wiki.archlinux.org/index.php/Perl_package_guidelines

fukawi2 commented on 2015-09-16 01:26

Bump to 2.88

Eschwartz commented on 2015-08-05 19:37

This needs a makedepends = "perl-module-build"

fukawi2 commented on 2015-07-23 23:48

Thanks for reporting. Added `perl-module-build` as makedepends

fusion809 commented on 2015-07-23 23:43

The build of this package gives:

Can't locate Module/Build/Compat.pm in @INC (you may need to install the Module::Build::Compat module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at Makefile.PL line 3.
BEGIN failed--compilation aborted at Makefile.PL line 3.

fukawi2 commented on 2014-07-06 04:39

CPAN has had some issues over the past few days I've noticed. How long have you been having problems?

tfla commented on 2014-07-05 15:06

The url http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Config-IniFiles-2.83.tar.gz seems to work better for me for some reason (the one in the PKGBUILD doens't download anything at all).

fukawi2 commented on 2014-03-11 05:36

Update to 2.83

fukawi2 commented on 2013-06-03 01:19

Bump to 2.82

fukawi2 commented on 2012-10-03 00:26

Indeed, thanks. Fixed:
https://github.com/fukawi2/aur-packages/commit/730d960a8dab3aa7cc95699cdf98a31a36271aad
(I won't bump pkgrel and upload new pkg just for that)

TioDuke commented on 2012-10-03 00:23

Shouldn't this package be arch=('any')?

fukawi2 commented on 2012-06-18 23:04

Thx, updated

TioDuke commented on 2012-06-16 11:12

Requires perl-list-moreutils

fukawi2 commented on 2012-06-16 02:54

Bump to 2.76

fukawi2 commented on 2012-04-20 04:01

Adopted and updated to 2.70

zlowly commented on 2011-07-27 16:28

2.68

tdy commented on 2010-07-02 14:25

2.58

Anonymous comment on 2010-05-05 18:09

2.54 is out of date.
Modified PKGBUILD for 2.57 at http://aur.pastebin.com/z7dsNpK7