Package Details: perl-convert-uulib 1.5-1

Git Clone URL: (read-only)
Package Base: perl-convert-uulib
Description: Perl interface to the uulib library (a.k.a. uudeview/uuenview).
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: yar
Last Packager: yar
Votes: 15
Popularity: 0.004580
First Submitted: 2006-07-17 07:43
Last Updated: 2015-08-02 18:32

Latest Comments

chetwisniewski commented on 2015-07-31 20:18

Also requires perl-canary-stability package now.

chetwisniewski commented on 2015-07-31 20:14

Version 1.5 is now available.

rumpelsepp commented on 2014-06-05 09:05

Needs rebuild because of perl 5.20.

techlive commented on 2013-11-09 09:18

Here is an updated [PKGBUILD][1], which prevent user's environment variable from interfering the packing process, like ending up with the package being installed into your $HOME directory.


yar commented on 2013-09-20 23:58

Breaks with Perl 5.18 unless you rebuild it. Please consider bumping pkgrel so users can upgrade their systems seamlessly.

pkmx commented on 2011-07-05 14:07

Ouch, that is a nasty bug. Thanks for bringing up this issue, kang. Here is the fixed PKGBUILD:

kang commented on 2011-07-03 12:17

looks like that:
warning: downgrading package perl-convert-uulib (1.33-2 => 1.4-1)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: amavisd-new: requires perl-convert-uulib>=1.08

and after fix:
resolving dependencies...
looking for inter-conflicts...

Targets (1): perl-convert-uulib-1.40-1 [0.12 MB]

tada ;-)

kang commented on 2011-07-03 12:16

Unfortunately the update is incorrect
Updating from 1.33 to 1.4 doesn't work out.

For Pacman, 1.08 is higher than 1.4 for example, because 1.08=1.8

It's not very logical to me but I haven't found the explanation for that.

Please upgrade the version number to 1.40 for pkgver (and use pkgrealver=1.4 for fetching and unpacking), otherwise, amavisd-new dependency will fail for example (aka this upgrade breaks amavisd-new atm).

It's not the other packages that should be fixed IMO because you have downgraded and they cannot expect that :-)

In short: 1.40 > 1.33 > 1.08 (it's in fact read as 1.8) > 1.4

techlive commented on 2011-06-21 09:46

Updated to 1.4,Thanks to @pkmx.

pkmx commented on 2011-06-10 09:26

The 1.33 tarball seems to be removed from CPAN and it was upgraded to 1.4. Here is the new PKGBUILD:

I tested it with amavisd-new and it seemed to work flawlessly with 1.4.

All comments