Package Details: perl-coro 6.57-1.1

Git Clone URL: https://aur.archlinux.org/perl-coro.git (read-only, click to copy)
Package Base: perl-coro
Description: CPAN/Coro - the only real threads in perl
Upstream URL: https://metacpan.org/release/Coro
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 4
Popularity: 0.002055
First Submitted: 2011-03-16 08:13 (UTC)
Last Updated: 2022-06-02 02:21 (UTC)

Latest Comments

MarsSeed commented on 2023-06-01 14:58 (UTC)

The perl package contains a libalpm pacman hook to check if any perl module needs rebuild due to major version change.

Therefore tying the package depends of perl-coro to a specific perl vMAJOR.MINOR version is superfluous and just throws an unnecessary roadblock when doing a pacman sysupgrade if there is a new perl main version.

Would you please consider removing that old version restriction logic?

MarsSeed commented on 2022-06-03 18:41 (UTC)

Please kindly remove the hidden trap of version locking.

Doesn't make sense if you are gonna bump pkgrel anyway upon upsteam Perl version upgrade.

MarsSeed commented on 2022-05-31 17:04 (UTC)

Prevents installing perl 5.36 because it constrains depending on perl<5.35 if installed earlier with perl 5.34.

IMHO constraint should be removed; nothing in source restricts perl version.

AUR Perl package rebuilds need to be handled by user. Arch perl package already has an ALPM hook that checks for such scenarios and warns user about it.

hexhu commented on 2021-05-28 23:39 (UTC)

Getting error: failed to prepare transaction (could not satisfy dependencies) :: installing perl (5.34.0-1) breaks dependency 'perl<5.33' required by perl-coro error installing repo packages

DanielDavis commented on 2019-06-11 22:01 (UTC)

The perl version constraint makes it impossible to do a full system, after installing this package, when the perl version has been bumped twice. It's not even clear why the dependency is listed.

sovanyio commented on 2017-07-21 12:43 (UTC)

Needs another patch for perl 5.26 https://rt.cpan.org/Public/Bug/Display.html?id=121836. Got it to build and install locally after applying

bidulock commented on 2016-12-19 05:53 (UTC)

Patch works, back up again.

sovanyio commented on 2016-10-12 18:33 (UTC)

Coro-6.511 compiles with the patch at https://rt.cpan.org/Public/Bug/Display.html?id=114708

bidulock commented on 2015-10-07 23:18 (UTC) (edited on 2015-10-07 23:22 (UTC) by bidulock)

Coro-6.48 still will not build under perl 5.22.0 (State.xs fails). Please report upstream.