Package Details: perl-cpan-meta-check 0.012-1

Git Clone URL: https://aur.archlinux.org/perl-cpan-meta-check.git (read-only)
Package Base: perl-cpan-meta-check
Description: Verify requirements in a CPAN::Meta object
Upstream URL: http://search.cpan.org/dist/CPAN-Meta-Check
Licenses: GPL, PerlArtistic
Submitter: harleypig
Maintainer: mbunkus
Last Packager: mbunkus
Votes: 27
Popularity: 0.642881
First Submitted: 2012-06-02 01:00
Last Updated: 2015-06-30 15:06

Latest Comments

beckus commented on 2015-01-01 17:50

Thank you again! I removed perl-extutils-makemaker to which the file belongs to and now it works.

mbunkus commented on 2014-12-28 19:55

Oops, I meant "pacman -Qo /path/to/file". Sorry.

mbunkus commented on 2014-12-28 10:49

Try to figure out which package owns that file:

pacman -S /usr/share/perl5/vendor_perl/Parse/CPAN/Meta.pm

If it isn't owned by any package then simply remove it (and any other file and directory that might belong to the same Perl package). Anyway, this is definitely an issue with your installation, not with this package.

beckus commented on 2014-12-27 13:47

The package perl-parse-cpan-meta is not installed and the second line gives "/usr/share/perl5/vendor_perl/Parse/CPAN/Meta.pm". I cannot remember installing anything manually via cpan. But looking to the output of the package build, it seems that perl-cpan-meta-check wants the Meta.pm and the location it is in your installation. I'll check why...

mbunkus commented on 2014-12-24 10:58

You most likely still have installed either a package called perl-parse-cpan-meta (note the »parse-« in there; you've only talked about »perl-cpan-meta«) or the module itself (e.g. installed manually via cpan). Check both cases:

1. »pacman -Q|grep perl-parse-cpan-meta«
2. perl -le "use Parse::CPAN::Meta; print for %INC" | grep /Parse/CPAN/Meta

For me 2. prints this:

/usr/share/perl5/core_perl/Parse/CPAN/Meta.pm

And this is what it should ouput as Parse::CPAN::Meta is in Perl's core.

beckus commented on 2014-12-22 12:03

It complains about perl-cpan-meta "Parse::CPAN::Meta version 1.4414 required--this is only version 1.4405". Its strange, but perl-cpan-meta is not installed and putting it as a depend into the PGKBUILD it tells me, perl-cpan-meta is already installed. I then installed it manually and I still get the same error when trying to build this package.

jnbek commented on 2014-06-13 00:43

k, nvm, I guess it's not, my bad, sorry

jnbek commented on 2014-06-12 22:58

Looks like this module is actually part of core_perl now... Should send in a delete request.

mbunkus commented on 2013-09-19 07:09

Please update your package. I cannot update some of mine due to failing build requirements until yours is updated.

If you don't have the time to maintain it anymore then that's perfectly understandable. In such a case please orphan it; I can adopt and maintain it.

Thanks.

mbunkus commented on 2013-05-08 10:34

I have a build error with 0.004-4 and a system pacman -Syu'd today:

==> Extracting sources...
-> Extracting CPAN-Meta-Check-0.004.tar.gz with bsdtar
==> Starting build()...
/tmp/yaourt-tmp-mbunkus/aur-perl-cpan-meta-check/./PKGBUILD: line 27: cd: /CPAN-Meta-Check-0.004: No such file or directory

It looks like $srcdir is not defined the moment the PKGBUILD is sourced, but only at the moment the individual functions are called.

My suggestion would be to move certain stuff into a new function called e.g. 'prepare_environment()' that can be called from the other functions, e.g. something like the following (I've built the package with this code):

http://pastebin.com/vfFpbWWA

All comments