Package Details: perl-devel-nytprof 6.14-1

Git Clone URL: https://aur.archlinux.org/perl-devel-nytprof.git (read-only, click to copy)
Package Base: perl-devel-nytprof
Description: Devel::NYTProf - Powerful fast feature-rich perl source code profiler
Upstream URL: https://metacpan.org/dist/Devel-NYTProf/
Licenses: GPL
Submitter: alexey-p
Maintainer: dracorp
Last Packager: dracorp
Votes: 7
Popularity: 0.040075
First Submitted: 2011-03-21 05:43 (UTC)
Last Updated: 2023-11-07 21:44 (UTC)

Latest Comments

Score_Under commented on 2022-11-03 17:17 (UTC) (edited on 2022-11-03 17:18 (UTC) by Score_Under)

I think this might need perl-capture-tiny for the test suite, which is required for the build to succeed under normal circumstances:

Can't locate Capture/Tiny.pm in @INC (you may need to install the Capture::Tiny module) (@INC contains: /build/perl-devel-nytprof/src/Devel-NYTProf-6.10/blib/lib /build/perl-devel-nytprof/src/Devel-NYTProf-6.10/blib/arch /usr/lib/perl5/5.36/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.36/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.36/core_perl /usr/share/perl5/core_perl .) at t/12-data.t line 10.
BEGIN failed--compilation aborted at t/12-data.t line 10.
t/12-data.t .............. 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
  • when built in clean chroot using makechrootpkg

demize commented on 2019-06-01 13:34 (UTC)

This package hasn't used perl-json-any since 6.02 in 2015, please remove it as the package is being dropped due to not building with the new perl.

kuehnelth commented on 2018-10-26 21:11 (UTC)

nytprofhtml needs perl-file-which and perl-json-maybexs as dependency.

Manifest0 commented on 2016-06-01 17:01 (UTC)

Version 6.03 is out. To use it just edit the PKGBUILD to the following: pkgver=6.03 pkgrel=1 sha1sums=('85533c100cd89eb6cca640330db7ff0cb99e7b2b')

mbunkus commented on 2014-07-07 12:30 (UTC)

Please upgrade this package. A new release (5.06) is out and is required for Perl 5.20, otherwise most tests will fail. Thanks.

mbunkus commented on 2013-06-04 08:48 (UTC)

Please upgrade this package. A new release (5.03) is out and is required for newer Perl versions due to the hash key randomization issues (meaning your current package fails during tests).

dracorp commented on 2011-11-08 11:33 (UTC)

Can you add to the PKGBUILD: provides=( 'perl-devel-nytprof-apache' 'perl-devel-nytprof-constants' 'perl-devel-nytprof-core' 'perl-devel-nytprof-data' 'perl-devel-nytprof-filehandle' 'perl-devel-nytprof-fileinfo' 'perl-devel-nytprof-reader' 'perl-devel-nytprof-readstream' 'perl-devel-nytprof-run' 'perl-devel-nytprof-subinfo' 'perl-devel-nytprof-util' ) ?