Package Details: perl-devel-repl 1.003029-1

Git Clone URL: https://aur.archlinux.org/perl-devel-repl.git (read-only, click to copy)
Package Base: perl-devel-repl
Description: a modern perl interactive shell
Upstream URL: http://search.cpan.org/dist/Devel-REPL/
Licenses: GPL, PerlArtistic
Submitter: xenoterracide
Maintainer: mbunkus
Last Packager: mbunkus
Votes: 6
Popularity: 0.000000
First Submitted: 2010-05-02 14:42 (UTC)
Last Updated: 2022-05-29 08:43 (UTC)

Latest Comments

mbunkus commented on 2020-11-03 22:14 (UTC)

I'm not sure why I missed those comments back in March until a kind soul flagged the package out-of-date half an hour ago. Sorry for that.

I've just added all the packages required for the optional REPL modules to the PKGBUILD. It's true that those modules are optional, but as they're distributed with the package the REPL attempts to auto-load them, which obviously fails is the optional modules' requirements aren't installed.

You'll have to install a couple more packages from the AUR now, but re.pl will start again.

jthvai commented on 2020-03-17 05:00 (UTC) (edited on 2020-03-17 05:01 (UTC) by jthvai)

After some testing:

Before compiling, add perl-lexical-persistence, perl-data-dump-streamer, and perl-ppi to the depends array in the PKGBUILD. lexical-persistence and data-dump-streamer are both AUR packages (with their own quirks that need some patching to the PKGBUILD.

This ensures that you are at the very least brought to the REPL shell (i.e., it runs), but I make no guarantees as to whether it parses Perl correctly after these additions~

Nowaker commented on 2020-03-13 01:51 (UTC) (edited on 2020-03-13 01:51 (UTC) by Nowaker)

Compiles just fine, but won't start.

% re.pl
Failed to load role: Devel::REPL::Plugin::LexEnv Can't locate Lexical/Persistence.pm in @INC (you may need to install the Lexical::Persistence module) (@INC contains: /usr/lib/perl5/5.30/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.30/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.30/core_perl /usr/share/perl5/core_perl) at /usr/share/perl5/vendor_perl/Devel/REPL/Plugin/LexEnv.pm line 10.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Devel/REPL/Plugin/LexEnv.pm line 10.
Compilation failed in require at /usr/share/perl5/vendor_perl/Module/Runtime.pm line 314.

mbunkus commented on 2018-08-24 15:33 (UTC)

The warnings while building perl-getopt-long-descriptive don't indicate that the package won't work. They only indicate that the package uses deprecated features that will be gone in Perl 5.32. You can simply build perl-getopt-long-descriptive without the tests, install it and continue with perl-moosex-getopt.

Additionally you should probably file a bug report with Getopt::Long::Descriptive.

hexadecagram commented on 2018-08-24 03:08 (UTC)

Thanks for the tips, @mbunkus, I did as you prescribed.

When I reach step 4, it says that it wants perl-getopt-long-descriptive, which also fails testing.

mbunkus commented on 2018-08-23 16:04 (UTC)

I am aware of the Perl update. The problem is, as you've noticed, that its dependency perl-moosex-getopt doesn't test cleanly. A new version has already been released upstream that does compile, and perl-moosex-getopt has appropriately flagged as outdated.

So here's your solution:

  1. Clone perl-moosex-getopt
  2. Adjust its PKGBUILD to build 0.72 instead of 0.71
  3. Install perl-test-needs, a new dependency of MooseX::Getopt 0.72
  4. Build & install your modified perl-moosex-getopt
  5. Build perl-devel-repl

I've just pushed a new version of perl-devel-repl that not only bumps the pkgrel, but also depends on perl-moosex-getopt>=0.72 in order to make this explicit.

hexadecagram commented on 2018-08-23 09:20 (UTC) (edited on 2018-08-23 09:42 (UTC) by hexadecagram)

ArchLinux Perl got updated from 5.26 to 5.28 recently, and as a result this package is b0rken.

pacman does not upgrade perl modules when a new base version is released, so to force a reinstall of all the modules, I run:

LC_ALL=C find "/usr/lib/perl5/site_perl" -type f -exec pacman -Qqo {} + |& sed -n 's/^error: No package owns \(.*\)$/\1/p'

as prescribed.

Some packages lag behind, such as perl-task-weaken and perl-getopt-long-descriptive. The former continues to install in /usr/lib/perl5/5.26 where as the latter just flatly fails to pass the testing phase.

Also, I made a comment for perl-data-dump-streamer which is one of the complaints re.pl fires at me when it starts. It seems to want this package even though it doesn't seem strictly necessary (I've gotten it to run without it).

The only solution right now is to pacman -Rccs perl-devel-repl and hope that some kind user can help me get it reinstalled. ;-)

jnbek commented on 2016-04-08 14:27 (UTC)

Also, regarding my Jenkins builder, I'll Open Source it when it's ready. It will scan your aur4/ root for new dirs, changes to PKGBUILDs etc using Inotify and trigger builds, create new builds if a new directory appears in the root, delete builds when a dir is removed ( say deleted pkgbuilds etc ). That way, it'll help those of us with a cpl hundred thousand PKGBUILDs to stay ahead of problems. I hope to have it done before Perl 5.24 releases, since core perl always makes for funtimes for perlaur :-P Email me, or add me on FB and we'll coordinate testing etc.

jnbek commented on 2016-04-08 14:23 (UTC)

Err, no, I'm very active with Maintainership of the AUR. I do rely heavily on the users to inform me when things break, even with an autobuilder, new deps can easily get missed, since I probably have hte dependency installed, but if the utility fails to catch the dep and put it in the pkgbuild, I'm ignorant to it, I only become aware of problems when either a) my build breaks or b) y'all tell me :D In other news, I'm working on a Jenkins build environment that will email me failures and can help me to notice problems a bit better, but even still, it won't be perfect. Just ping me if any of my PKGBUILDs are broken/out of date. I almost always get to them the same day I see the email.

mbunkus commented on 2016-04-08 07:07 (UTC)

Absolutely. If the package is orphaned I'll adopt it.

hexadecagram commented on 2016-04-08 04:44 (UTC)

The latest update to perl-devel-repl seems to address whatever issue I was having building it, which I'm struggling to remember, but I think the following is pretty accurate. You are correct that perl-devel-repl should not add a dependency on perl-module-pluggable. IIRC, I commented because I was able to get perl-devel-repl to build and install WITHOUT perl-moosex-object-pluggable if I manually installed perl-module-pluggable. perl-module-pluggable is still missing from perl-moosex-object-pluggable's dependency list. I seem to remember commenting about that but obviously it's not there. I'll ping jnbek, but it seems his participation in AUR package maintainership ceased 2015-6-16. Would you be willing to take over that package if necessary?

mbunkus commented on 2016-02-10 11:46 (UTC)

I disagree. The META.json[1] directly includes MooseX::Object::Pluggable as a runtime dependency. That MooseX::Object::Pluggable depends on Object::Pluggable is not my problem; it should be declared as a dependency in perl-moosex-object-pluggable instead. That's what I've pointed out in 2014 already[2] as a comment for that particular package. Why do you think those dependencies should be changed? [1] https://metacpan.org/source/ETHER/Devel-REPL-1.003027/META.json [2] https://aur.archlinux.org/packages/perl-moosex-object-pluggable/

hexadecagram commented on 2016-02-10 10:49 (UTC)

Dependency on perl-moose-x-object-pluggable>=0.0009 needs to be replaced with perl-module-pluggable.

mbunkus commented on 2015-08-24 15:36 (UTC)

I'll push a new build in a moment. Note that you will have to build its dependency perl-data-dump-streamer with »--nocheck« as Data::Dump::Streamer 2.28 has its tests failing with Perl 5.22: https://rt.cpan.org/Public/Bug/Display.html?id=102369 etc.

jnbek commented on 2014-02-27 18:10 (UTC)

ya, perl-moosex-getopt has been a problem child for quite some time; no fault to the maintainer, just a GCF. Thanks for stepping up @mbunkus.

mbunkus commented on 2014-02-27 11:33 (UTC)

I've taken over maintainership. Please note that check() currently fails. What it boils down to is one of the recursive dependencies of Devel::REPL requires a certain version of another module, but there's only an older version in Perl core. So until a new Perl version itself has been released just disable the check() functionality when you build this module.

hexadecagram commented on 2013-11-17 20:53 (UTC)

_pkgname='Devel-REPL' pkgver='1.003025' source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/${_pkgname}-${pkgver}.tar.gz") md5sums=('c610a5bfe436adec8b84f1d500e3a22f') sha512sums=('6ba0f3dfc5dad2d9af51fcbd0cd93a96cc615c2ac0b03781f3b19d69ed0bab0d446380e62caeec317c4f94093e9af19380716f821c6c8847d3bdd53cdc5b35ba') _distdir="${_pkgname}-${pkgver}" Also, *** WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING *** If you're seeing this warning, your toolchain is really, really old and you'll almost certainly have problems installing CPAN modules from this century. But never fear, dear user, for we have the technology to fix this! and t/00-check-deps.t ...... Test::CheckDeps version 0.007 required--this is only version 0.006 at t/00-check-deps.t line 7. BEGIN failed--compilation aborted at t/00-check-deps.t line 7.

jnbek commented on 2013-04-17 01:17 (UTC)

heh, sorry about that.... it exists now :)

seschwar commented on 2013-04-16 12:39 (UTC)

The make dependency perl-test-warnings is neither in the official repositories not the AUR and therefore perl-devel-repl cannot be built. - https://www.archlinux.org/packages/?limit=all&q=perl-test-warnings&sort=pkgname - https://aur.archlinux.org/packages.php?O=0&K=perl-test-warnings&detail=1&C=0&SeB=nd&SB=n&SO=a&PP=50

jnbek commented on 2012-09-10 14:52 (UTC)

Put the dependency back so it'll build

jnbek commented on 2012-09-10 14:37 (UTC)

grr, so now it barfs... wtf....

jnbek commented on 2012-09-09 21:12 (UTC)

Ya, works good... be sure to uninstall perl-moosex-attributehelpers if you've installed it, as it's not needed for anything anymore. Deprecated_Code--;

jnbek commented on 2012-09-09 21:04 (UTC)

Looks like the perl-moosex-attributehelpers>=0.16 dependency might not be needed, since the code it provides has been moved to Moose core, I might should remove the dep and see what happens ;-)