Package Details: perl-encode-detect 1.01-5

Git Clone URL: https://aur.archlinux.org/perl-encode-detect.git (read-only)
Package Base: perl-encode-detect
Description: An Encode::Encoding subclass that detects the encoding of data
Upstream URL: https://metacpan.org/release/Encode-Detect
Licenses: GPL, PerlArtistic
Submitter: alexmerry
Maintainer: amish
Last Packager: amish
Votes: 11
Popularity: 0.048604
First Submitted: 2007-07-03 13:16
Last Updated: 2018-12-11 05:51

Latest Comments

1 2 Next › Last »

mr_nuub commented on 2018-12-11 18:05

For everyone who wonders why there is an unset in the PKGBUILD, please read https://wiki.archlinux.org/index.php/Perl_package_guidelines.

amish commented on 2018-12-11 05:53

@mr_nuub: Done thanks. Please check.

mr_nuub commented on 2018-12-10 17:27

Hi! The PKGBUILD has a significant flaw. It installs the module into the current user home directory. To install the modules system-wide, please change the PKGBUILD according to my proposal:

package() {
  cd "$srcdir/$_distdir"
  unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
  # maybe you should specify DESTDIR, too?
  #make INSTALLDIRS=vendor DESTDIR="${pkgdir}" install
  make INSTALLDIRS=vendor install

  find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}

joeydc commented on 2018-09-16 02:49

I'm getting those errors on 3 different Arch installation:

error: failed to commit transaction (conflicting files) perl-encode-detect: /home/joeydc/perl5/lib/perl5/x86_64-linux-thread-multi/Encode/Detect.pm exists in filesystem perl-encode-detect: /home/joeydc/perl5/lib/perl5/x86_64-linux-thread-multi/Encode/Detect/Detector.pm exists in filesystem perl-encode-detect: /home/joeydc/perl5/lib/perl5/x86_64-linux-thread-multi/auto/Encode/Detect/Detector/Detector.bs exists in filesystem perl-encode-detect: /home/joeydc/perl5/lib/perl5/x86_64-linux-thread-multi/auto/Encode/Detect/Detector/Detector.so exists in filesystem perl-encode-detect: /home/joeydc/perl5/man/man3/Encode::Detect.3pm exists in filesystem perl-encode-detect: /home/joeydc/perl5/man/man3/Encode::Detect::Detector.3pm exists in filesystem Errors occurred, no packages were upgraded.

Any help please?

sanjaychak01 commented on 2018-09-12 09:50

Installs perfectly! Thanks!

amish commented on 2018-09-11 10:09

Added perl-module-build to makedepends. pkgrel is not increased to avoid unnecessary rebuilding for those who already had perl-module-build installed.

sanjaychak01 commented on 2018-09-11 07:50

Could not install 1.01-4. After "/usr/bin/make install -- OK", I get "Couldn't install Module::Build, giving up"

jnbek commented on 2018-09-10 20:15

Disowned, I don't have the cycles right now to take care of this.

Excalibur commented on 2018-08-27 14:35

I was trying to install this on ESPRESSObin. What I need to do is to install 'perl-module-build', update PKGBUILD for 'aarch64', and rm any leftover encode detector installed by 'perl-authen-pam'.

aqualx commented on 2018-08-09 22:13

"perl-module-build" should be added to "depends" list. Without it build fails with following error:

Permission denied at /usr/share/perl5/core_perl/ExtUtils/Install.pm line 489.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! at lib/Module/Build/Base.pm line 3565. make: *** [Makefile:77: install] Error 13