Package Details: perl-file-find-object 0.3.8-1

Git Clone URL: https://aur.archlinux.org/perl-file-find-object.git (read-only, click to copy)
Package Base: perl-file-find-object
Description: An object oriented File::Find replacement
Upstream URL: https://metacpan.org/release/File-Find-Object
Licenses: GPL, PerlArtistic
Provides: perl-file-find-object-base, perl-file-find-object-deeppath, perl-file-find-object-pathcomp, perl-file-find-object-result, perl-file-find-object-toppath
Submitter: dracorp
Maintainer: guzzisti (morgenstern)
Last Packager: morgenstern
Votes: 2
Popularity: 0.044392
First Submitted: 2014-12-05 23:07 (UTC)
Last Updated: 2023-12-05 20:55 (UTC)

Latest Comments

6e2f61 commented on 2024-01-07 15:48 (UTC)

FYI, I tried pikaur, yay and finally I just cloned repo and made makepkg but still had error. For some reason I had 2 different versions of perl-test-file module (one in site_packages and one installed by pacman in vendor_packages:

$ pacman -Qi perl-test-file
Name            : perl-test-file
Version         : 1.993-2
$ sudo cpan -l | grep -i test::file
Test::File  1.444
Test::File  1.993
$ locate Test/File.pm
/usr/share/perl5/site_perl/Test/File.pm
/usr/share/perl5/vendor_perl/Test/File.pm

I had to remove module manually from site_perl path (v 1.444) and now everything work's fine. Thanks for support :)

morgenstern commented on 2023-12-24 04:25 (UTC)

@6e2f61 most likely an issue with your AUR helper - builds and checks just fine in a clean chroot:

==> Starting build()...
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for File::Find::Object
Writing MYMETA.yml and MYMETA.json
cp lib/File/Find/Object/Result.pm blib/lib/File/Find/Object/Result.pm
cp lib/File/Find/Object.pm blib/lib/File/Find/Object.pm
cp lib/File/Find/Object/PathComp.pm blib/lib/File/Find/Object/PathComp.pm
cp lib/File/Find/Object/Base.pm blib/lib/File/Find/Object/Base.pm
Manifying 4 pod documents
==> Starting check()...
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t ........ ok
t/01ffo.t ............. ok
t/02tree-create.t ..... ok
t/03traverse.t ........ ok
t/04destroy.t ......... ok
t/05prune.t ........... ok
t/06trailing-slash.t .. ok
All tests successful.
Files=7, Tests=83,  0 wallclock secs ( 0.03 usr  0.01 sys +  0.58 cusr  0.09 csys =  0.71 CPU)
Result: PASS

6e2f61 commented on 2023-12-21 21:11 (UTC)

@guzzisti I have the one available in repository

pikaur -Qi perl-test-file
Name            : perl-test-file
Version         : 1.993-2

:/

guzzisti commented on 2023-12-19 19:17 (UTC)

@6e2f61 I think your package perl-test-file is outdated.

6e2f61 commented on 2023-12-17 19:32 (UTC) (edited on 2023-12-17 19:33 (UTC) by 6e2f61)

I have issues installing it using pikaur. Is it package related or AUR helper?

==> Validating source files with sha512sums...
    File-Find-Object-0.3.8.tar.gz ... Passed
==> Extracting sources...
  -> Extracting File-Find-Object-0.3.8.tar.gz with bsdtar
==> Starting build()...
Checking if your kit is complete...
Looks good
Warning: prerequisite Test::File 1.993 not found. We have 1.444.
Generating a Unix-style Makefile
Writing Makefile for File::Find::Object
Writing MYMETA.yml and MYMETA.json
cp lib/File/Find/Object/PathComp.pm blib/lib/File/Find/Object/PathComp.pm
...
Manifying 4 pod documents
==> Starting check()...
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t ........ Old package separator "'" deprecated at /usr/share/perl5/site_perl/Test/More.pm line 414.
t/00-compile.t ........ ok
t/01ffo.t ............. Old package separator "'" deprecated at /usr/share/perl5/site_perl/Test/More.pm line 414.
Test::File version 1.993 required--this is only version 1.444 at t/01ffo.t line 12.
BEGIN failed--compilation aborted at t/01ffo.t line 12.
# Looks like your test exited with 255 before it could output anything.
t/01ffo.t ............. Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 4/4 subtests
...
Test Summary Report
-------------------
t/01ffo.t           (Wstat: 65280 (exited 255) Tests: 0 Failed: 0)
  Non-zero exit status: 255
  Parse errors: Bad plan.  You planned 4 tests but ran 0.
Files=7, Tests=79,  1 wallclock secs ( 0.05 usr  0.01 sys +  0.77 cusr  0.09 csys =  0.92 CPU)
Result: FAIL
Failed 1/7 test programs. 0/79 subtests failed.
make: *** [Makefile:899: test_dynamic] Error 255
==> ERROR: A failure occurred in check().
    Aborting...
Command 'sudo --user=#1000 --preserve-env=EDITOR -- makepkg --force' failed to execute.

guzzisti commented on 2023-12-06 07:30 (UTC)

@morgenstern Thanks! :)

morgenstern commented on 2023-12-04 22:30 (UTC)

@guzzisti happy to co-maintain/take over this package if you do not have time to update it - cheers.